Adding OpenWrt support for QNAP QHora-301W

i use 160Mhz with no problems so far

try the US reg

1 Like

I installed snapshot 9a205ee from rmandrad's repo into two of my ax3600 802.11s mesh nodes and also in one qnap mesh node, no problems observed yet. Keep you informed.

1 Like

I'm running the latest release (2022-8-18) from
reporting that everything that I use works fine except for the USB printing... looks like there is no kmod-usb-printer module for this router yet. For anyone just getting started, I followed these instructions and reflashed the sysupgrade image from the web GUI after completing the instructions. For whatever reason it wasn't saving nvram but the reflash fixed that. Also I had to build an initramfs image for the initial flash because the ones on github are missing losetup and opkg was missing something to install it.

Hope that this helps.

Hello again!
Since the last time I wrote I used the build from @robimarko-s repo as a daily driver on my qhora. Everything worked perfectly at 2.5G speeds, but after upgrading to the latest build, the 10G ports only advertise themselves as 1G and 10G ports. The auto negotiation doesn’t work for 2.5G nor 5G. Using a custom build with ethtool I can force 2.5G and everything works. Does anyone have an idea for a better fix?
Thanks in advance!

Did you try the flashing the new firmware for the ethernet ports? the mbn file on github linked in the instructions that I used? I posted a link to them in the post above yours. Direct link following -> Be sure to backup your mtd partition 10 before flashing it... I did not as I screwed up the command. If you have the stock firmware mbn could you please post it somewhere for me?

Also does anyone know what the default boot command(s) is? I should have checked that before editing it for the new firmware.

It's probably related to this:

This would mean that kernel is restricting the advertised speeds for whatever reason.

Mine is working correctly... My 10Gbps port is displaying correctly on my PC. Is there something in Openwrt that I should check too? I assume that it is correct as the link is negotiated at 10Gbps.

If you read his issue, 10G is working however 2.5 and 5G are not advertised

Thanks, I missed that.

Edit: I can confirm that @Airamek is correct. I just tried to use windows to force negotiation of 2.5 and 5 Gbps and it failed.

The issue was pretty much uncovered by the linked kernel commit as previously it was always advertised despite the kernel not advertising it.

I am looking to see where it is getting limited as NSS-DP quite literally just uses the generic phy_ethtool_get_link_ksettings and phy_ethtool_set_link_ksettings which just expose everything that PHY does.

I have found the code that parses the C45 supported capabilities, but not why are those not fully advertised

This newer image is working properly for people? (robimarko-2022-9-2)

I'm fairly sure I have a hardware issue, but looking to test another build before I have to pay for service shipping. I have problems consistently && It's easily the worst router I've ever owned... The stock QNap fw, and both 5.10 and 5.15 builds from a several months back + others built myself: all have non stop issues. Usually with https / encryption but in general I'm sending well over twice as many packets as receiving (not the case, running no public servers just leaching : so this is some packet loss that doesn't show / TCP retransmit multiple times)

( Yes, I've ensured ssdk sets registers and ethtool to disable tso : i still got errors especially in git when using openwrt. With the stock qnap openwrt fw I do not get the errors, but get the highest amount of packets resent. Things that transmit before updating show huge latency/lag sometimes.

Also, i see chat about 10G lan @ 5gbE : I had it working just fine at one point with a usb3.1 adapter it's showed the active link speed as 5gb/s on both sides, it does work if advertised.)

If anyone can shed some light I'm up for trying one last time.

Mildly put, both SSDK and NSS-DP are terrible drivers, no way around it

So, this is just to be expected? Probably QNap hardware itself is also just as bad?

I'd seen how much people wanted support for Xiaomi AX3600, and that this wone was similar with better specs, many people seem to have both working and are happy with them..

Should I just dump it and buy a 4x1GbE + 10GbE pcie nic(s),stick in cheapest pc that has thunderbolt and install pfsense? This is starting to look like the best choice now, if very expensive for a router ..

I'll certainly never buy another QNap product

I wish I knew whats expected and whats not, its all best effort.

I dont see what this has to do with Qnap HW and how its their fault?
They are using QSDK and things just work there

I wish I knew whats expected and whats not, its all best effort.

  • From openwrt && it's developers?

No expectations of any kind for an open source project.
I know exactly how much effort goes into something like this.
And I very much appreciate the effort of everyone involved.

  • From qnap?

A working product, what they advertised and I paid for.
Support/Service, if the thing can't be made to work, and they can't be bothered to support it: A return/refund. They will not return, only replace and refuse to pay for a return label as well.

I dont see what this has to do with qnap HW and how its their fault?

How it's qnap's fault: I'm not even sure how this is a question.
They sell something that's not finished and they don't support it at all..
Even if the [reference] driver is Qualcomm's the final device is not.
Even if the base design is a qcom [reference] design, the same holds true.
They modified openwrt to brand (and neuter), is not the fault of openwrt project..
So qnap cobbled a bunch of software choices together, and either failed at QoS tests or knowingly released a buggy pos.
I can't see who else would be at fault but them?

They are using QSDK and things just work there

The image in prev. post where send()'ing over 2x the packets as recv()'ing,
when in reality I download 5x as much as upload : is using qnap firmware.
I got tired of all the errors I had from the 5.10 and 5.15 builds, from git and other tools, from webpages that randomly refuse to load, or won't load images, and other things and have been using the latest qnap firmware for months.

I have one of these coming in tomorrow. I'll see how it performs.

My point is if it works with Qnap FW, what are they to blame for?

They are doing exactly as all of the ODMs, take the vendor SDK, butcher it some more and roll it.

1 Like

I don't really count it sending over 6x as many packets as it's supposed to and crazy latency as a result of them being resent [multiple times in a row] as 'working'. It's a terrible browsing experience, thus the 'worst router ever owned' comment.

Technically it operates, and some things work well enough, others are horrid.
eg, discord I get latency so bad from it resending the notification packet when typing starts/stops on https I thought I had malware that was keylogging.. encrypted https uplink is the worst culprit.

Wait, that happens under stock FW?