Adding OpenWrt support for QNAP QHora-301W

Just to report that the lan 4 labeled on the back of the router is internally tagged as eth0... also it seems I am unable to get an ip if I use any of the lan ports (1-4) from the isp

would there be anything on the dts that is causing this behavior ? only one specific port eth4 (10G) only gets an ip from the isp ... has anyone tried two wan's (wan & wanb) on this router?

@bitthief i had a go and build qnap on your repository

i have a few issues that i came across with qnap (also ax3600) namely i get a number of messages with the following

8.271971] bad descriptor dump for nss core = 0

and for all of the eth

nss-dp 3a001000.dp1 eth0: Data plane vsi assign failed

also get

 qca-nss 39400000.nss: Direct firmware load for qca-nss1.bin failed with error -2

in spite of having

-rw-r--r--    1 root     root          4476 Jul 28 12:38 regulatory.db
lrwxrwxrwx    1 root     root            33 Jul 28 12:38 qca-nss1.bin -> /lib/firmware/qca-nss1-retail.bin
-rw-r--r--    1 root     root        295196 Jul 28 12:38 qca-nss1-retail.bin
lrwxrwxrwx    1 root     root            33 Jul 28 12:38 qca-nss0.bin -> /lib/firmware/qca-nss0-retail.bin
-rw-r--r--    1 root     root        827584 Jul 28 12:38 qca-nss0-retail.bin

this could all be related to me missing merging some files from robi / yours can you help ? keen to test with nss + ecm ... ecm seems to init

34.713458] ECM init
[   34.713530] ECM database jhash random seed: 0xf77a996f
[   34.715644] ECM init complete

as nss-crypto

Has anyone noticed this warning on the Status->Firewall page

Is this something to be mindful of?

are you using mwan3 ? I do and I get a similar to yours. I don't think package has been migrated to nftables yet

Yes, I'm using mwan3. I do not remember seeing the warnings in my earlier builds that did not include mwan3.

It could be the case that the warnings are related to mwan3 which I can't really live without :slight_smile:

which ports are you using ? port 0 & 1? this seems to be the option on the stock firmware ... getting both 10g ports don't work even on the stock firmware

I am using port 0 and 1 at the moment.
I have been struggling with a more conservative port usage approach since yesterday. I tried assigning VLANs on the wan side as follows:

wan0 -> eth0.10
wan1 -> eth0.20
wan2 -> eth0.30
wan3 -> eth0.40

So that port 0 is trunk to a managed switch (Cisco SG200-08) but strange that only one of the wan interfaces would get assigned IP at a time. Not an issue from my ISP because when I use the physical ports eth0 - eth3, I am able to obtain 4x download /upload.

Note - VLANs work with the same switch on the LAN side, so should not be an issue with the switch, I even tested with a Netgear managed switch and obtained the same outcome.

I have since given up with the above VLAN approach to use only 2 port (2 x download/upload), but will appreciate some info if you are able to make any progress on the wan VLAN approach :slight_smile:

1 Like

Great work by @robimarko and @kirdes and others for getting things working for this QNAP QHora-301W device.

I was wondering, has someone already done any power measurements on these?
like, idle consumption without cables connected, idle with 2x 1GbE connected, idle with 2x 10GbE connected for example? And maybe some when doing benchmarks?
Would be interesting to know I think.

Doubt anybody did that

According to review it's 12 watts with both 10G links active.

I'm guessing a single 10G link is about 2- 3 watts alone.

I found some documentation on the ssdk_sh command - hope it helps

there is also a FAQ with examples

further info on using ethtool with aquantia


I've been running a build from ipq807x-5.15-pr branch for a few days and noticed the following:

1.) The 5GHZ radio goes offline after a few hours, it usually becomes available after a restart of the Generic 802.11acaxn device.

2.) The 2 x10G ports appear to support 1G/10G. When connected to a 5G NIC, eth4 negotiates and connects at 1G speed while eth5 does not connect at all, probably due to a known issue with eth5 which does not support 1G but 5G worked earlier on 5.10. When connected to 10G NIC, both ports (eth4 and eth5) work just fine. I have not tested 2.5G connection yet.

Does anyone know what logs I can look at to understand what actually happens to the 5GHZ WIFI? System/Kernel logs do not contain useful information.

Regarding the 2 x 10G ports, has any one here had a similar observation and is there a workaround?

I never had a problem with the 5 Ghz wifi, what does the log say? I guess it's related to DFS....

Regarding the 10G ports:

Yes I was having the same problem. After the boot, 5G and 2.5G modes are missing in the advertised modes (you can see that with "ethtool eth4/5)
Though the 5G and 2.5G are still in the supported modes.


ethtool -s eth4 advertise 18000000E102C

(18000000E102C is the sum of all supported modes in hex, see - advertise N)

Now 5G and 2.5G modes are back in the advertised modes.

I don't know the reason for this behaviour, maybe there was a change in the aquantia driver.


Thanks a bunch @kirdes

Hmm, that is a weird one.

If they arent being advertised, its probably getting restricted by the kernel/phylink somewhere.

Maybe this change is the reason:

If I have some time later, i can revert that change and check if the 10G ports advertising 2.5G and 5G by default.

That commit probably only exposes the issue, it itself only asks Phylink whether those are allowed and if not stops the advertisement in HW.

You are right about the DFS channel, my Wifi got disabled again. This time I see the following on the logs kernel: [ .....] device wlan0 left promiscuous mode kernel: [ .....] br-lan: port 3(wlan0) entered disabled state
daemon.notice netifd: Network device 'wlan0' link is down
daemon.notice hostapd: wlan0: interface state DISABLED->COUNTRY_UPDATE
daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
daemon.err hostapd: could not get valid channel
daemon.notice hostapd: wlan0: interface state HT_SCAN->DFS kernel: [ .....] br-lan: port 3(wlan0) entered disabled state

Although I'm located in the EU, I had to set my 5GHz Wifi config as shown below.
My country code (SE) never works:

Country code - IN India, Operation frequency - AX 100(5500 Mhz) 160 Mhz

Would you know what configuration to use in the EU that works and avoids the DFS channel issue.

Don't use 160Mhz wide channels, it's not possible to avoid DFS then.

1 Like

Hi everyone

thx to @bitthief we now have a repo that fully supports the qca nss/ecm/crypto

here's his repo -

I am currently running it for a few days after minor changes on the qnap dts to include his nss dtsi

i pushed my own changes to github

Feel free to try it ... either using @bitthief repo or mine (note this is for my own use case ... i don't use ppoe and a very straightforward use case of house router ... although i am using mwan3 to up the restriction of my isp provider of 1gb lan router).

just personally want to say thank you to @bitthief for all his efforts.