Adding OpenWrt support for QNAP QHora-301W

That patch is just a revert, it needs to get properly fixed.

Good luck with NSS

1 Like

True but here is a tentative which actually works (at least me).

There's a PR for fixing it. No idea if it really helps.


And yeah, that works and allows advertising 2500BaseT

1 Like

For a similar Buffalo WXR-5950AX12 (also has 2x10G), does the fix applies to it as well?


All i performed a Sysupgrade (AgustinLorenzo build from here IPQ807X NSS Build - #348 by strxno) not the first time and up until now all have been ok across all 3 of my QNAP devices but on the latest update, sadly 1 of of my 3 devices isn't coming back-up and might be bricked, Power LED is GREEN and Status LED starts off Green before turning flashing RED.

I cant get an IP and thus cant SSH and I've tried to see is a way to revert back to Stock firmware, but i cant find any way to go back using USB + firmware, Reset (3 sec or 10 Sec) does not work. so i was wondering as you all have QNAP 301W if any of you know a way to force the HW to revert back to Stock (similar to a linksys etc) ?

1 Like

You need to open the router and use the serial console to revert the boot partition (see here and here).

1 Like

What device/gadget should I get in order to connect to the on-board serial pins.

You will need a serial cable to connect to the serial pins in the router.
You can find more details about this cable at Serial Cables page on Openwrt

EDIT (1):
The best is FDTI cable, but they are a bit expensive

1 Like

I suppose this one should do the job.

I bought two different cables from AliExpress in the past one of them was similar to the one you shared its link, however it never worked, other worked on Linux but did not work on windows.

I ended up with FTDI cable at the end of the day.

1 Like

Without NSS offloading should we expect full LAN (no NAT) performance from 10G ports.

I've tried the procedure for flashing OpenWrt without opening the router from @MusikJunk . I've used @robimarko sysupgrade image from his repo.
It was successfully flashed and booted. I've started to explore the settings. I couldn't connect to the 2.4GHz wlan. Cannot say the reason for it. The 5G worked OK. The Wlan LED was not working.

I was following this and the other thread about IPQ807x NSS Build. I decided to try latest @AgustinLorenzo NSS build.
I've tried to upgrade from web interface using the sysupgrade firmware image - 2023-06-12-2358.
I've got a warning that the device 301W is supported by the image but the image version is not compatible with current version (1.0 -> 1.1) and it was recommended to upgrade without keeping the settings.
I've done it using the force upgrade option.
Unfortunately the router couldn't boot anymore. When I power on the device only the first and second LEDs are on, then the second LED flashes for several seconds and turns off and only the first LED remains on. And that's it.
Probably I've made a mistake but I don't understand what I did wrong. Probably I will have to open it to use the serial console.
Can anyone help.

I would start by doing exactly what you said and connecting up serial

you tried fail safe mode?

maybe it kept the config for some reason.

1 Like

I had that issue once when loading a saved config. Held the reset button on the back while booting until there was rapid flashing. Was not able to get a IP and left it on. Checked again after a couple hours and it just started working again.

1 Like

Same boat, I brick my ax6 after force upgrade. I need set to official firmware first than build again using snapshot openwrt-ipq807x-generic-xiaomi_ax6-initramfs-nand-factory.ubi, follow openwrt guide.

After couple time test using latest snapshot firmware working normal, than I try install AgustinLorenzo build, work well no big issue, only issue when install mwan3 package

Coz my isp only 100mbps I switch back to latest snapshot version, I prefer mwan3 than nss package.

1 Like

If I press the reset button continuously nothing happens.
If I press the reset button during the fast blinking of the LED, the LED just continues blinking infinitely.
The LEDs of the LAN ports don't work no matter if I connect a cable to them.
Can anyone that opened the device give me a clue how to easily remove the rubber pads. Are they glued to the plastic. They seem firmly attached to it.

Yes, the rubber pads are glued. You can try to insert a flat screwdriver between the pads and the shell to detach them.

1 Like

Try setting a static ip.


Do a continuous ping on and after the fast blinking and let it sit for a while. The LED on the LAN ports also didn't show up for a while.