IPQ807X NSS Build

Thanks for Your work, it works nice on my dynalink, when i got back to my home next week i can play with new image.

Thx! Installing now.

Updated to latest build, thanks @AgustinLorenzo, I still saw the SSL issue. It might be a little better, I don't know for sure: I am not testing scientifically enough. I don't fully understand what is going on, is there a issue tracker for that, somewhere?

all good i got no ssl error too
but it feels more stable without packet steering and software offloading i disabled those
also my isp requires 1492 for mtu size this may be what me apart from the rest of people i don't know
not many people sets their mtu to 1492 i suppose

Same here - if I turn off software offloading, no SSL errors. But with it enabled they are still present.
I'm using wired connection.

Anyone know why I am getting low (compared to stock) upload speeds using OpenWRT on Xiaomi AX3600 with AgustinLorenzo builds? On stock I was able to reach approx 900-940mbps upload via speedtest.net, but now I am getting barely 150-200mbps on the latest build. I have tried this on multiple builds, but I seem to have the same issue regardless.

EDIT: forgot to mention this is on Wi-Fi.

1 Like

in my case, the whole wifi is fu**ed up ;/ I bought this model to modernize my network but it is worse than on the old EA8500 linksys

2 Likes

helo

i just try this firmware compare with SNAPSHOT r23409-984786a2f7
i don't see any different do test from local lan and from isp give same result

lan speed from my nas to my pc around D/U 980Mbps
wifi speed test from nas to my phone wifi 5AC 80mhz around D/U 340Mbps
cpu load is same with both firmware.

isp test both pc / wifi give same result around 100Mpbs. (my package is 100mbps)

below nss package i found from snapshot firmware.

Hi,
you will only see difference if you have over 600Mbps package. On OpenWrt without NSS you can get max 650Mbps, on this one you will get full speed - over 900Mbps (isp of course).

1 Like

oh ok too bad my isp only 100mbps, i think for me snapshot still ok.

i must wait for another 10years to enjoy isp with 1Gbps

Yes, but what if i have fast home network and i want fast transfer from internal network to wlan client?

No idea, you have to test this yourself. As it is straightforward to switch from snapshot build to this one it should not be an issue. I'm using this build as I have 1Gbps isp connection.

@AgustinLorenzo I've used your latest NSS build sysupgrade image for QHora-301W to upgrade from robimarko's build that I installed previously successfully. I've described the details here. The router no longer boots. Is your build compatible for sysupgrade.

ok... for me helped change 160MHz to 80MHz... now wifi is working better :slight_smile:

Does anyone know what package/s should be installed in order to see CPU data (CPU and NSS load, frequency and temperature) as on the image below.


Image was taken from here.

you can use htop ...also you can nssinfo (make sure you modprobe qca-nss-netlink before) that will show you something like this

                        NSS STATS
Stats for core 0
Node         RX Pkts       TX Pkts       Drops     Exceptions
----         -------       -------       -----     ----------
eth_rx       6,364,476     6,364,476     0         9,039
ipv4         6,364,452     4,697,664     0         1,666,788
ipv6         24            0             0         24
lso_rx       10,790        31,992        0
n2h          29,399,498    3,086,065     0

Stats for core 1
Node         RX Pkts       TX Pkts       Drops     Exceptions
----         -------       -------       -----     ----------
n2h          5,962,716     127           0
 buf_cmd     0             2,176,472
 buf_emty    912,949       282,075
 buf_pkt     1,675,851     909,720
 status_sync 0

1 Like

Thank you. I already use htop but nssinfo is helpful somewhat too.
As I've had big troubles switching between NSS and Non-NSS builds preventing access to the QHora-301W, I strongly recommend anyone that has an intention to do so to read my post first.
Luckily I've recovered from the unpleasant situation.
Any advises how to switch safely to a NSS build?

so I started porting the nss build to 6.1 using as a baseline for this work of course the main openwrt repo and the qsdk AU_LINUX_QSDK_NHSS.QSDK.12.4.5.R1_TARGET_ALL.12.4.501.052.016

The qsdk version is supporting 6.1 however not ipq807x but ongoing work for the upcoming qualcomm wifi7 devices.

I managed to get nss-drv and nss-ecm running on openwrt 6.1.35

There is a lot of work still namely all of the other qca modules but also some workarounds most crucially i had to add the last two parameters so the kernel could compile successfully.

CONFIG_EXTRA_OPTIMIZATION="-fno-caller-saves -fno-plt -Wno-unused-variable -Wno-discarded-qualifiers"

to the openwrt .config (or via menuconfig)

the repo & branch https://github.com/rmandrad/openwrt/tree/qualcommax-nss-6.1
the nss packages repo & branch https://github.com/rmandrad/nss-packages/tree/main-6.1

finally make sure you ubiformat the factory image (to mtd12 or mtd13) ... check the wiki instructions in doubt. sysupgrade didn't worked for me.

If there is any bandwitdh on your side go ahead fork the repos and fix all of the other packages ... refer to the qsdk as there is a lot of patches one can reuse / help fix

note - i tested on the xiaomi ax3600

BEWARE - anything of what I have done is not supported so do it at your own risk.

1 Like

Is this suitable for QHora-301W?

all of the ipq807x subtarget is suitable

1 Like