Adding a Wireless AP / BPI-R3

I'm trying to add a wireless AP. It seems simple enough, I've read the instructions and forum posts, but I seem to be missing something. Here is what I've done.

I have 2 vLAN networks. LAN2 cannot access LAN1, but both can access the WAN. I have lots of devices on both, and everything works as intended.

I want to attach a wireless access point to LAN2 so I clicked on ADD for the radio I want and configured it this way:

Mode: Access Point
Network: lan2

Lan2 has DHCP enabled (and it works for all the wired devices). However, when I attempt to connect to the wifi network I'm not getting assigned an IP.

Since that didn't work I created a NEW interface / network called wireless, with DHCP enabled, that forwards traffic to LAN2 & WAN. I added the wireless connection to that network but still had the same issue.

I've tried rebooting individual services, the radio, the interfaces, and the overall device. I've also tried connecting from an Android device & ios device. The Android won't connect at all, the ios device will connect with a 169 IP address.

To do some further testing I fixed the IP address on an Android device. If I do that I can connect to the network but I can't access any of the devices on that network or the WAN (which lan2 has access to).

I'm not sure what else to try. Can anyone help?

Two more things I've tried:

Adding the AP to LAN1 - Same issue
Adding the AP to WAN - I can connect, get an IP out of the LAN1 & LAN2 range, and can access the internet. I cannot access LAN1 or LAN2 devices (I need access to LAN2).