Add VLAN 835 to WAN and WAN6 on ER-X with 21.02 and DSA

I'm changing ISP soon, the new ISP will give me an external ONT that I will connect to my ER-X router with OpenWRT 21.02 with DSA.
I need to set WAN (PPPoE) and WAN6 (DHCP6) both with VLAN 835

This is the network file with the default names of devices and interfaces gave by the default configuration after flash OpenWRT (seams that standard DSA names are not used on ER-X but this works with my old ISP that don't use VLAN).

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd73:31de:3663::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth2'
	list ports 'eth3'
	list ports 'eth4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0' # change to option device 'eth0.835' ?
	option proto 'pppoe'
	option username 'username'
	option password 'password'
	option ipv6 'auto'

config interface 'wan6'
	option device 'eth0' # change to option device 'eth0.835' ?
	option proto 'none'  # then configure DHCP6

How to change this network configuration to add VLAN 835 to WAN and WAN6?

Is correct to add just .835 at end in this way?

config interface 'wan'
	option device 'eth0.835'
	
config interface 'wan6'
	option device 'eth0.835'

Do I have to update also other configuration files like dhcp, firewall and other to change?

Thanks

You can do it that way (and I probably would, especially if we're 'just' talking about the WAN interface), or employ bridge VLAN filtering (following the DSA guides).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.