Add support for Xiaomi AX1800 Wifi 6 router

The AX1800 mesh very easily but there doesn't seem to be any controls.
Even from command line I cannot see much available.

It worked fine for me when I plugged two AX1800 together using LAN from AX1800 set to router (in 3.0.34 firmware) and WAN on the other unit.
The Chinese Firmware (1.0.44) works even better and doesn't require the main unit to work in router mode.. I had it set to AP mode. It was able to setup another AX1800 via wired connection into mesh without using the normal recommended method.
Note also mesh via wifi is probably not gaining you anything over just using AP mode.

Also i can set the wifi power higher?

Yes but you need to get permanent SSH access and set CountryCode and power levels yourself. It is not easy unless you have another router that can be flashed to OpenWrt assuming you want to keep the international firmware 3.0.34 which unfortunately has not been released to public.

1 Like

I have a few question for the forum.
Thanks for all the info. I bought 3 AX1800 to try out as AP or mesh in place of some of the big name commerical units which don't suit lots of people.
I opened SSH using an old OpenWRT router I had saved for just such a purpose.
Made the SSH permanent by modifying the mtd9 bdata area.. using Oded.dev method with a few kinks in the system worked out from Chinese originals.
https://oded.dev/2020/11/30/AX3600-1/
The header.py script failed continually. On both Mac and Linux machine from a friend. Line 158 error. So just edited it directly using hexfiend.

Question 1
It all worked great.. for first few resets. Change of setup etc. Telnet in and got SSH working again each time. Then something happened and the password stopped working. Going right through the opening SSH again did not work. The password for the router was changed.
Has anyone experienced this?
I searched and nobody else has reported the problem I can see.
To fix it I loaded latest Chinese firmware.. 1.0.44 and the password came back to Xiaomi default.
So far another AX1800 has suffered the same problem. And I was forced to flash to 1.0.44 on that as well.
If we had a copy of the 3.0.34 firmware to flash it would not be an issue.. but until Xiaomi releases an update I am stuck. The Chinese firmware is fine.. better in fact in some of the Mesh setup as per question above.

Question 2
Did anyone flash back to 3.0.44 firmware using any method??
I have an AX3600 on order to play with as it seems a better unit to work with. So I might try flashing partitions on that one and hopefully can figure out which is what.
I made a copy of all the flash partitions.. except the last two which are active (mtd24,25). So I have a copy of mtd0 to mtd23 but not from either of the ones now on Chinese firmware.. I was in the process of getting its firmware when the password problem happened.

1 Like

I also use the same, the ap is plugged by wan, and the other is plugged by lan, but they connect each other by wifi.
How i can setup to connect by cable?

There is any tutorial to ssh access?

Plug the mesh node via its WAN port. I think using LAN is causing it to behave as if you are creating a wireless bridge.

Out of the three original units only one is left that has 3.0.34 firmware but when I swapped that firmware to 1.0.44 (chinese version) it did allow mesh from AP mode.. whereas the international firmware only allowed mesh from full router mode.

Tell me what firmware you are running on AP unit and mesh node unit and I can run a test to see if it works.

The whole of this thread has the topic of how to get SSH access.. sorry but you need to read it. There is no single tutorial site unless you use Chinese firmware and once there you cannot go back.. but it is easy from 1.0.17.
See the youtube link near the top.

The only way to get ssh access with international firmware is using the second true OpenWRT router... You can probably pickup something second hand for a few dollars.
I followed this exactly.. It is for the Redmi AX6 but the AX5 is close enough to work. Don't expect instant success .. it takes loads of patience to get the sequence exactly right. At each step you must get the right response from your browser connection.. otherwise go back and start over.. which means every time you will get a new stok key.
Note a computer with both ethernet and wifi network adapters makes life a lot easier.

That gives you SSH but it is not permanent. It will survive reboots but not reset, firmware update etc.
So the second bit means you need to follow the link I gave in the second post to Oded.dev and here things start getting complicated because a key part of his method simply did not work. If you get the first part done post back and I can perhaps help a bit with the second bit.
Note that this led to me having to flash Chinese firmware as it also lost the password in two of the units.

Did you get dump of global firmware? Sorry, I'm not quite sure I'm understood the sentence right. If you did, mtd22 and mtd23 are the kernel and the system partition images and all you need to create restore image. System partition dump has a lot of FF at the end and probably needs to be stripped (or maybe not),
then you need combine kernel and system partition files (with --data option) with ubinize.sh script from here. And then you can flash it via ssh with xqflash or some other way.

Yes.. the global firmware is still working on one of the AX1800 and yes mtd22 and mtd23 are listed as

mtd22: 003a2000 0001f000 "kernel"
mtd23: 01303000 0001f000 "ubi_rootfs"

So that makes sense.. thanks for the link.. will check it out.

Hello

i have the global version firmvare on is.
if i install the china version, app still working?
english language is available?
if i put the second router in wan the internet stop working, like some ip problem, or i dont know.

On the global version the option to select mesh disappears when you select AP mode.. so I don't understand how you have it configured on the main unit. Are you running it in router but double NAT? If that is the case is your wired network plugged ONLY into the Xiaomi or still into your main router because that will totally mess things up.
For your situation reset the second unit and configure it in AP mode as well.. configure it with the identical SSID and passwords to your other unit.
You lose nothing... you will get handoff and all the other goodies of mesh without the pain. But you will have to check your main router NOT the Xiaomi for all the clients and it will not show what AP they are connected to.

Using the Chinese version firmware the mesh works much better. You just use google translate to see the English version.. but since Xiaomi routers show you next to zero info it will all still be much the same.

The main router is just set as dynamic ip internet, then i add the second on as mesh.

if i install the china version the wifi power will be higher?

No, because it is set to EU. You use the Chinese version to open SSH so you can change power and country settings to match your own.
And fix your issue with failure of connection over ethernet for backhaul.

Do you have any success in dumping/flashing global firmware? If you need volounteer for test, I'm ready to assist.

Wow, that would be great. I looked at the site you referenced but it is going to take a bit of absorbing as it is outside my experience.
Can I email you? How? New user here.

Bellcow did a great job and using the dump from firmware 3.0.34 it is possible to flash any version of the AX1800 back to 3.0.34 with the proviso you must do it via SSH which is easy. Make sure you have made SSH permanent by editing mtd9 as per info from oded.dev which I referenced above. SSH will be lost when you update but with permanent access to telnet it is easy to get ssh back again.
So that makes it easy?? to get SSH via the earlier Chinese firmware.. make it permanent then go back to International firmware.

Hey guys, i habe a device which seems to be a clone of Xiaomi AX1800 it is called Outengda CAX840-openwrt.

It seems like 128 MB NANA like in Xiaomi and there is an OpenWRT Chaos Calmer 15.05 running:

Here is my dmesg:

i have a problem with mesh AX5 china firmware
my country is singapore which only support 5ghz from channel 149 above

before using mesh, i using 5ghz 149 channel

but after setting mesh ,channel 149 above become disappear
only channel 36-48 show

with this problem , i cant using mesh with 5ghz channel because my phone not supported 36-48 channel

any solution ?
thanks

The Xiaomi routers have NO mesh controls. It is well neigh impossible to use them in specific ways if there are limitations. My recommendation is to read the thread carefully.. or suitable Chinese references and open SSH so you can set the wifi correctly. Either to CountryCode=Singapore or just set the channel in command line. Alternatively, running ethernet and using AP or Repeater mode (Xiaomi use either term interchangeably) works much better than mesh while allowing control over channels even in default settings.

thanks for reply and advice

im already fix with some trick
edit 5 ghz channel to 149 with browser inspector
now 5Ghz become visible

but i dont know if 5ghz mesh stable or not

Global 3.0.34 firmware for AX5 aka AX1800 with ssh root access.
Download https://www.mediafire.com/file/f2fynnu4kf0gtxd/ra67-raw-img-txpmax-ssh.zip/file

  1. Copy fw and xqflash script to /tmp
  2. Via SSH flash it:
cd /tmp
chmod 755 xqflash
./xqflash ra67-raw-img_rootfix_3.0.34.bin
reboot
  1. To do hard physical reset.
    After hard physical reset ssh root access is:
Login - root
Password - password
  1. Set WiFi power to fullest:
nvram set CountryCode=CN
uci set wireless.wifi0.country=CN
uci set wireless.wifi1.country=CN
uci commit wireless
nvram set wl0_txpower=0
nvram set wl1_txpower=0
nvram commit
wifi reload &> /dev/null
iwconfig | grep "Tx-Power"

P.S. English language by default.

1 Like

Amazing work @Blaze, thank you!

Anybody tried this OpenWRT firmware https://github.com/Lvellios/OpenWrt-AX5-AX1800/releases/ for AX5 and AX1800?