Add support for TP-Link RE450 v3

Is there a release with Luci embedded?

Hello,

new user of openwrt here, I hesitated quite a bit before trying so I thought I'd share my experience :slight_smile:

Before switching I had a lot of problems with the RE450, the network was very unstable, now I've been using OpenWrt for a week and it's day and nigh. Not perfect, I still have a few disconnections but it is much much better. Also I think my issues are more related to the main AP which is an android phone rather than openwrt.

The only drawback I would say is that when you install, you only have ssh, luci is not installed, internet is not available, so I had to mess with config files (notably /etc/config/wireless) to connect to my wifi net, then install luci with opkg, then it's easier through the interface.

Can you enable the equivalence to stock firmware "High Speed", which it receives at 5ghz and transmits only on 2.4ghz disabling the bottleneck between receive/transmit?

I know on openwrt this can be done, but I have tried this feature on other wireless repeater I own, and results weren't that great.

Hi everybody,

I flashed the latest snapshot (r14900-acb336235c) on my RE450 v3.

I configured WDS on my 5GHz AP on my main router (which is an Archer C7 v5 running OpenWrt) and a WDS Client (STA) on my RE450 on 5GHz.
I can access it through SSH wireless.

When I try to create a 5GHz AP, it seems to be working but the network (SSID: Test) is not emit. No problem creating a 2.4GHz AP.

Thanks in advance for your help

Regards

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option channel '40'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option ssid 'HomeWifi'
        option encryption 'psk2'
        option key 'passphrase'
        option wds '1'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Test'
        option network 'lan'
        option encryption 'psk2'
        option key 'testpassphrase'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Test_2.4Ghz'
        option encryption 'psk2'
        option key 'testpassphrase'
        option network 'lan'

Does anyone here knows when RE450 V3 will get stable status and luci embedded?

I just installed the 19th Dec release for re450v3 and it bricked the device.

@uknh Did you manage to get out of the flashing lights state? What did you have to do?

Ok, I shorted the two resistors and now I've got a serial prompt. Just need to compile an older version of openwrt to see what broke. I have a feeling it is this commit:


as I haven't seen any other recent commits reference re450.

Looks like it was a faulty device. Another re450v3 worked. It might've been the way I flashed it. The first one I did through the UI, the second one I did by booting the second device through serial/tftp and flashing it using the sysupgrade method.

Commands to remind me how to later:

setenv serverip 192.168.2.1
setenv ipaddr 192.168.2.50
tftp 0x81000000 openwrt-ath79-generic-tplink_re450-v3-initramfs-kernel.bin
boot 0x81000000
sysupgrade -n openwrt-ath79-generic-tplink_re450-v3-squashfs-sysupgrade.bin

I have had V3 for about 6 months. With the original firmware I had no problems, then I wanted to install openwrt and despite it being loaded correctly there were some operating problems. It was not a good experience if we consider that it does not have dual firmware and putting the original firmware back is risky and complex. If you do a search you will see that many people have bricked the devices.

Hey @stevennausak,

Thanks for letting me know. Would you mind listing the issues you know and have heard about? There are so many messages on this forum :sweat_smile:

The main problem was that after putting WRT it could not connect to the 5Ghz Network from an Archer C7 (same brand) despite seeing the SSID.Now I no longer have either the Archer or the RE450 and I have no more problems.

@nebster here the search

Still no release with Luci embedded?

tolqen,

Thanks a lot, can you please upload a stock firmware already converted to openWrt sysupgrade file, I tell you this because I myself, and probably some users from this forum, don't know how to use Linux, only Windows based operating systems.

This is a great discovery.

Can anyone please upload stock firmware from RE450 using tolqen method, I don't have Linux or MacOS

Thanks

I had a similar issue, and following the steps from @tolqen I managed to reset my RE450v3 to the native firmware.

At the link below you can find the image I've used to reset my device. After you flash this image according to the steps above, you are back to the last settings you had on the original firmware.

RE450v3 orig firmware - reset from OpenWRT

Good luck!

2 Likes

Thanks, very much, after this we can easily revert to original firmwmare and try openwrt with peace of mind :slightly_smiling_face:

This topic was intended for adding support for this specific device.
Since official snapshot images are available since quite a while now, I will set a timer for this topic to close.

Why?

Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier.

Therefore: Please open new topics for any open issues with this device.

Thanks!

Thanks, for the team for adding support to this router, and also providing stock firmware ported for Openwrt standards, just wondering if new OpenWrt 21.02 will came with stable release to this router and Luci embedded.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.