Add support for Linksys EA6350 v3

Hey forum, I was curious if there were any overclocking guides for this router processor? Any pointers on how to do so if there aren't any guides?

Please open a new topic for this question.

I went ahead and ordered one so lets hope it's version 3. :grinning:

Can the latest 19.07 snapshot be installed via the web interface as this is my first time?

This is the device page
https://openwrt.org/toh/linksys/linksys_ea6350_v3

It looks like you can simply flash from web.

And you are correct to install 19.07.

1 Like

Guide: don't do it outside of testing sandbox environment. If you ask for guides then you mostly are not someone who should do it.

The possible performance gain is near to irrelevant for real time applications but the stability problems for your network service and reduced device longevity is there all the time.

2 Likes

Like i said above I was curious. I am curious how the performance would be with Cake enabled.

I have to disagree with you on this. During my CompSci degree this was the best way for me of learning a new language is looking a guides and examples.

I figured since I have a backup pfsense box I'll be prepared for the worst.

At least when you screw up a computer program, generally all that happens is that it doesn't run.

If you screw up overclocking, your SoC is dead. Permanently. Or your memory fails. Permanently.

These devices are designed from silicon, packaging, and device to meet specs, not exceed them, and at the lowest possible cost. Higher clock rates mean higher power dissipation, which needs to be extracted from the silicon, and even from within the silicon. Higher clock rates often require higher voltages -- no BIOS to change the supply rails. Higher voltages will, at some point, break down the junctions or insulating layers in the chip. These are devices clocked at rates where electron transition time becomes critical. "Wires" aren't wires at 1 GHz. Signal propagation often isn't linear with clock rate. This ain't your over-built P90 that you can clock to 120 Mhz.

Overclocking can, at best, gain you a few percent. What you see in actual performance gain is usually significantly less than the increase in clock rate.

Yes, this really is a "if you have to ask, you shouldn't try" kind of thing, unless the $75 or more you'd spend is "throw-away" money for you.

5 Likes

What do you want to learn?

Let's do some math as you don't believe me.

Add support for Linksys EA6350 v3 - #348 by bill888 gives about 30 Mbit/s OpenVPN throughput on EA6350 v3.

Let's assume you can reach 20% overclock with reasonable stability. Let's also assume the OpenVPN task fits in the CPU cache and scales 66% with clock speed increases.

Then you might get a performance of 30 Mbit/s stock and 34 Mbit/s overclocked OpenVPN throughput. But at the same time you could see stability problems.

I would suggest something else. IF you are able to route 100% of line speed through your device: no overclocking necessary. Don't do it as it gets you nothing but it will produce problems. IF not: buy a more powerful router which is able to reach your line speed.

Overclocking could be useful, if you earn money out of more performance and you are already working with the fastest available stock speed devices. But not if you run a low end device and just want to play, without a reason to run into stability problems.

There is another performance dimension: latency. But that's a different story and overclocking cheap routers would also be one of the last things I would consider to get a lower latency.

Another thing would also be the case if you wouldn't do real time processing, but you would do computation tasks that take minutes or hours to complete. Let's assume for example your task takes one hour to complete on stock clock speed and again your task is heavily CPU speed bound and benefits 66% of more CPU clock speed. Then it could finish not in 60 minutes, but in 53 minutes.

The price for this benefit would be that you would need to check a lot more for consistency, as you could not be sure the result is correct on 20% overclock. I guess it might often be the case that it is not worth the increase in performance.

Also: I would have expected you to get to this conclusion by yourself if you own a CompSci degree.

1 Like

Woooohooo it's a V3 :grinning:

Thanks again Pilot6 for the help and sorry all for cluttering the Dev section, i'll move over to install section.

Hi is it possible to split the 4 port switch into 2 vlans group on the linksys ea6350v3?

config interface 'lan'                
        option ifname 'eth0.1'                     
        option type 'bridge'                       
        option proto 'static'                      
        option ipaddr '192.168.3.1'                
        option netmask '255.255.255.0'             
        option dns '1.1.1.1 1.0.0.1'               
        option peerdns '0'                         
        option ip6assign '60'                      
                                                   
config interface 'lan2'                            
        option ifname 'eth0.4'                     
        option type 'bridge'                       
        option proto 'static'                      
        option ipaddr '192.168.4.1'                
        option netmask '255.255.255.0'             
        option dns '1.1.1.1 1.0.0.1'               
        option peerdns '0'                         
        option ip6assign '60'      
                
config switch_vlan            
        option device 'switch0'
        option vlan '1'        
        option ports '0t 1 2'  
        option vid '1'         
                               
config switch_vlan             
        option device 'switch0'
        option vlan '4'        
        option ports '0t 3 4'  
        option vid '4'

Is Wan Mac override working for anyone as it's not working for me , Only Lan Mac override is working but that no use to me as i need to change Wan to get online.

I'm not sure if this is a Luci issue or a 19.07 firmware issue?

Thanks

@sammo see

1 Like

This device was merged in January, 2019 and snapshots have been available since that time.

This was a development thread.

For support questions, please search for existing answers and, if none found, open a new thread in the appropriate Installing and Using OpenWrt section.

Can anyone give me instructions on how to downgrade to either the original snapshot or stock? Since updating my coverage is terrible and I regularly get internet connection issues with the 5g connection. It was much better on the original snapshot release and I don't want to make a mess of things when downgrading.

1 Like

What are you calling "original snapshot"? You can flash any Openwrt sysupgrade using Web GUI.

I'm referring to the original OpenWRT fw for this device, openwrt-ipq40xx-linksys_ea6350v3-squashfs-factory. I tried just flashing this over the top of the current 19.07 and it soft bricked. I had to use the recovery option to return to the last installed fw.

Another query - is uPnP and/or NAT-PMP available on this router? The reason I'm asking is, I have a WD MyCloud Home network storage device which uses a version of Plex server to stream media both locally and remotely. But it is not connecting securely and looking through the Plex documentation, it says to check if either of these services is enabled in the router's firmware. Looking through the firmware, I can't find any reference to either service.

Have you seen this thread describing how to revert to Linksys FW using a prebuilt sysupgrade image?
https://forum.openwrt.org/t/ea6350-v3-revert-back-to-stock-factory-firmware/42581/44

2 Likes

No I hadn't. I thought NoTengoBattery had taken his github repository down after his initial work on the router. So thank you for the link.

Am I right in thinking that I can switch between OEM and OpenWRT firmware by turning the router on and off three times?

First off, anything but basic routing and management is not pre-installed by OpenWrt. You need to install packages for UPnP (which many consider inherently insecure), VPN, and the like.

Yes, three failed boots will change the firmware to be booted to the other one. If you have only installed once, then it would be OEM firmware.

Finally, this was a development thread, not a support thread. Right above your first post

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.