Add support for Linksys EA6350 v3

Woooohooo it's a V3 :grinning:

Thanks again Pilot6 for the help and sorry all for cluttering the Dev section, i'll move over to install section.

Hi is it possible to split the 4 port switch into 2 vlans group on the linksys ea6350v3?

config interface 'lan'                
        option ifname 'eth0.1'                     
        option type 'bridge'                       
        option proto 'static'                      
        option ipaddr '192.168.3.1'                
        option netmask '255.255.255.0'             
        option dns '1.1.1.1 1.0.0.1'               
        option peerdns '0'                         
        option ip6assign '60'                      
                                                   
config interface 'lan2'                            
        option ifname 'eth0.4'                     
        option type 'bridge'                       
        option proto 'static'                      
        option ipaddr '192.168.4.1'                
        option netmask '255.255.255.0'             
        option dns '1.1.1.1 1.0.0.1'               
        option peerdns '0'                         
        option ip6assign '60'      
                
config switch_vlan            
        option device 'switch0'
        option vlan '1'        
        option ports '0t 1 2'  
        option vid '1'         
                               
config switch_vlan             
        option device 'switch0'
        option vlan '4'        
        option ports '0t 3 4'  
        option vid '4'

Is Wan Mac override working for anyone as it's not working for me , Only Lan Mac override is working but that no use to me as i need to change Wan to get online.

I'm not sure if this is a Luci issue or a 19.07 firmware issue?

Thanks

@sammo see

1 Like

This device was merged in January, 2019 and snapshots have been available since that time.

This was a development thread.

For support questions, please search for existing answers and, if none found, open a new thread in the appropriate Installing and Using OpenWrt section.

Can anyone give me instructions on how to downgrade to either the original snapshot or stock? Since updating my coverage is terrible and I regularly get internet connection issues with the 5g connection. It was much better on the original snapshot release and I don't want to make a mess of things when downgrading.

1 Like

What are you calling "original snapshot"? You can flash any Openwrt sysupgrade using Web GUI.

I'm referring to the original OpenWRT fw for this device, openwrt-ipq40xx-linksys_ea6350v3-squashfs-factory. I tried just flashing this over the top of the current 19.07 and it soft bricked. I had to use the recovery option to return to the last installed fw.

Another query - is uPnP and/or NAT-PMP available on this router? The reason I'm asking is, I have a WD MyCloud Home network storage device which uses a version of Plex server to stream media both locally and remotely. But it is not connecting securely and looking through the Plex documentation, it says to check if either of these services is enabled in the router's firmware. Looking through the firmware, I can't find any reference to either service.

Have you seen this thread describing how to revert to Linksys FW using a prebuilt sysupgrade image?
https://forum.openwrt.org/t/ea6350-v3-revert-back-to-stock-factory-firmware/42581/44

2 Likes

No I hadn't. I thought NoTengoBattery had taken his github repository down after his initial work on the router. So thank you for the link.

Am I right in thinking that I can switch between OEM and OpenWRT firmware by turning the router on and off three times?

First off, anything but basic routing and management is not pre-installed by OpenWrt. You need to install packages for UPnP (which many consider inherently insecure), VPN, and the like.

Yes, three failed boots will change the firmware to be booted to the other one. If you have only installed once, then it would be OEM firmware.

Finally, this was a development thread, not a support thread. Right above your first post

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.