Add support for ASUS RT-AX89X AX6000

I don't think I ever said this, but I wanted to give my thanks to all who have been volunteering their time and effort in getting OpenWRT to work on this router. Its nice to see hardware like this get custom opensource firmware support allowing us to do some neat stuff with it.

Like using it for creating a secure connection or having it play music for giggles. or both!

1 Like

This is somewhat reminiscent of this case: Link


Where can I download webGUI roms? I want to test using it.
I use robimarko's code to compile it into a file, but I don't know how to flash it.

I'm thinking of making an attempt at this but on HW revision B1. Would it be safe to try or should I wait some more? Asking because I been feeling more confident with this Linux stuff thanks to OpenWRT.

I dont know either. I was just asking a question to better understand what was going on in the discussion here.

Initramfs works just fine, however I really need to test permanently flashing it and then everything is ready for a PR

Hi !
I've been working on making the @robimarko image to load from webui.
Not working yet, still on it, not as easy as I thought.
On the other hand, I tried to make the port 10-sfp and 10-cooper working for fun, it does not !! Have I missed something ?
It is working pretty well on other lans port though.


Hm, last time I tried 10G DAC and FS SFP were working just fine

The interfaces are detected. I tried with the constructor firmware, I have a connection on both interfaces using my switch.
Maybe I forgot something during the build. Or it could be my hardware revision version. I don't know which one I use and I don't know how to check.

Look on the bottom of the router. You should see something like "HW Revision b1 or b2"

1 Like

Thanks, it is revision B2.
So I guess that it is not the problem.

I ran some simple tests :

set link down and up

ip link set 10g-sfp down
ip link set 10g-sfp up

I also tried to change the speed and set autoneg to off :

sudo ethtool -s 10g-sfp autoneg off speed 1000 duplex full

I tried the same with interface 10g-copper

I finally got around to testing SFP again and with an FS 10G DAC, it works just fine.
AQR though doesn't work, it seems something broke in regards to SSDK

1 Like

How do you drop down to u-boot from the ssh shell and boot with openwrt? I'd like to see if my XGS-PON SFP+ works (it doesn't in stock fw) - I compiled with latest patches and there's a .itb file and a .ubi file.

You need UART for now

I thought UART was patched out of the firmware?

Yes, out of Linux, but it works in U-Boot

is this uart flashing something i can do myself? i got a usb to ttl adapter. or do i have to...well i guess for lack of better words "go to college for"?

like, am i better off waiting for a web firmware image due to how risky this uart method is?

Many modern routers need this as their only method to flash OpenWrt, as vendors are clamping down on the possibility of installing third party firmwares (partially because of regulatory demands, partially to reduce fraudulent RMAs, partially because they can and want to). Using the serial console and booting OpenWrt from there itself is usually easy, what can be less convenient is reaching the header (disassembling the case without damaging it, in case of there not being a populated header soldering pins to it/ clearing the solder filled holes - or even fixing the data paths, in case the vendor (*cough*TP-Link*cough*) intentionally broke it). This part is device specific and varies widely, e.g. the e8450/ rt3200 is said to be easy in this regard (easy to open, prepopulated 2mm header, easy to close again), others need bigger tools…

I have had to open routers before for serial recovery and such so I understand how difficult it can be. I am asking about the programming part. Although you did just make a strong point about soldering. I have only a decent soldering iron but not the rest of the parts or a good working enviroment.

Ill just take this as "Leave it to the professionals and wait for the official release of this firmware for the router".

You all seem to have better tools and knowledge than I do. Like I would be following right behind you. Or sitting on your shoulder. Its a fun learning experience when I watch you all do your thing. This firmware basically gave me my biggest eureka moment in the linux world but thats another thread for another time.