Add OpenWrt support for Xiaomi "Redmi AX6000"

Lowering TX power to 13-14 dbm allows higher MCS rates. This could be caused (maybe) by PA non-linearity at higher powers. Still strange, because AX3000T seems unaffected even on 26 dbm.

Hi Guys,
I'm on version 23.05.3 with my AX6000 and I have a problem with the wifi. If I set the 5GHz device to AX mode with 80MHz bandwidth, everything look fine. I have to restart the 5GHz device every other months, but I can live with that.
However, if I set the bandwidth to 160MHz, regarding the channel I set manually, the device starts the interface on 6130 MHz:


It would be fine, if my clients would support the upper frequencies, but unfortunately, they don't. So is there a way, to use the 160MHz bandwidth in AX mode with the lower channels (and frequencies)? What am I missing?

Don't know what's going on there. What is your country set to in advanced settings. The frequencies 5,180MHz to 5,825MHz are normal, yours seems to be in the 6GHz range (WiFi 7)

Some clients only support upper DFS. It looks like your frequency isn't being reported correctly. Try switching to channel 100 and waiting a few minutes for dfs to scan at boot.

Thanks guys, I forgot to set the country and it was driver default. I set it to the correct country and now it looks fine! Thanks again!

Hi!
Just got this router and I'm trying to install OpenWrt using the official tutorial, but I'm stuck at the very first step - I'm unable to downgrade the firmware to version 1.0.48 or 1.0.60.
I get an error saying "文件校验失败", which translates to "File verification failed".
The tutorial mentions changing some digit at the end of the URL, but I'm not seeing it. This is the URL of the upgrade page: http://192.168.31.1/cgi-bin/luci/;stok={token}/web/apsetting/upgrade.
My current firmware version is 1.0.122.
Any advice?

Turns out I got the wrong router😭
I got a "Xiaomi AX6000", which apparently is not the same as "Xiaomi REDMI AX6000". My device codename is RA72 whereas the Redmi is RB06.
Hope I can return it...

Would like to share I've set up bonding for this router if anyone is interested. I intend the AX6000 to be running as an AP and is linked to another managed switch with LACP set up. I have also tested bonding with another openwrt router with the similar configuration for bonding and it works fine too.

  1. Software required: kmod-bonding luci-proto-bonding
  2. Add following to /etc/config/network
config interface 'bond0'
        option proto 'bonding'
        option ipaddr '192.168.1.XX'
        option netmask '255.255.255.0'
        option bonding_policy '802.3ad'
        option all_slaves_active '0'
        option link_monitoring 'off'
        option mode '802.3ad'
        option lacp_rate 'fast'
        option xmit_hash_policy 'layer2+3'
        list slaves 'lan3'
        list slaves 'lan4'
        option force_link '1'
        option min_links '0'
        option ad_actor_sys_prio '65535'
        option ad_select 'stable'

Notes:

  • Just choose an unused IP

  • list slaves lan3 and lan4 are the ports to bond, these should be removed from br_lan and replaced with the created bond (refer to next step)

  • option bonding_policy '802.3ad' has to be used for LACP, 'balanced-rr' can be used if using static aggregation

  1. Below is example of device, after removing lan3 and lan4, replacing it with bond0
config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'lan2'
    list ports 'bond0'
2 Likes

Does anyone use the luci on the AX6000 via https? I uploaded the certificate and the key file, restarted the uhttpd but for some reason uhttpd does not bind to port 443. What am I missing? I'm on OpenWRT version 23.05.3.

Sorry, my bad, the luci-ssl package was missing, I had to install it, now it binds to port 443.

Hi all,

I've been using OpenWRT for this router more than a week and it's working really well. I had to use some configuration tweaks so I can use all functionalities of this router correctly, but it was not that difficult thanks to the contributors and community members here.

Some tricks I used are:

  • Disable WED (Wireless Ethernet Dispatch) to use WDS
  • Disable WPA3 in case of 802.11r FT to use with Apple devices (especially MacBook)

It's really great and WDS is working well at the moment but I wanna configure 802.11s mesh point for better stability of multiple devices. The good thing is all devices I have are the same model with the latest stable OpenWRT. Is there anything I need to know to configure the mesh point on this device?

I actually tried to active the mesh point via LuCI but it didn't work as the 5GHz device was stuck at DFS stage. I confirmed this via the system log (or readlog -f) In this thread, someone suggested that 80MHz wide will tackle the situation but I had no luck even with the waiting for than 5 minutes.

At the moment, I'm too new to this ecosystem. Therefore, I may take some time to understand the things correctly. I hope you have a refreshing weekend. If there's something I can do even with the use of snapshot builds, please let me know.

Thanks.

You can go back to WPA3 if you configure 802.11r manually like so: 802.11r Fast Transition how to understand that FT works? - #81 by cotequeiroz

1 Like

Hi Taylor,

I thought this was specific to this router at the first time. Thank you for the direct link.

Hello. Has the WiFi issue on this router been fixed? I think I've had it for a year now, tried different snapshot builds (currently on r26741-dcc4307205 from a few days ago) and 23.05.3, and different WiFi settings, and while it works great as a wired router, WiFi completely stops working (both 2.4 and 5Ghz) several times a day, where the clients would connect, but then get stuck on the base TX rate (e.g. 6Mb/s) and get no internet, until I restart the router. It happens even after factory resetting it, and only setting up WiFi name and WPA2 password. I've even tried disabling WiFi AX, and it still happens with AC and 80MHz.

My current WiFi config (with which I have no WiFi):

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'WiFi :)'
        option encryption 'psk2'
        option key '<redacted>'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option ieee80211k '1'
        option time_advertisement '2'
        option time_zone 'CET-1CEST,M3.5.0,M10.5.0/3'
        option wnm_sleep_mode '1'
        option wnm_sleep_mode_no_keys '1'
        option bss_transition '1'
        option proxy_arp '1'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option wpa_group_rekey '86400'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '48'
        option band '5g'
        option htmode 'HE80'
        option cell_density '3'
        option country 'ES'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'WiFi :)'
        option encryption 'psk2'
        option key '<redacted>'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option ieee80211k '1'
        option time_advertisement '2'
        option time_zone 'GMT1'
        option wnm_sleep_mode '1'
        option wnm_sleep_mode_no_keys '1'
        option bss_transition '1'
        option proxy_arp '1'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option wps_pushbutton '1'
        option wpa_group_rekey '86400'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'WiFi :) 2.4'
        option encryption 'psk2'
        option key '<redacted>'
        option network 'lan'

Just at first glance that's an awfully complex wifi config and no one else is reporting any issues, so I'd start there. Especially the power saving options, etc.

Same 5Ghz WiFi disconnection problem


note the 5Ghz frequency of channel 116

Does WPA3 have the same issue?

My wifi is rock solid with this device. I agree that you have a bit more options than most. Recommend that you try a recent snapshot and simplify. If that works, you can consider adding back more options one-at-a-time to see what is causing your problem. For reference, mine:

/etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option channel '1'
	option band '2g'
	option cell_density '0'
	option txpower '3'
	option htmode 'HE40'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option band '5g'
	option country 'US'
	option cell_density '2'
	option htmode 'HE80'
	option chennels '100, 104, 108, 112, 116, 120, 124, 128'
	option channel '149'
	option txpower '24'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option network 'lan'
	option ssid 'cyan'
	option encryption 'sae-mixed'
	option key 'xxxxxxxxxx'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211w '2'

Have you set the Country to your country? The frequency should be in the 5GHz
range, not 6.530GHz.

Country IT