Add OpenWrt support for Xiaomi "Redmi AX6000"

Uploaded Snapshot (r21968, ~february 3rd) images that I used at first install (stock layout):

expired links



Also rsync'ed full snapshot folder at 2023.02.20: all targets and packages.
It's about 156Gb.. Maybe this data will be more helpful (with corresponding packages). Can share this too if needed.

Update: Uploaded snapshot (2023.02.20) only for mediatek/filogic target:

expired links
file link size comment
targets.txt 2 MB Table of contents. Output of du -ha command
packages.txt 765 kB Table of contents. Output of du -ha command 25 MB zip - part 1
targets--mediatek--filogic.z01 500 MB zip - part 2
targets--mediatek--filogic.z02 500 MB zip - part 3 370 MB zip - part 1
packages--aarch64_cortex-a53.z01 900 MB zip - part 2
packages--aarch64_cortex-a53.z02 900 MB zip - part 3

Update2: Reloaded on GDrive:

new link on GDrive


  • Snapshot 2023-02-03 (only stock-layout firmwares)
  • Snapshot 2023-02-20 (whole filogic target + packages)

If you just install stock version as I said after that commit, you will never be able to boot system and need to back to miwifi system for now unless you revert that commit and compile firmware manually, I DO NOT know why they said they tested.

1 Like

Hi, do we know (or have some time estimate) when final version of the firmware should be released? I have just received this router and I am not sure if to wait or use the snapshot version.

EDITED: Now I read this thread and it looks like there is major problem in the snapshot so I will wait, hopefully it will be fixed soon. I am still interested when the final release should be finished though.

Installed Openwrt with success using your files


to install the stock layout and used today's snapshot to install the ubootmod version

Thanks a lot for sharing the files. It was really helpful and was enough to bypass the temporary error when installing stock layout Openwrt

1 Like

I'm running Firmware X-WRT 22.10_b202302102335 Kinetic for 14 days without any issues now. Using similar build on my AX6S without issues. So you could search for this build (or a pure OpenWRT snapshot from approx that date) and you'll be fine.
Not sure if or when there will be a "Final" build, but this version is way more stable then any final Windows build :slight_smile:

1 Like

Thank you, I waisted so many hours for that bug, with this version, you saved me even more time as well as frustration.

files targets--mediatek--filogic.z01, targets--mediatek--filogic.z02 was expiered. Could you reload them again, may be reload on Google Disk?

Updated links in previous post.

1 Like

Thank you a lot :+1:
But when run command

sysupgrade -n /tmp/squashfs-sysupgrade.bin

it wrote warning:

Thu Feb  2 11:03:44 UTC 2023 upgrade: Image metadata not present
Thu Feb  2 11:03:44 UTC 2023 upgrade: Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
invalid sysupgrade file
Image check failed.

Is it ok to run it with -F parameter? Or something wrong?

Something is wrong. I don't used the -F parameter

Stock layout, step 5?
kastellsc right - make sure you use correct file for this step.

for snapshot 2023-02-03

sha256sum: a582b21a4495b38a5db23311840590ea2c88c0c5e56d9bf82a3772a748db575b


for snapshot 2023-02-20

sha256sum: 5ded9bfff945f86b671f023c805ed478164b4cb91e14dfdb36959f3cf3ae9e31

Also check if you select correct device. Filogic target contains several devices.

Stock layout, step 5?

sha256sum is the same, but what you mean select correct device?
On mine wrote:
Redmi AX6000, RB06 (rb06_minet_XXXX), CPU mt7986a

so was choosed files:

For step 5 checksum and file (*sysupgrade.bin) correct.
But in step 3 you used *initramfs-kernel.bin instead of *initramfs-factory.ubi

1 Like

Thank you! All works now. Upgrade until ubootmod layout + luci WebUI.

1 Like

When I enable Vlan on br-lan the connectivity is lost and I need to hard reset.
There is any know bug with vlan on Openwrt on this device? Anyone with same problem?

It's working fine for me, but keep in mind that once you enable VLANs, you'll have to use br-lan.1 (not br-lan) as the LAN interface for it to work. Both changes (interface change and vlan activation) need to be done on the same commit so you don't lose connectivity.

1 Like

Thanks. Solved!

Has this problem been solved in the latest stock layout version? Does it work?

Hello folks! How's it going?

Is there any way to get the snapshot version before March 7th?

I'm having bootloops after updating to the latest version.

I read late the comment above.

Thank you so much.


You can build any state of the (source-) repositories yourself, binary snapshot images however are not retained and are pushed out (replaced) after a successful buildbot run.

1 Like