Adblock support thread

Thanks I'll try to find out how to do that later today, when I'm off work. :grinning:

1 Like

Finally the endless Adblock restarts are gone.

I didn't get anywhere with it, but I found another way that worked after a few tries: Block all website url except some whitelisted - #9 by manuel.vita96

So now I only have the addresses that I wanted working. Unfortunately I can't change the whitelist from the GUI, so it's not possible to easily jump between this and full opening (for updates and stuff), I have to edit the config manually. But it will have to do since I can't get the jail list working.

1 Like

So you worked with serversfile in dnsmasq config? there was a toutorial from @dibdot for that but I might remember somthing about this option is deprecated in up to date dnsmasq versions. But don't quote me on that.
Congrats that you've got it working in the first place!

Thanks! And serversfile doesn't seem to be deprecated, this is the very latest image I downloaded for the Raspberry Pi.

Your right the serversfile option is still supported by dnsmasq but adblock from version 4.x uses a new format now. Sry for that.
See: Adblock support thread - #2018 by dibdot
That should be the reason why you can't edit the list via gui, cause the syntax is different. Maybe @dibdot can give better advice on how to use adblock with jail list only on primary dnsmaq instance, or point us to the right post :slight_smile:

Actually my problem was that the jail list didn't block anything at all, not that I couldn't get the necessary stuff through. :thinking:

the jail list format for my described setup would be:


yours should now look a little different as a serversfile. but if it's working for you than :+1:

1 Like

Is it possible to include the size (or the number of blocked servers) of every filter used by Adblock here
image(500kb)-for example
after the name of the filter or anywhere else in the interface.

Adblock is blocking embedded Youtube videos on news websites.

For example, this contains a video at the top of the page.

But the YouTube video is blocked and I just see an image.

I currently have the following lists enabled:

Any ideas how I can permit these embedded videos?

It is a problem of the lists, not of adblock. I use AdGuardHome and I also see the same symptom.

Which list/block source blocks access to

Turn the filters off/on one by one and you'll find out.

Very helpful mate! Very helpful...............................................

Simple. Just look for "Extremist Filter List" by Adolf Putin, you'll get both that and Instagram blocked right away. :rofl:

1 Like

Please, no trollin'....

Sorry, with Facebook blocking that door was wide open and I had to go in...

How can I select one of the included ad filters in the /etc/init.d/adblock list command? My router is based on OpenWRT, so I can't install the LUCI interface.

Search Near Bottom of

Edit, add new adblock sources:
The adblock blocklist sources are stored in an external, compressed JSON file '/etc/adblock/adblock.sources.gz'. This file is directly parsed in LuCI and accessible via CLI, just call /etc/init.d/adblock list :


I do not use Adblock and other than this search/link to the file directing you to search for the CLI usage near the bottom of the page for usage instruction; this is as far as I can assist.

1 Like

::: domain '' in backups and black-/whitelist

On the report page it has response OK. So not blocked. Why?