Adblock support thread

ist the dnsmasq instance your main one? To my knowledge the main overall.list gets deployed to /tmp/dnsmasq.d, with your settings, and then dnsmasq takes this list.

The jail.list will be deployed to /tmp and could be user via script that moves it and starts a second dnsmasq instance. You could use it with your primary once, but have to deploy it by hand and deactivate any automatic updates in adblock, so it didn't get overturned by the next overall list, wich must be removed beforehand.
Hope this is kind of right. Good luck with yout setup

Thanks for answering! I have not changed anything in the regular DNS, so I suppose I'm uing dnsmasq, and that's the only instance that's there. I'm afraid I didn't fully understand that... Do you mean that I need to change jail directory from /tmp to /tmp/dnsmasq.d? That didn't change anything for me.

That was my first thought two but now this doesn't work because both paths can't be the same in adb config und if you move the instance path at the top, the instance is no longer recognized.
So what you can do, if you doen't need any automatic updates and only change your whitelistet domains not so often, deactivate the autoupdate depending on interface or time etc.
Put your whitelist domains in gui (whatch out for the right format->manual)
Update list by manually start update. and wait for it to finish
delete overall.list from /tmp/dnsmasq.d
move jail.list to this location
restart dnsmasq with systemctl ot init.d
the last 3 steps could be done via a shellscript (maybe adb has some kind of execution path - i don't know right now).

Now only yout whitelisted domains could be reached from your network.

I can't give any guarantees for this solution, cause that's all from memory. Hope this helps. If someone knows any better please correct me. Would be glad to know a more elegant solution.

Thanks I'll try to find out how to do that later today, when I'm off work. :grinning:

1 Like

Finally the endless Adblock restarts are gone.

I didn't get anywhere with it, but I found another way that worked after a few tries: Block all website url except some whitelisted - #9 by manuel.vita96

So now I only have the addresses that I wanted working. Unfortunately I can't change the whitelist from the GUI, so it's not possible to easily jump between this and full opening (for updates and stuff), I have to edit the config manually. But it will have to do since I can't get the jail list working.

1 Like

So you worked with serversfile in dnsmasq config? there was a toutorial from @dibdot for that but I might remember somthing about this option is deprecated in up to date dnsmasq versions. But don't quote me on that.
Congrats that you've got it working in the first place!

Thanks! And serversfile doesn't seem to be deprecated, this is the very latest image I downloaded for the Raspberry Pi.

Your right the serversfile option is still supported by dnsmasq but adblock from version 4.x uses a new format now. Sry for that.
See: Adblock support thread - #2018 by dibdot
That should be the reason why you can't edit the list via gui, cause the syntax is different. Maybe @dibdot can give better advice on how to use adblock with jail list only on primary dnsmaq instance, or point us to the right post :slight_smile:

Actually my problem was that the jail list didn't block anything at all, not that I couldn't get the necessary stuff through. :thinking:

the jail list format for my described setup would be:


yours should now look a little different as a serversfile. but if it's working for you than :+1:

1 Like

Is it possible to include the size (or the number of blocked servers) of every filter used by Adblock here
image(500kb)-for example
after the name of the filter or anywhere else in the interface.

Adblock is blocking embedded Youtube videos on news websites.

For example, this contains a video at the top of the page.

But the YouTube video is blocked and I just see an image.

I currently have the following lists enabled:

Any ideas how I can permit these embedded videos?

It is a problem of the lists, not of adblock. I use AdGuardHome and I also see the same symptom.

Which list/block source blocks access to

Turn the filters off/on one by one and you'll find out.

Very helpful mate! Very helpful...............................................

Simple. Just look for "Extremist Filter List" by Adolf Putin, you'll get both that and Instagram blocked right away. :rofl:

1 Like

Please, no trollin'....

Sorry, with Facebook blocking that door was wide open and I had to go in...