Activate USB support - USB modem

Hi all,

I have a ZTE Mobley device, and it worked well with ASUS stock firmware as a USB modem.
I now have a TP-Link Archer C7 v4 and installed OpenWrt 18.06.1.
Currently it does not show any option for USB.
I tried following some instructions online by installing packaged kmod-usb-*, they are installed but I still can't configure the USB connection. Maybe because I need to activate the packages, I don't know.

Could someone help me with some guidance? Am I supposed to do all that via SSH, or can be done via LuCI interface?

Thank you for any help!

Which instructions did you try to follow? Exactly which kernel modules did you install? How do you expect to be able to configure the connection?

This wiki:
However it seems outdated.

Packages I installed: kmod-usb-serial, kmod-usb-serial-option, kmod-usb-serial-wwan and usb-modeswitch.

Apparently the USB modem would show up as an interface.

Your usb 3g dongle must be listed in usb-json file, its vid and pid
Is it even recognized by linux? What is new in /dev if you plug it in?
Do you have /etc/chat?/ present?

Would you mind sharing the commands I need to issue to get the info and change the usb-json file? Should I do it via SSH or it can be done within LuCI?

That .json file is in /etc
Copy it to pc and with good editor search if vid pid of your usb stick is there
Put usb stick in windows machine and in manager have a look at vid pid

No simple magic commands to solve this

I don't think those are the kernel modules you need. Try kmod-usb-net-rndis, and if that doesn't work, kmod-usb-net-cdc-mbim. See

It's easier to switch if you use mwan3. You can set it up to use the modem automatically if there is no other internet connection. It can be a bit hard to set up the first time, though.

Just by installing the modules, something should show up in Interfaces? Because neither worked. The modem is connected and on.

No, you need to add the interface manually as described on the wiki page. If that doesn't work then you need to check that the USB device has been recognized. There is some troubleshooting advice on the same page and some more here:

I have kmod-usb-net-rndis installed here for my Huawei 4G modem and the following stanza in /etc/config/network:

config interface 'wan_usb'
	option proto 'dhcp'
	option ifname 'usb0'

Igorjjj and others, stop acting like blind people, installing modules try-and-see goes nowhere just to hell

First of all, Igor is hiding what 3g dongle he has got...

Now step-by-step FIRST step: /next steps later when i have a time/

  • without dongle put in usb look in /dev if there is any ttyUSB0, 1, 2 ..
  • then put dongle in usb
  • look if it is there recognizef by system

Unless it is there forget any other settings, luci and so on....

Pid, vid? Do you have installed usb support? If you put usb flash stick is it recognized as /dev/sda, b, c ..?

Do you have installed usb-uhci, ohci, usb2 ? as we do not know if it is usb1, usb2 install all 3 modules

waiting feedback from step 1

It's a waste of time to start with the most complex troubleshooting methods before he's tried to set it up using the drivers that will work out of the box at least 90% of the time.

1 Like

Waste of time is try-and-see, sorry, it should be try-and-not-see

Not when the try and see works 90% of the time and takes almost no time to finish, compared to starting with a time consuming troubleshooting procedure that will ultimately lead to the same solution 90% of the time. It's simple math.

if it does not work 100% but only 99,999999% it is useless
Igorjrr has spent already too much time and if you would insist to continuethe way as now he will spend even more time without sucess

He is so desperate that he already open thread over here

Now is the time to read the manual....

No need to argue about methods. The 3gdongle guide looks a bit outdated, as noted. It's also very long and tries to cover too much IMHO. I'd recommend starting with one of the LTE guides instead. For example:

And do note the tip about
cat /sys/kernel/debug/usb/devices
Post the output and we can tell exactly which package is missing, if any

Most mobile devices (both phones and dongles) uses rndis for USB tethering, and neither it nor the second two most used drivers (mbim and qmi) are installed so obviously it most likely won't work in the current state, no matter how much troubleshooting you do. It's not my time being wasted, though, so feel free to use any method you like.

As we still do not know what dongle he has got the words "most mobile devices" sounds to me gently speaking funny

It says ZTE Mobley in the first sentence.

Try to search it.....