Access to service ON the Router


This one is driving me up the wall. We have a few VDSL modems (BT ECI B-Focus) running OpenWRT 18.06 which we installed. I have some hardware I want to attach to the UART port. I've disabled the use of the port by everything. made sure I can locally send and receive data to the hardware and thats all good.

I've installed ser2net, configured this as I would on any other system and its listening on port 6502.

Now trying to connect to this fromt he LAN I get connection refused. Looking on TCPdume I see the request but no reply on ETH0 but on BR-LAN I get the connection attempt and the reply. Having worked a lot woth Smoothwall (Ex employee) and PF (Contributor) I just can't get my head around the firewall section. I've added a traffic rule:

Any tcp, udp
From any host in any zone
To any host, port 6502 in any zone

which makes no odds. I'm sure it's something stupid but I cant see what, lack of firewall logging isnt helping :frowning: I'm certain it is firewall related.

The modems are going up on poles around the UK as stand alone VDSL weather stations and weather cameras for a community project in case anyone is curious. The Serial device itself handles the security on the port via its on onboard STM32 processor.

Like this you allow forwarding.
If you want to allow on the router you need to change it to To any router IP at port 6502 on this device
You can check the 'Allow-DHCP-Renew' rule that exists in the default Firewall configuration.


Solved, not enough caffine today...
Disabled all kernel services on the port, stopped the debug messages, created the firewall rule, flashed the hardware, installed ser2net, edited the config for ser2net......

Totally forgot to uncomment the config line, just didnt see it. facepalm I'll go back under my rock now.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like