Access to OpenWrt behind router

Hi guys
I have a problem connecting to my OpenWRT behind a router. here is my scenario:

What I want is access from my Wi-Fi network to OpenWRT so I can manage aria2c and other services of it but no chance. no connection to, or even when I connect it to D-Link. is there any firewall or VLAN that cause this problem? OpenWRT connection to the internet has no problem and when I connect a device through Lan, the device has access to the internet too.
(I have no access to OpenWRT by Wi-Fi because of hardware incompatibility of my OpenWRT device)

And I really really appreciate your help and OpenWRT as a great product.

You cannot have the same ipaddress/subnet on Wan and Lan side. Maybe you can merge Wan to Lan on Openwrt ? Which router has Internet provide ? As I understand D-Link ?


If your use of the OpenWrt device is to run servers for your LAN, set it up as a basic LAN device. Don't define a "wan" network on it. It would hold one IP address in the subnet. You can then reach it from any wired or wireless device on the LAN since they are all in the same subnet.

Your diagram doesn't show how the Internet is connected. Assuming the D-Link is routing the LAN to the Internet, should you need to reach the OpenWrt box from the Internet, then you would have to configure the D-Link router to forward ports.


Hi dear kofec thank you for your response. yes, as you said D-Link is responsible for providing internet. can you please explain what do mean by merging Wan to Lan?
I tried to change the scenario to what I understood from your post and still no success. I just changed IP in /etc/config/network and restarted network service in /etc/init.d/network and then connected the cable to D-Link. I just changed the IP and connected it to D-Link, should I do anything in D-Link?
=> here is the new scenario:

=> and here is the result from D-Link Traceroute:
RESULT: Traceroute Status: The host name is unknown

=> and no ping or access to services from my Wan Network.

Hi dear mk24, yes, I'm using my OpenWrt only as a service provider to my network, services like aria2c, samba, and so on. and D-Link is responsible for providing internet. the only thing I need is to have access to manage OpenWrt and have access to it from my Wi-Fi network. with the scenario I mentioned in the first post there is no access to 192.168.100 from my Wi-Fi network.
and it's really interesting but I don't need to access my OpenWrt from the internet at this point.

Connect one of the LAN ports of the OpenWrt to a LAN port on the D-Link.
Do not connect anything to the WAN port of the OpenWrt. (later you can re-configure it to be usable for another LAN device, but that is an advanced subject).
Set the OpenWrt LAN IP to an available address within
Set the OpenWrt gateway and DNS to the D-Link,
Disable the DHCP server in OpenWrt on its LAN network. Also click the IPv6 tab and disable the IPV6 server.


Great progress! here is the new simplified scenario by getting rid of WAN port and my interfaces setting in luci:

Now for sure, D-Link can ping
Also, my OpenWrt has internet access by defining as it's gateway and DNS.
But, OpenWrt has no ping to my Wi-Fi network and vice versa. so no ping from my Wi-Fi Network to
is there a VLAN or firewall setting I should take care of?

Why not simply configure your Openwrt device as a switch? You can use then the wan port as well.

1 Like

A D-Link router in default configuration should be bridging the wifi users over to the wired LAN ports, this setup should just work. Make very sure the OpenWrt DHCP server is turned off or it will cause trouble for DHCP devices on the network.

1 Like

1 Like

thanks a lot, dear mk24! the problem as you said was isolation between Wi-Fi and LAN users. more precisely multiAP isolation is checked by default in Dlink firmware that I don't know why? by the way, thank you again for your help. :hugs:

I see that it's already solved, but what models are both routers? I was thinking of the one running OpenWrt is of decent specs you can have it doing everything and make the D-Link as a modem only.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.