Access to modem in a different subnet

HI,

my OpenWrt has the IP 192.168.1.1 and my modem 192.168.2.1 and I would like to be able to access the Web Interface of the Modem from devices in the 192.168.1.0 subnet. I found this by googling around a bit, but it doesn't work:

I have a PPPoE connection with vlan 40 on the WAN port connected to the modem.

Does anyone have any idea how to accomplish this?

There is documentation about this, which worked fine for my PPPoE (without VLAN) case.
What is your configuration?
uci export network

1 Like

As far as I can see, the documation is basically matching the guide I linked in the opening post, just cli vs. LuCi.

The interface config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd23:9d9b:6dae::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'

config interface 'wan'
        option ifname 'eth0.40'
        option proto 'pppoe'
        option password 'secretpassword'
        option ipv6 'auto'
        option username 'supersecretusername'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0.40'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 3 2 1 0'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '40'
        option ports '6t 4t'

config interface 'modem'
        option ifname 'eth0.40'
        option proto 'static'
        option ipaddr '192.168.2.2'
        option netmask '255.255.255.0'

I found the issue, the vlan tagging caused it. I created a seperate vlan without the tagging and it's working now!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.