Access modem's web/telnet even when wan is down

My internet is thru this device. it has its own telnet and web server running on
I followed these instructions to set up a modem alias to access from devices in LAN. It works, but only works when the wan uplink is UP. when the WAN link is down, e.g. when the ISP is down or the cable is disconnected from the PON stick, the modem interface doesnt work at all. even pinging the static IP of the modem interface ( in openwrt doesnt work when the WAN link is down. This is especially problematic because accessing is the main way to debug why the WAN link is down: it shows detailed PON status info

I think I can work around this problem by putting a fake DHCP server on one of the wan ports. But is there a way to fix that guide such that the modem's IP can be accessed even when the WAN link is down?

To determine if there is any possible method to do this, test this:

  • Get the ONT/modem into the disconnected state (i.e. disconnect the cable from the PON stick)
  • Disconnect the ethernet cable from your OpenWrt router and plug it directly into one of your computer.
  • Set the IP address of the computer's ethernet port to
  • make sure your computer's wifi is disabled and that there are no other physical network connections (relevant if you have more than one ethernet port on your computer)
  • Test your ability to connect to the ONT/modem at via ssh/web.
  • Report back with the test results.

I have already done that many times, e.g. to configure the xgs-pon device before use in the openwrt router. It works.

To be clear, does that mean that the xgs-pon upstream is disconnected (i.e. fiber unplugged, only power and copper ethernet connected) and it works from your computer?

yes, the fiber cable was unplugged. the xgs-pon devices was in a media converter. one ethernet cable connected the ethernet ports of the media converter and my linux desktop

Did you unplug the cable going to the router and connect it to the computer? Or were you using a different cable/port?

The most likely cause of your issue is that the 'modem' interface you've created on the router is an alias of the wan connection (you're basically providing the wan link with an additional IP to allow it to route traffic to the xgs-pon device); however, this means that when the wan link is down so is the alias.

You need an interface that isn't tied to the status of the wan connection, but it's tricky to advise on that without further details about your setup, e.g. what are the devices you're using (both OpenWRT device and media converter)?

1 Like

Did you unplug the cable going to the router and connect it to the computer?

yes. and it works even if I reboot the media converter after unplugging the fiber cable from the xgs-pon device

This should only happen when the interface has option force_link '0' set.

Try replacing the @wan pseudonym with the actual name of your L2 device.