About Transmission package build version 2.92 (0)

Hello LEDErs.

I am running Transmission on a Linksys WRT1900ACS on LEDE 17.01.5 and I cannot donwload from any private trackers as the build version it is reporting to them is "(0)", instead of the most common ones (14714)...etc, so it is blacklisted (or not whitelisted). In public trackers it works like a charm.

I see the Transmission package that is offically included in opkg is 2.92 (0) as it is reported by the web-control panel.


Would be there any way to update it or at least to public the build string correctly? (I do not know exactly which build version is included in opkg).

Thanks in advance.

2.92 is in LEDE. I tried backporting to 2.94 bit it never got merged.

You could try running opkg install on the OpenWrt 18.06 package.

1 Like

Thank you for the hint.

I tried OpenWRT18.06 transmission packages but I cannot even connect to RPC or WEB-UI on this release.

Uninstalled previous transmission packages (2.92) from LEDE sources, rebooted, and manually installed transmission packages (2.93-7) from OpenWRT sources and rebooted again:


I made sure transmission was enabled and tried the default config (RPC at 9091 and so on), but I cannot even remotely connect to the RPC on my transmission client, and the WEB-UI does not get launched either. So I reverted back to 2.92 and at least it works with public trackers.

The RPC issue is because you probably restored your config. 2.93 introduced a new option designed to block DNS rebinding, but this needs to be disabled.

1 Like

Thank you.

I think I will wait for the 18.06 final to be released (expected around 30th July) and I will try Transmission 2.93 from there. I hope it includes the build version so it is whitelisted for the trackers.