802.11s mesh over 5GHz issues

I bought 4 TL-WR902AC business routers to experiment with mesh before possibly replacing my odd mix of APs here. They are V3 and use MediaTek chips (MT7628AN, MT7610EN). I'm using the stock 19.07.3 installation but replacing wpad-basic with the full-fat wpad. I eventually got it all configured, with eth0.1, wlan0, wlan1 and the mesh all bridged together. One node connects to my main network and the others are all on the mesh. However, with the mesh on the 5GHz radio (ch 48), I got lots of dplicate responses to pings, and ping would just hang for many seconds before displaying lots of very delayed responses. The mesh was also useless for traffic - my phone would not even get an IP address.

However, changing the mesh to the 2.4GHz radio, and it all works perfectly! Connecting my phone at 5GHz and running Speedtest, it maxed out near the capacity of my vdsl, though connecting at 2.4GHz it was much lower, having to share the AP link with the mesh.

I wonder if anyone else has seen the same thing? I'm now running the main mesh on 2.4GHz but I've set up an isolated second one on 5GHz with its own IP addresses for running tests by changing parameters. Here are the network and wireless configs:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb8:dead:beef::/48'

config interface 'locbr'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option gateway '192.168.2.254'
	option dns '192.168.2.254'
	option ip6assign '60'

config interface 'mesh2'
        option proto 'static'
        option ipaddr '10.0.2.1'
        option netmask '255.255.255.0'
	option force_link '1'


config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'cc:32:e5:ff:ff:ff'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '4 6t'


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '1'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option disabled '0'

config wifi-iface 'wifinet0'
	option ifname 'wlap0'
	option device 'radio0'
	option network 'locbr'
	option mode 'ap'
	option ssid 'meshtest'
	option encryption 'psk2+ccmp'
	option key <redacted>

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '48'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT40'
	option disabled '0'

config wifi-iface 'wifinet1'
	option ifname 'wlap1'
	option device 'radio1'
	option network 'locbr'
	option mode 'ap'
	option ssid 'meshtest'
	option encryption 'psk2+ccmp'
	option key <redacted>

config wifi-iface 'mesh'
	option ifname 'mesh0'
	option network 'locbr'
	option device 'radio0'
	option mode 'mesh'
	option mesh_fwding '1'
	option mesh_id 'xxmesh1'
	option encryption 'none'

config wifi-iface 'mesh2'
        option ifname 'mesh1'                             
        option network 'mesh2'                            
        option device 'radio1'                            
        option mode 'mesh'                                
        option mesh_fwding '1'                            
        option mesh_id 'xxmesh2'
        option encryption 'none'

Yes I have had the same issue. They only have 64MB ram and running dual logical interfaces at 5GHz and a single at 2GHz was too much causing many dropped packets as the wireless drivers ran out of memory for buffering. The 2GHz drivers seem to need much less ram though so turning off the 5GHz allowed use of the devices.

I'm sorry to say my solution was to change to gl-inet ar750s devices for the project, more expensive but worked well.

1 Like

Thanks for the reply. I can still use the 5GHz radio as an AP and it runs fine in that mode.

Another data point. Originally I used the same SSID on 2.4GHz and 5GHz. I changed the 5GHz SSID so I could test over the bands separately, and now, magically, the 5GHz mesh stuff works properly! On reflection I didn't think it was running out of memory, and looking at /proc/meminfo bore that out.

Sorry to bump an old thread, but was this ever resolved? I have a Dlink DIR-822 with MediaTek MT7615E and a DIR-859 with Qualcomm Atheros QCA9880. Having a similar issue - I can use the 5GHz radios successfully as APs, but they will not associate if I try and use them in a mesh. Same config with the 2.4GHz radios - mesh works fine. Both routers are running 23.05.0.

Wow! 4 years later... :wink:

Much has changed since then!
Have you read the up to date documentation?
https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s

5GHz can be problematic for a mesh network as:

  1. You must use a fixed channel (not auto) and the same for every node.
  2. You must not use a DFS channel (because it might not come up and could go down at any time)
  3. 1 and 2 above do not leave many channels available

Have you installed mesh11sd?

I was using channel 40 and following a tutorial based on the 802.11s instructions on the doc site which suggest wpad-mesh-openssl. Is mesh11sd similar?

If it does not mention mesh11sd nor wpad-mbedtls it will be very outdated.

You should read:
https://openwrt.org/docs/guide-user/network/wifi/mesh/mesh11sd

as well as the link I mentioned to you previously:
https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s

Thanks! I'll do some reading :slight_smile: