802.11s extremely slow on MT76 / How to patch?

https://github.com/openwrt/mt76/issues/387
https://github.com/openwrt/mt76/issues/450

I've run into same problem by trying to create 802.11s bridge between two locations as WDS was unstable/buggy.

It can be "patched" by disabling A-MSDU (see git) when compiling and while I am familiar with building from source I am also very big noob when it comes to applying patches, can somebody here please walk me through how to apply said workaround?

Also is there some sort of fix coming to upstream OpenWRT? (I am running v21.02.0-rc3 and the bug is still there)

Thanks

Find the mac80211.c file, around line 304 you'll find

ieee80211_hw_set(hw, SUPPORTS_AMSDU_IN_AMPDU);

Put // in front of it

//ieee80211_hw_set(hw, SUPPORTS_AMSDU_IN_AMPDU);
1 Like

Thanks for the reply,

but where do I find this file, there are like 3 of these in build directory that belong to mt76 driver (toolchain, backport, ...), tried commenting the line out of all of them with no effect. Does the compiler need some special arguments to reflect the changes? (To force the recompilation of these files?)

Yeah, you might, but the compiler should have noticed the c file's changed.

Hello, did you manage to disable the amsdu? If so, can you also teach me how did you do it? Thank you.