802.11s and dhcp


I'm trying to configure 3 aps on mesh topography.
On meshnode, all seem ok, it can connected to "master", i've a MESH-PEER-CONNECTED

But I've added the mesh0 to the lan bridge on the meshnode. I've set lan to dhcp.
When the meshnode connect, he try a DHCPDISCOVER. The master reply with an offer but it never get the ip and try again a discover, etc....

I've missed something ? (my meshnode become unreachable after this since it doesn't have anymore an ip).

The 802.11s mesh network provides a layer 2 mac-routing network - if it is configured correctly.

DHCP is a layer 2 protocol. A node sends a broadcast DHCPDISCOVER.
If the mac-routing network is not properly established it is very common to see the symptoms you describe ie the DHCP "handshake" does not complete because the layer 2 mac routing table is incomplete.

Complete configuration is not possible using the wireless uci config.
The package mesh11sd has been provided to dynamically set/reset/adjust the required mesh parameters for an operational mac-routing table to be established.

Have you installed mesh11sd?




Thanks for your help.
I've installed mesh11sd. I think the problem is with my hardware / support hardware.

When I put the mesh on the 2,4ghz network, it work perfectly. When I put it in my 5ghz network but with he20, it work. With he40 it work "sometimes" and with he80 it never work.

But my network, without mesh, work great in he80. With this configuration, I'm limited to around 50/100mbps meshing configuration :confused:

It won’t be a true mesh without mesh11sd installed (unless you manually configure the mesh while it’s up).

2.4ghz and HT20@5ghz might work because the range is better. Try to disable mesh11sd. If the mesh still works as before then chances are you still haven’t configured mesh11sd correctly and L2 layer routing is still incomplete.

Hello, I stay with the default mesh11sd configuration. I only try to change mesh_rssi_threshold
What params do you recommand to tune on mesh11sd ?

Thanks !

Generally the default options are good. But have it run on all your APs and main router.

Mostly it’s mesh forwarding that’s the culprit and needs to be set. Without that you will only get 1 hop from 1 node to main router, not node2 to node1 to main.

Not really. Nodes need to know from the mac-routing table where to forward. It is building the distributed routing table that matters.
The important parameters for ensuring the mac-routing table gets built and updated are, in order of importance:

  1. mesh_fwding
  2. mesh_hwmp_rootmode
  3. mesh_gate_announcements

Others also matter for smooth operation but not necessarily for the routing table.

The command mesh11sd status is useful for checking what is going on.

1 Like

Yes, 2.4GHz is the least problematic. If you can use HT40 (because you are in a quiet area - maybe out in the country as I am :wink: ), then you can push close to 300/300 Mb/s on the backhaul.

For 5 GHz, you have to ensure you are not using a DFS channel as this will make mesh links very unreliable, baring in mind that if you increase the bandwidth, you may well impinge upon a DFS channel inadvertently.