802.11ac not working on Linksys WRT1900ACS

Hey all, I have just installed LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.315.61305-a9bddc4) on my WRT1900ACS, and it is running nicely on 2.4GHz. However, the 5.5GHz 802.11ac radio is not working: When I look at in the Luci web interface, the status shows as this;

SSID: Sigmund
Mode: Master
Channel: 100 (5.500 GHz)
Bitrate: ? Mbit/s
BSSID: 16:91:82:32:69:A6
Encryption: WPA2 PSK (CCMP) 

When I look through the system log, I see lots of stuff like this:

[  454.078069] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  454.084537] br-lan: port 3(wlan0) entered forwarding state
[  454.090074] br-lan: port 3(wlan0) entered forwarding state
[  456.088037] br-lan: port 3(wlan0) entered forwarding state
[  899.954217] device wlan0 left promiscuous mode
[  899.958723] br-lan: port 3(wlan0) entered disabled state
[  900.032369] ieee80211 phy0: change: 0x40
[  900.140160] ieee80211 phy0: change: 0x100
[  921.861947] ieee80211 phy0: change: 0xffffffff
[  921.979145] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

I have tried updating the mwlwifi drivers to the latest version (as described here:6733), but I apparently already have the latest version.

Any thoughts?

6733? 17.01.4 does not have the current mwlwifi OOTB, but a search of mwlwifi in the forum should provide the requisite information to get an ipk to install.

Okay, well I have installed the latest mwlwifi drivers from here: https://github.com/eduperez/mwlwifi_LEDE/releases

but that has not helped. I still get the same problem.

Is there another version I should be installing here?

Ah, spoke too soon. I just rebooted* and it now seems to be running okay, getting a good 5-600Mbps connection to my devices.

So, seems to be sorted with the update to the eduperez mlwwifi drivers. Thanks!

  • or rather, a power glitch rebooted the router for me :wink: