64-bit x86 Archives corrupted?

I'm trying to run OpenWRT on an AMD64 system.

I've tried three different (de)compression utilities and all give errors about corrupt files when I try to unpack any the .gz files I downloaded today. I've downloaded efi and non-efi versions of both the squashfs and the ext4 images.

Does anyone else have problems with these files (direct links below for anyone else who wants to try)?

Working fine in here by using Winrar 6.10, tested the https://downloads.openwrt.org/releases/21.02.2/targets/x86/64/openwrt-21.02.2-x86-64-generic-ext4-combined-efi.img.gz file link. Perhaps something are interfering your download stream?.

Are you on Windows?, try to disable Windows Defender/3rd party networking/anti-malware/antivirus related software before downloading the images.

I was just successful when opening the first link with winrar.

Thanks for checking.

I'm on a Mac. There isn't anything that should be interfering with my download stream.

I tried using wget to download the file, rather than my browser. Same problem.

gunzip on the commandline succeeds in decompressing the file, but says "trailing garbage ignored"

Interestingly the sha256 sum for the gz file matches the one given on the downloads site.

I tried downloading and decompressing on a linux vps I use. Same message about "trailing garbage ignored" from gunzip.

Me either, also on my Debian 11 VM getting "trailing garbage ignored", downloading for example "openwrt-21.02.2-x86-64-generic-ext4-combined-efi.img.gz" match sha256 checksum "f2f1a0aaa6fc2edce3338d6a9ce7970d60bad868d2e54ca30261071413ef1f28", both verified in either Windows 10 or Debian 11 VM.

But when testing the gziped archive/image through Winrar on Windows, it doesn't detect any malformed gziped archive. Been using Winrar also for extracting my self-built OpenWRT image and doesn't get any corrupt *.img, even after flashing it to the device.

Probably there are two possible reasons :

  • Either corrupted from the source or upstream OpenWRT
  • Bugs in the gunzip

The trailing garbage "error" is normal.

2 Likes

The archives aren't corrupted, but they do have image meta data (parsed by sysupgrade) appended at the end, that's the 'trailing garbage' reported by many decompressors (complained about, but safely ignored).

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.