5GHz not working with only some devices (1 works 3 don't)?

Hi there,

I have a TP-LINK Archer C2 v1 which is a dual-band router with 5 ethernet (4 LAN 1 WAN)

I have configured it with OpenWRT 22.03.0 and two separate, completely different SSIDs, one for 2.4GHz and one for 5GHz. Lets call them WiFi2 and WiFi5.

I have 3 4 different devices I want to use with this OpenWRT device. My windows laptop, my Macbook, my new phone, and my old phone as a testing device.

  • All 4 devices work perfectly when connected to WiFi2.
  • The windows laptop works perfectly when connected to WiFi5.
  • The new phone gets an IP address on WiFi5 but then fails to access any other devices on the network or access the internet.
  • The old phone fails to get an IP address on WiFi5
  • The Macbook gets an IP address on WiFi5 but then fails to access any other devices on the network or access the internet

Here are the associated sections of my system log for both the new phone and the old phone (but not the windows laptop or Macbook). All MAC addresses have been redacted:

Failed 5GHz from old phone (no IP address obtained)

Sat Oct  8 15:53:57 2022 daemon.info hostapd: wlan0: STA AA:AA:AA:AA:AA:AA IEEE 802.11: authenticated
Sat Oct  8 15:53:57 2022 daemon.info hostapd: wlan0: STA AA:AA:AA:AA:AA:AA IEEE 802.11: associated (aid 1)
Sat Oct  8 15:53:57 2022 daemon.notice hostapd: wlan0: AP-STA-CONNECTED AA:AA:AA:AA:AA:AA
Sat Oct  8 15:53:57 2022 daemon.info hostapd: wlan0: STA AA:AA:AA:AA:AA:AA WPA: pairwise key handshake completed (RSN)
Sat Oct  8 15:53:57 2022 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED AA:AA:AA:AA:AA:AA
Sat Oct  8 15:54:33 2022 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED AA:AA:AA:AA:AA:AA
Sat Oct  8 15:54:33 2022 daemon.info hostapd: wlan0: STA AA:AA:AA:AA:AA:AA IEEE 802.11: disassociated
Sat Oct  8 15:54:34 2022 daemon.info hostapd: wlan0: STA AA:AA:AA:AA:AA:AA IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

Failed 5GHz from new phone (IP obtained, no network access afterwards)

Sat Oct  8 15:55:46 2022 daemon.info hostapd: wlan0: STA BB:BB:BB:BB:BB:BB IEEE 802.11: authenticated
Sat Oct  8 15:55:46 2022 daemon.info hostapd: wlan0: STA BB:BB:BB:BB:BB:BB IEEE 802.11: associated (aid 1)
Sat Oct  8 15:55:47 2022 daemon.notice hostapd: wlan0: AP-STA-CONNECTED BB:BB:BB:BB:BB:BB
Sat Oct  8 15:55:47 2022 daemon.info hostapd: wlan0: STA BB:BB:BB:BB:BB:BB WPA: pairwise key handshake completed (RSN)
Sat Oct  8 15:55:47 2022 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED BB:BB:BB:BB:BB:BB

Succeeded 2.4GHz from new phone

Sat Oct  8 15:58:02 2022 daemon.info hostapd: wlan1: STA BB:BB:BB:BB:BB:BB IEEE 802.11: authenticated
Sat Oct  8 15:58:02 2022 daemon.info hostapd: wlan1: STA BB:BB:BB:BB:BB:BB IEEE 802.11: associated (aid 2)
Sat Oct  8 15:58:03 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED BB:BB:BB:BB:BB:BB
Sat Oct  8 15:58:03 2022 daemon.info hostapd: wlan1: STA BB:BB:BB:BB:BB:BB WPA: pairwise key handshake completed (RSN)
Sat Oct  8 15:58:03 2022 daemon.notice hostapd: wlan1: EAPOL-4WAY-HS-COMPLETED BB:BB:BB:BB:BB:BB

For a little more context, both phones are Samsung devices, one is an S22 Ultra (new) and one is an S8 (old). It is not an unreasonable assumption that this could be affecting Samsung devices specifically however these devices work perfectly fine with other 5GHz networks operated on other APs, including other APs running OpenWRT. My Macbook is also having the same issue.

Any ideas as to why these devices do not work?

Thanks!

Best way to troubleshoot is to look at the configs.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Hi psherman!

My setup is a little bit weird, however I have tested using a more standard (stock) configuration without this split LAN and mobility domain roaming and the issue still occurs. If you would (understandably) like me to return to the stock configuration, retest and repost these configurations, I would be more than happy to do so.

Here are the configurations:

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'aaaa:bbbb:cccc::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config switch
        option name 'switch1'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch1'
        option vlan '1'
        option ports '0 1 2 3 4 6'

config switch_vlan
        option device 'switch1'
        option ports '0t 1t 2t 3t 4t 6t'
        option vlan '11'

config device
        option name 'eth0'

config interface 'lan2'
        option proto 'dhcp'
        option device 'br-lan2'

config device
        option type 'bridge'
        option name 'br-lan2'
        list ports 'eth0.11'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel 'auto'
        option cell_density '0'
        option htmode 'VHT80'
        option band '5g'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option ssid 'lan1net 5GHz'
        option mobility_domain '2f28'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option band '2g'
        option htmode 'HT40'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'lan1net'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option mobility_domain '2f28'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'lan2net 5GHz'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option mobility_domain 'beef'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan2'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'lan2net'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option mobility_domain 'beef'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan2'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'
        option ra 'hybrid'
        option dhcpv6 'hybrid'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

/etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'lan2'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan2'

Thanks!

I’d start by disabling 802.11r - there are devices that just don’t work well when this is enabled. If that doesn’t fix the issue, the mobility domain could be responsible for the issues.

I have disabled 802.11r, and the mobility domain is directly related to it so that is automatically removed also. I have also disabled the 2 APs for lan2.

Unfortunately, the issue still persists. Config snip:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel 'auto'
        option cell_density '0'
        option htmode 'VHT80'
        option band '5g'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'redacted'
        option ssid 'lan1net 5GHz'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option band '2g'
        option htmode 'HT40'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'lan1net'
        option encryption 'psk2'
        option key 'redacted'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'lan2net 5GHz'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option mobility_domain 'beef'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan2'
        option disabled '1'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'lan2net'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option mobility_domain 'beef'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option network 'lan2'
        option disabled '1'

It seems that my 5GHz issue might be directly related to https://github.com/openwrt/mt76/issues/227

Edit: Latest snapshot seems to fix connection issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.