5G SSIDs not visible to clients after reboot (SOLVED)

Hello ive seen similar issues but with no solutions.

SOLUTION
NOTE: after reboot I noticed the auto went to channel 173 or other channels. I changed it to channel 36 and the SSID showed up for clients and I was able to connect.
Lesson... start with channel 36 for debugging.

TLDR issue:
Second wifi SSID on 5GHz radio doesn’t work after reboot

My steps:

1. adding a second SSID to the 5g radio.
2. Both SSIDs show up and work.
3. Reboot router (testing if in a power outage)
4. SSIDs from the 5GHz radio do not show up anymore for clients (even after waiting 10+ minutes)
5. 2.4GHz SSID shows up

To fix it

1. Delete all interfaces from 5g radio
2. Reboot
3. Add original wifi interface back to radio
4. wait for it SSID to appear
5. connect some clients
6. Reboot
7. Wait a looooong time and it shows up as normal
8. sometimes it doesn't work and need to repeat steps

Hardware and software

Router: Dynalink DL-WRX36
Radio0: Qualcomm Atheros IPQ8074 802.11ac/ax/n
OpenWRT: OpenWrt 23.05.2, r23630-842932a63d

Theories
Ive read in some places that the 2 SSIDs need different Macs... and they need to be on the same channel... which they have to be since it's set in the radio. Could this be an issue with having channel set to auto? I tried with specific channels 36 and I believe it happened then too.. this is tricky and time consuming since it requires several reboots and lots of waiting.

(ref A*) Showing that VAPs are supported

root@OpenWrt:~# iwinfo
phy0-ap0  ESSID: "<MYSSID5G>"
          Access Point: A4:**:**:**:**:B4
          Mode: Master  Channel: 64 (5.320 GHz)  HT Mode: HE80
          Center Channel 1: 58 2: unknown
          Tx-Power: 23 dBm  Link Quality: 64/70
          Signal: -46 dBm  Noise: -108 dBm
          Bit Rate: 290.8 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: embedded [Qualcomm Atheros IPQ8074]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

phy1-ap0  ESSID: "<MYSSID2.4G>"
          Access Point: A4:**:**:**:**:B5
          Mode: Master  Channel: 1 (2.412 GHz)  HT Mode: HE20
          Center Channel 1: 1 2: unknown
          Tx-Power: 27 dBm  Link Quality: 70/70
          Signal: -37 dBm  Noise: -100 dBm
          Bit Rate: 37.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ax/b/g/n
          Hardware: embedded [Qualcomm Atheros IPQ8074]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

(ref B*) State of configs that are working — shows up for all clients

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel 'auto'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel 'auto'
	option band '2g'
	option htmode 'HE20'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<MYSSID2.4G>'
	option encryption 'psk2'
	option key '<SSID-PASSWORD>'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '<MYSSID5G>'
	option encryption 'psk2'
	option key '<SSID-PASSWORD>'
	option network 'lan'

(ref C*) Adding a SSID on 5G radio0 using phy0 as stated in “Supports VAPs: yes PHY name: phy0”
SSID appears for all clients and can connect

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel 'auto'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel 'auto'
	option band '2g'
	option htmode 'HE20'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<MYSSID2.4G>'
	option encryption 'psk2'
	option key '<SSID-PASSWORD>'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '<MYSSID5G>'
	option encryption 'psk2'
	option key '<SSID-PASSWORD>'
	option network 'lan'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid '<NEW-SSID5G>'
	option encryption 'psk2'
	option isolate '1'
	option key '<SSID-PASSWORD>'
	option network 'lan'
	option ifname 'phy0'

(ref D*) Perform router reboot
and the original do not show up anymore. The 2.4G band shows up immediately after reboot <MYSSID2.4G>
Wireless config is the same

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel 'auto'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel 'auto'
	option band '2g'
	option htmode 'HE20'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<MYSSID2.4G>'
	option encryption 'psk2'
	option key '<SSID-PASSWORD>'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '<MYSSID5G>'
	option encryption 'psk2'
	option key '<SSID-PASSWORD>'
	option network 'lan'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid '<NEW-SSID5G>'
	option encryption 'psk2'
	option isolate '1'
	option key '<SSID-PASSWORD>'
	option network 'lan'
	option ifname 'phy0'

(ref D*) after fixing the issue (steps at the top)

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel 'auto'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel 'auto'
	option band '2g'
	option htmode 'HE20'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'got ne mo dat wifey'
	option encryption 'psk2'
	option key 'mother8organize-OBLIGATE8ma.doare!buca'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'got ne mo dat wifey-5G'
	option encryption 'psk2'
	option key 'mother8organize-OBLIGATE8ma.doare!buca'
	option network 'lan'

thank you kindly to this community for your hard work and helping with all these issues we all face.

I have definitely been going through the same issue. The steps "kinda" solve the issue since forcing it on channel 36 shows the SSID. But it loses access WAN from ethernet.
Now to contribute and fix this issue I will try crawling through the forums but have you made any progress on this? @neapasianwrt

An interesting find also is that after the SSID for 5g is discoverable the host name that is usually picked up by openwrt shows up as ? (so not read correctly basically). Surface level overview seems that its an 5g Radio driver issue from reading headlines of community forums