5 Mhz bandwith option?

Hello,
is it possible to reduce the bandwidth in the 5 GHz band to 5 or 10 Mhz?

I see only the options 20 Mhz or 40 MHz in the web interface, but I know
that some routers also provide the option for lower bandwidths.

Lower bandwidth -> less interference -> more channels -> longer range
(if you don't need a very high speed).

Any comments welcome!

Uwe

Sub-20MHz channels are only configurable via debugfs and are not supported by LuCI or any of the standard Linux wireless utilities. Try echo 5 > /sys/kernel/debug/ieee80211/phy0/ath9k/chanbw on both sides of a working p-t-p link.

1 Like

How to execute this comand..?

I remember there were patches for this on the ath9k driver at least. You could add "option chanbw 10" (or 5) to /etc/config/wireless

I didnt check, but are those patches still part of the mac80211 kernel module??

This actually improves your connections, bandwidth, speed, etc? is 5Ghz so used on all channels where you live ? Did you have problems with devices when you changed to 5/10Mhz band ? Which channel do you use?

It is really interesting to me this, where I live there almost no 5Ghz signals around. I am in typical very populated area city.

Moving to the 5Ghz band would be my suggestion too in a crowded 2.4Ghz area. A simple Dual band AC Lede compatible router could be found for under 20 USD.

Using half (10Mhz) or quarter channel bandwidth will give slower speeds, but might still work better due to less interference.

I could not find the references, but I think the 5 and 10Mhz bandwidth was dropped from the official ieee80211 specs.

I think that would be a good option, it is used by the ham radio guys for their hamnet :wink:

Should still work on Atheros chips.

I was using 5ghz, since about a year with no problems... I have a LOT of SSID's around with a lot of signal and almost no one have 5ghz. some ISP new routers but less than 10 and usually on same channels.
I have fast transmissions of multimedia from computer-tv just using wifi... works very well.

i have it working on 5 and 10 mhz chainbw, but I cannot make work it on channels -1 and -2, any info:

iw phy0 info
Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	max # scan plans: 1
	max scan plan interval: -1
	max scan plan iterations: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports AP-side u-APSD.
	Device supports T-DLS.
	Available Antennas: TX 0x3 RX 0x3
	Configured Antennas: TX 0x3 RX 0x3
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
		 * outside context of a BSS
	Band 1:
		Capabilities: 0x11ef
			RX LDPC
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 8 usec (0x06)
		HT TX/RX MCS rate indexes supported: 0-15
		Frequencies:
			* 2397 MHz [-2] (22.0 dBm)
			* 2402 MHz [-1] (22.0 dBm)
			* 2412 MHz [1] (22.0 dBm)
			* 2417 MHz [2] (22.0 dBm)
			* 2422 MHz [3] (22.0 dBm)
			* 2427 MHz [4] (22.0 dBm)
			* 2432 MHz [5] (22.0 dBm)
			* 2437 MHz [6] (22.0 dBm)
			* 2442 MHz [7] (22.0 dBm)
			* 2447 MHz [8] (22.0 dBm)
			* 2452 MHz [9] (22.0 dBm)
			* 2457 MHz [10] (22.0 dBm)
			* 2462 MHz [11] (22.0 dBm)
			* 2467 MHz [12] (22.0 dBm)
			* 2472 MHz [13] (22.0 dBm)
			* 2484 MHz [14] (22.0 dBm)
	valid interface combinations:
		 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
		   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

the log when i set one of this two channels

Fri Oct 16 11:47:35 2020 daemon.notice netifd: radio0 (5255): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Fri Oct 16 11:47:35 2020 daemon.notice netifd: radio0 (5255): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path (/proc/exe)
Fri Oct 16 11:47:35 2020 daemon.notice netifd: radio0 (5255): Command failed: Invalid argument
Fri Oct 16 11:47:35 2020 daemon.notice netifd: radio0 (5255): Device setup failed: HOSTAPD_START_FAILED

channels -1 and -2 does not work at all

it only work in monitor mode is thi a wpad or hostapd problem?

iw dev
phy#0
	Interface wlan0
		ifindex 14
		wdev 0x9
		addr xxxxxxxx
		type monitor
		channel -2 (2397 MHz), width: 20 MHz (no HT), center1: 2397 MHz
		txpower 22.00 dBm

Because they are not in the International "unlicensed"/"licensed by regulation" portion of the 2.4. GHz band, hence inaccessible (that's the easy answer).

(Please note using a radio of of it's manufactured spec is illegal - I'm not considering the Amateur Licence, which the router can't guess you possess.)

  • I'm curious, does it work on channel 0?
  • Are you even able to set channels: -2, -1 and 0 on your OpenWrt device?

hi ,yes (it work on channel 0) . 0 is the only one that is up , sometimes not, and sometimes up and down until it goes down again.
I'm just curios to understand how it works.
also in luci channel -1 = 255 and channel -2 =254

hi, i found a way to make it work. but i don't like it. because after a reboot the channel switch to another one. anyway that how i did that, via command line.

 iw dev
phy#0
	Interface wlan0
		ifindex 6
		wdev 0x2
		addr xxxxxxxxxxx
		 ssid OpenWrt
		type AP
		channel 1 (2412 MHz), width: 20 MHz (no HT), center1: 2412 MHz
		txpower 22.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	0	0	0	0	0	0		0
:~# ifconfig wlan0 down
:~# iw dev wlan0 set freq 2397
:~# ifconfig wlan0 up
:~# iw dev
phy#0
	Interface wlan0
		ifindex 6
		wdev 0x2
		addr xxxxxxxxxx
		ssid OpenWrt
		type AP
		channel -2 (2397 MHz), width: 20 MHz (no HT), center1: 2397 MHz
		txpower 22.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	0	0	0	0	0	0		0

any way to make this working after a reboot?