4g usb not seen in /dev/

I had an installation in 19.07.06 with 4G usb stick Huawei 3372 (stick mode, non-Hilink). TheCF card is malfunctioning and i got a new one. Once i flashed 19.07.07 i got an error message on interfaces for missing packages in wwan. No matter how many times i tried it did not help and i decided to create the 4G by hand. I plug the usb and i can see it found in lsusb:

root@OpenWrt_alix: ~ $ lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
**Bus 001 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard**
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@OpenWrt_alix: ~ $

I cannot find it in /dev/ as usb device:

root@OpenWrt_alix: ~ $ ls /dev/
bsg                 loop7               tty1                tty26               tty42               tty59               ttyS3
bus                 memory_bandwidth    tty10               tty27               tty43               tty6                ttyS4
console             network_latency     tty11               tty28               tty44               tty60               ttyS5
cpu                 network_throughput  tty12               tty29               tty45               tty61               ttyS6
cpu_dma_latency     null                tty13               tty3                tty46               tty62               ttyS7
full                nvram               tty14               tty30               tty47               tty63               ttyS8
gpiochip0           port                tty15               tty31               tty48               tty7                ttyS9
hwrng               ppp                 tty16               tty32               tty49               tty8                urandom
kmsg                ptmx                tty17               tty33               tty5                tty9                vcs
log                 pts                 tty18               tty34               tty50               ttyS0               vcs1
loop-control        random              tty19               tty35               tty51               ttyS1               vcsa
loop0               rtc0                tty2                tty36               tty52               ttyS10              vcsa1
loop1               sda                 tty20               tty37               tty53               ttyS11              watchdog
loop2               sda1                tty21               tty38               tty54               ttyS12              zero
loop3               sda2                tty22               tty39               tty55               ttyS13
loop4               shm                 tty23               tty4                tty56               ttyS14
loop5               tty                 tty24               tty40               tty57               ttyS15
loop6               tty0                tty25               tty41               tty58               ttyS2
root@OpenWrt_alix: ~ $

By opening the config file for networking from the backup it has:

config interface 'wwan'
	option proto 'ncm'
	option ifname 'wwan0'
	option apn 'myq'
	option mode 'preferlte'
	option delay '5'
	option pdptype 'IP'
	option ipv6 'auto'
	option dialnumber '*99#'
	option service 'auto'
	option device '/dev/ttyUSB0'

Why i cannot see anything in /dev/ for USB?

modeswitch, and the device specific packages installed ?


modeswitch solved the situation

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.