4g router in bridge mode connected to OpenWrt router

#What I like to accomplish: internet access via OpenWRT interface.
using a Huawei B 715 router in bridge mode as my gateway/modem to the internet, connecting it to OpenWRT router. I am using the latest firmware.
LAN is
B 715 is
I have no clue which interfaces I have to create for this set up in OpenWRT.
Pointing me in the right direction is most appreciated .

The default OpenWrt configurations usually have a WAN interface. I assume you would connect it to the router. To reach the configuration web UI on the B 715 you need to add another interface using the same physical interface (or using the @wan alias) with the static address 192.168.8.x and netmask (I guess). X can be between 2 and 254.

Okay, I had a working solution with a E 3372 stick using DMZ.
But now I am using bridge mode and Ethernet cabling and I assume it is done differently.
Is it a very uncommon set up?

Maybe someone else has a similar set-up I will describe mine a bit here:
I am using a Huawei B 715s-23c router as a "modem". I turned off dhcp, firewall, wlan, but I am using DMZ.
Next I connect my Huawei B 715s-23c to my OpenWRT router with ethernet cable. I am using a LAN Port on Huawei and WAN port on OpenWRT. '

My network address schema:

  • Huawei B 715s-23c: As I wrote DHCP is disabled and my machine has
  • DMZ has
  • everything else is disabled because it is done by my OpenWRT router.

I am using OpenWRT/LEDE 18.06.01.
For your convenience I post screenshots:

My firewall settings:


Last but not least my LAN settings:



Most of 4G dongle/router do not offer (at least Huawei - do not offer bridge mode), so above set-up is working just fine. In the openWRT documentation this set-up is descriped here: Poor Man's Bridge Mode.

Huawei B 715s-23c offers a real bridge mode. As soon as you enable it almost all functionality of the hilink-router is switched off.
My poor man's brigde mode set-up is not working anymore in my openWRT router. (of course it does not). Unfortunately I am not capable to do the right modification to use full bridge mode from my Huawei B 715s-23c router.
Again documentation is not helping much: Bridge Mode.
Maybe someone already got the same set-up and can help. Thank you.

Did you ever get this figured out?

The following works for me for an ISP (DNA) that hands out a /64 prefix.

  1. Set B715 to bridge mode.
  2. Connect openwrt router WAN to B715 LAN4 (=WAN). Make sure no other ethernet connections on B715.
  3. Verify that ipv4 works.
  4. Enable relay mode for ipv6 (note, wan6 must be configured via CLI, LUCI doesn't support this):
config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'wan6'
	option interface 'wan6'
	option ignore '1'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'
	option master '1'
  1. Reload odhcpd.
service odhcpd reload
  1. Verify that WAN6 gets ipv6 address and then verify connectivity.

And that's it for me at least. It's worth noting that I never managed to get B715 working in the regular routing mode with an openwrt box in between. I suspect B715 did not relay all ipv6 related packets to LAN leading to the issue. My clients were able to get a global ipv6 address, but no packets routed back from B715.

EDIT: Oh yeah, I als changed the openwrt lan to other subnet than the b715. Mine's on