4G/LTE Modem mode - connection over PPP

Hi,
I got a 4G/LTE modem ZTE MF823 switched into "modem mode" (0016) (as per this post) which do not load web management and is possible to connect to the internet using ppp protocol and APN specified. Thanks to that, you can get external IP address in dongle attached to the router.

Its working on Draytek router over PPP as follow.

I fould like to replicate this in OpenWRT to get an interface that connect over PPP (with APN) but struggle to sort this out.

Tried
[OpenWrt Wiki] Use 3g/UMTS USB Dongle for WAN connection
and
[OpenWrt Wiki] How to use LTE modem in QMI mode for WAN connection

Modem is not in QMI mode.

When trying to select PPP protocol there is no APN settings etc. that are sent.

Tried 3g proto, but it doesn't seams to connect. Any ideas?

What forces you to use PPP instead of QMI or MBIM?

QMI don't see the device. Device is only in /dev/ttyUSB1 USB2 and USB3 not /dev/cdc-wdm0

any luci-proto-mbim?

I tried NCM but when set all up in Network > Interfaces
got error "Unable to determine interface name" or (despite that interface is visible) shortly after "Network device is not present".

Please switch it to QMI or MBIM and show the output of cat /sys/kernel/debug/usb/devices

current state

T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=19d2 ProdID=0016 Rev=50.09
S:  Manufacturer=ZTE,Incorporated
S:  Product=ZTE Technologies MSM
C:* #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=83(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=85(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

cannot switch to mbim as just after the switch dongle switch back to cdc mode

output for qmi

T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  9 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=19d2 ProdID=1402 Rev=50.09
S:  Manufacturer=ZTE,Incorporated
S:  Product=ZTE Technologies MSM
S:  SerialNumber=1234567890ABCDEFCP261718SKYDWQ5II0PESHF3BW707_9C64&&&&&&&&&&&&&0
C:* #Ifs= 5 Cfg#= 1 Atr=a0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=83(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
E:  Ad=85(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
I:* If#= 4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=42 Prot=01 Driver=(none)
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

despite showing signal and showing as connected, there is no internet and there is no external IP as I am expecting.

This means that QMI driver is loaded and you should have /dev/cdc-wdmX device.
Check the actual device name and proceed with the configuration according to https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle

QMI mode is not permanent. After reboot its reverting to standard.
also, despite QMI showing connected there is no internet and IP on wwan0 is 192.168.4.4 hence not external as I got on PPP on Draytek, this is why I want to use PPP mode for it.

Please show the interface configuration from /etc/config/network
If the mode change is not permanent you will need to find a workaround for that.

Thanks, but
QMI not an option, as not able to get this perment and most of the time is changing to quickly to apply anything on openwrt, hence passed on that for now.

luci-proto-3g (via /dev/ttyUSB2) managed to get connection but not stright away. What was important to setup the interface (run it, ans see that there are packages on RX and TX flowing despite lack of IP) and do the reboot. After reboot connection been established and external IP provided. (tip: set dial number like *99# etc.).