40MHz 802.11N setup saved but is 20MHz wide

Is this a bug, where are bugs reported... I setup an 802.11N channel to 40MHz wide, save and apply setting. I use Acrylic Wifi Home to monitor the channel and its 20MHz wide. I'm using OpenWrt 18.06.0 r7188-b0b5c64c22 with Linksys wrt1900ACS. The original OEM firmware set to 40MHz always showes a 40MHz wide 802.11N channel from Acrylic wifi monitoring.

That's expected behaviour, 40 MHz channels are only actually available if there is no channel overlap with other APs (and that is basically impossible in the 2.4 GHz band, unless you're quite literally in the sticks and ~300-600m away from the next house).

3 Likes

Not sure if that is correct then lots of router manufacture's firmware is wrong. As I type this, I'm looking at a near-by 40MHz 802.11N signal now. It's using channels 1-8! You'll never get 40MHz channels knocking down the bandwidth but the firmware says 40MHz channel is saved. I'm using Acrylic WiFi to monitor signals. Is this a spec open to interpretation I wonder?

Also, there is co-channel interference anyhow. Not going to make a big difference keeping the channel at 20MHz. There will always be co-channel interference since the spectrum is crowded...

Unless you've got a multi-thousand-dollar or a hundred-pound boat anchor of a spectrum analyzer, what consumer-grade analyzers generally show is what the AP reports as capabilities and not a measure of the true bandwidth in use. They may draw pretty pictures on the screen, but they look in the information broadcast by the AP for numbers and draw a comforting curve from those numbers.

It may be that the OEM firmware is optimistically showing potential bandwidth, but it will still fall back to 20 MHz as soon as a connection is established with a client.

A expensive instrument is not need to measure the bandwidth, cus yes the radios tell you the configuration. I consider this a firmware bug since it says it bandwidth is 40MHz but its still using 20MHz channel.

I just fired up Wifi Analyzer (on my Android tablet) and its show the same thing... a 20MHz channel although the firmware says the setting is 40MHz. I've never seen a wifi router that reports 40MHz setting but is actually outputting 20MHz.

Definitely a 20MHz only channel.

I compare the 802.11AC bandwidth setting to how 802.11N bandwith setting work. Just made a change to my 802.11AC from 80MHz bandwidth to 40MHz bandwidth and it works. Unlike 802.11N it doesn't change to 40MHz bandwidth, 802.11N only uses 20MHz bandwidth (a slower speed compare to 40MHz).

2 GHz drivers are required to drop to 20 MHz if another AP is detected in the extended channel. If the stock firmware didn't do that, it has a bug.

The "noscan" option can be set on the radio to force 40 MHz even if another AP is detected. This is seriously not recommended. It is likely to reduce the performance of your network as well as your neighbors.

Ok, what your saying “if an adjacent channel exist, stay at 20MHz” is open for interpretation. If your in any urban or suburban area there are always other radios on the same channel, i.e. co-channel, or on an adjacent channel. We only have 3 channels in the use that do not overlap in bandwidth, channels 1, 6, and 11 in 802.11N. If my signal to noise is high enough 40MHz bandwidth works just fine. Not using 40MHz is a waste of bandwidth. It should go to 40MHz if I set it that way. Moreover, if the S/N ratio is bad go to 20MHz. But you will really need a stronger signal that over powers your connection for that, highly unlikely.

WiFi 802.11N uses spread sprectrum, i.e. the frequency hops this is why it’s ok to have co channel and adjacent channel radios on the same channel. Each radio hops to different frequencies eliminating interference. I could go on but my thumbs are tired. There is No reason to not use the 40MHz channel.

You need to set option noscan 1 to enforce the use of 40MHz channels without checking for overlapping adjacent BSSes. Until very recently that option was not exposed in the gui, it was added a few weeks ago to master but is not part of a release iirc.

So, via SSH you need to perform:

uci set wireless.@wifi-iface[0].noscan=1
uci set wireless.@wifi-iface[1].noscan=1  # if you have a 2nd radio
uci commit wireless
wifi up
2 Likes

While "old" 802.11 modulation was "spread spectrum", this is not the case with 802.11n or 802.11ac, which typically use BPSK, QPSK, or higher-order QAM modulation.

It is likely in your best interest to disable legacy rates (at least 802.11b, if not 802.11g) as well for a variety of reasons, including "beacon pollution".

"Part 15" of the FCC regulations in the United States is not open to such wishful interpretation. It includes, for example

(b) Operation of an intentional, unintentional, or incidental radiator is subject to the conditions that no harmful interference is caused and that interference must be accepted that may be caused by the operation of an authorized radio station, by another intentional or unintentional radiator, by industrial, scientific and medical (ISM) equipment, or by an incidental radiator.

and that your device carry the notification

This device complies with part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) This device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause undesired operation.

Operating with a 40 MHz bandwidth will cause "harmful interference" when there are other stations operating on adjacent channels. Willfully doing so violates that regulation.

Further, if you have more than one AP, both trying to operate with 40 MHz bandwidth, you will cause yourself co-channel interference.

2 Likes

Ok, 802.11N is backward compatible with G, A, B etc. I always disable, via the firmware settings, the old G WiFi since I have no radios operating on that technology. So yes as u and I have said that uses spread spectrum technology.

Now the newer 802.11N uses OFMD modulation (same as cell phone technology) on a 20MHZ or 40MHZ channel. OFDM assigns the radio to a subcarrier, aka sub-channel, which is orthogonal to other sub-channel. Essentially the other sub-channels are frequency nullified with the radio operating on a sub-channel. This is how interference is eliminated whether 20MHZ or 40MHZ channel.

If ur talking about interference describe by FCC WiFi is inherently built to handle interferes on co channel or adjacent channel. No reason to not use 40MHz channel on 802.11N. WiFi is design for multiple radios the same channel or adjacent channel.

Incorrect regarding the adjacent channel statement...you assume the users of the adjacent channel are also using N...and for that matter, you assume that the technology in use on the adjacent channel is 802.11n...or even WiFi. You even make that assumption for the channel in question.

Also, you may be shocked to realize, WiFi is not the primary use of this band, so WiFi users MUST accept interference from the other [NON-WIFI] users of the band.

Believe it or not, the microwave oven in your local restaurant has priority on the band over the WiFi.

2 Likes

Ok, all what you have said in the last post is trivial information. That’s why the modulation schemes in the 2.4GHz range are designed to handle interference.

IMHO, today WiFi is mostly used in that range. 802.11N is very popular and prices for these routers are cheap. Other technologies, Bluetooth, microwave oven (1 freq), wireless phone (if still use landline) are in the 2.4GHz band. Your WiFi is not likely to be effected by these other technologies due to the modulation scheme. Other higher power 802.11ABCN routers, if they are in your area are likely to knock you off a channel especially when your reception is weaker that the interference.

The point is OpenWrt 802.11N has implemented 40MHZ bandwidth essentially turned off. There will always be interfering radios by design.

Folk, take a look at any OEM WiFi router out there. If u set the bandwidth to 40MHZ, it does it. OpenWRT WiFi routers spectrum is the only 1 not using 40MHz bandwidth, unbelievable u would throw away half your bandwidth. Your interpreting the bandwidth radio operation all wrong.

How about this.
The standard says that it should check for interfering channels, and MUST fall back to 20MHz if it does not pass the test.
Here is a good summary:
https://www.smallnetbuilder.com/wireless/wireless-features/31743-bye-bye-40-mhz-mode-in-24-ghz-part-1

Openwrt complies with that standard by default, as it should.
If other OEM firmwares do not, shame on them, but what is your point?
You’ve been told at least 3 times now how to force it to 40MHz (even though this is against the standard).

I’ve gone ahead and marked the solution for you as this topic has reached its logical conclusion.

There are no [multiple] modulation schemes on anything but 802.11, and I've noted WiFi's not the primary user. You go on to disagree:

Inaccurate again; and most of your statements are opinion. Last I checked, most people have WiFi, Bluetooth and microwaves, though. I've also seen 2 microwaves, one interferes, one doesn't (different frequencies and/or harmonic leakage). So, no debate here. I'll just agree with @lantis1008 -

Inaccurate again. My device uses 40MHz all the time...when the band isn't congested. I do not have to force 40MHz for this to occur. I simply switch to 40MHz, and when needed (and the band's free), it switches.

This is illegal in most cases; and the manufacturer is in violation. Search this community's threads. I (and others) describe why.

I'll be proposing that this thread be closed if we continue into illegal interferance, as the community rules don't support discussion of any other illegal thing. Causing electronic interference is illegal in most countries. We already have a lot of problems with devices because of the fear of malicious actors with 3rd party software...with a lack of knowledge of the Communications Act.

Your comments "illegal interference" is hilariously funny. Wifi 802.11 was made to operate co-channel, i.e. 2 or more radios on the same channel. There are 11 channels operational in the USA, all wifi devices share the bandwidth on multiple channels. I've explained OFDM, when its necessary to download or upload, the radio is assigned a sub-carrier channel (eliminating or null) any interferes aka radios on the same channel. It appears you guys have very little background or foundation is wireless communication.

Now I will set my router to a fixed 40MHz like all my other routers I've ever used. OpenWRT throws away half of 802.11N bandwidth.

Various technologies exist in 802.11n to prevent operation of 40 MHz if neighboring networks stand to be too negatively affected.
This is sometimes called “Safe Neighbor” technology. Generally, it’s good practice to only enable 40 MHz mode in 2.4 GHz if you are in an isolated area where neighboring networks won’t be negatively affected.

https://www.cwnp.com/802-11n-2040-mhz-bss-mode-rules/

LOL...passed my Technician's Exam with a perfect score...and so forth. And haven't electrocuted myself yet servicing a radio...or transmitting with them...to a couple hundred watts...

Studied in school...

They haven't took my license yet for experimenting in the low 2.4GHz...like interfering with people on channels -1 - 8...so I'd say I'm doing pretty well with my knowledge.

Oddly again, though, I'm aware that I'm a primary user in that portion of the band because of that...I think you're incorrect again, and just have mostly unfounded opinions.

And what occurs when you've opened YOUR RADIO to 40MHz, and all the other so-called "co-channel" operators are playing fair at 20 MHz???

You honestly believe that doesn't interfere...

(I'm wondering why there's non-overlapping channels 1, 6 and 11 fully clear...I can pick a channel in between like 2, 3, 4, 5, 7, 8, 9 or 10 and not interfere with 1, 6 and 11 then...WOW...if it were only this easy!!!) :thinking: :man_facepalming: