30 second internet drops/latency

I'm experiencing some bizarre behavior on my setup. 99% of the time it works great, but every couple of hours I will get these ~30 second internet outages. By that I mean there doesn't appear to be a time correlation with when the drops occur, it just happens once or twice every two hours. What's even more strange is that pings to google DNS go through without issues. We have connectivity, but it just seems to lag. Making the issue even stranger is that when I connect to openwrt to troubleshoot, the issue will clear itself early.

For example, I'll be playing a game and it will cut out so I'll switch to my browser to connect to openwrt and while openwrt will take a little bit longer to load, the internet will come back at the same time the luci login screen appears. Typically within 5 to 10 seconds. Whereas if I don't connect to the router it will take much longer to come back up.

There are absolutely 0 logs that I've found that correlate to this problem. There are literally none in the system log that line up with the timing of the issue.

Well, you explained your problem, but you didn't give literally any details, whatsoever, about your setup or settings. Do explain your entire setup and what settings you are using.

1 Like

Raspberry Pi 4B 1gb
Alfa AWUS036ACM USB wireless card on powered USB hub
Fios 200mbps service that had no issues like this prior to running openwrt

Firewall Config
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'wlan'
list network 'lan'

config zone
option name 'wan'
option output 'ACCEPT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option forward 'REJECT'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config rule
option name 'Support-UDP-Traceroute'
option src 'wan'
option dest_port '33434:33689'
option proto 'udp'
option family 'ipv4'
option target 'REJECT'
option enabled 'false'

config include
option path '/etc/firewall.user'

Network Config
config interface 'wan'
option device 'eth0'
option proto 'dhcp'
option hostname '*'

config interface 'wlan'
option proto 'static'
option ipaddr '192.168.66.1'
option netmask '255.255.255.0'
option device 'wlan0'
option type 'bridge'

Wireless Config
config wifi-device 'radio0'
option type 'mac80211'
option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-2/2-2.3/2-2.3:1.0'
option channel '48'
option band '5g'
option htmode 'VHT80'
option country 'US'
option cell_density '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'wlan'
option mode 'ap'
option ssid 'OpenWRT'
option encryption 'psk2'
option key 'My Eyes Only'
option max_inactivity '0'

config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
option band '5g'
option htmode 'VHT80'
option country 'US'
option cell_density '0'
option channel '36'
option disabled '1'

Update on this. I was incorrect in saying I could still ping while this occurred. It is extreme latency to the point of page connections dropping and giving bad dns config errors. Pings will make it through sporadically so it's not a 100% drop rate.

Does anyone have any pointers?

Did you ever get to the bottom of this as I am having almost the exact same issue except openwrt is installed on my router. I get complete dropouts every hour like clockwork.

Linksys WRT3200 22.03 Snapshot

I unfortunately did not. But I did find others with the same issue as well, so it appears to be related to the driver. I tried multiple USB cards and literally none of those drivers were stable as APs. Sorry for the bad news. I didn't want to build a small PC as a wifi router, so I dropped the whole project and bought an off the shelf router. At some point I may try openwrt on the router or build an AP with some of the smaller power efficient components available today.