23.05.0 Wifi Too Slow and Not stable. Tested Multiple Devices MT7620 and MT7621

Configured OpenWRT 23.05.0 on multiple devices, including the MT7621 (Netgear R6260) and MT7620 (TPLink Archer C4 V4). Unfortunately, I encountered significant issues with internet speed, especially on the wireless networks, where the speed was severely lacking. In comparison, the wired connection was 25% slower. To validate my concerns, I tested the same setup with two other basic routers using stock firmware, and the results were notably better.

Here are the details of my tests:

Test Cases:

  1. Nokia G-2425G-A Fiber N Mode:
  • WiFi Speed: 250Mbps (2.4GHz)
  1. Mercusys MW325R in Bridge Mode to Nokia, Wireless N Mode:
  • Received Speed: 270Mbps (2.4GHz)

OpenWRT Tests:

  1. MT7621 Bridge to Nokia:
  • 2.4GHz Speed: 10Mbps
  • 5GHz Speed: 60Mbps
  1. MT7620 Bridge to Nokia:
  • 2.4GHz Speed: 10-20Mbps (similar to 7621)
  • 5GHz Speed: 50-70Mbps

Tried resetting routers multiple times. Software Offloading, Packet tracing, Country etc... tried. Tried installing snapshot compiled locally. Tried installing 23.05-rc builds. The below configurations are on Freshly installed setups.

Configurations

TPLink Archer C5 V4

/etc/config/network

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
	option proto 'pppoe'
	option device 'eth0.100'
	option username 'xxxxxxxxxx@airtelbroadband.in'
	option password 'xxxxxxxxxxxxx'
	option ipv6 'auto'
	option metric '20'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '0 1 2 3 7t'

config switch_vlan
	option device 'switch1'
	option vlan '2'
	option ports '4 7t'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '0'
	option cell_density '0'
	option country 'IN'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Archer-C5-V4-5G'
	option encryption 'psk2'
	option key '0123456789'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/10180000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '0'
	option cell_density '0'
	option country 'IN'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Archer-C5-V4'
	option encryption 'psk2'
	option key '0123456789'

Netgear R6260

/etc/config/network


config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan.100'
	option proto 'pppoe'
	option username 'xxxxxxxx@airtelbroadband.in'
	option password 'xxxxxxxxx'
	option ipv6 'auto'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '100'
	option name 'wan.100'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'
	option country 'IN'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'NG-R6260'
	option encryption 'psk2'
	option key '0123456789'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'NG-R260-5G'
	option encryption 'psk2'
	option key '0123456789'

I have the exact same issues on my Netgear R6850 (which is almost identical to your models). Stock works as expected. I'm come across multiple post like this and no progress has been made.

This is truly frustrating. Acquired Netgear R6850 for the primary purpose of installing OpenWRT.
So far, the abysmally low WiFi speeds hasn't been addressed in all routers with the MT7621 chipset.

The problem is focused in wifi? In wired mode works fine?

(I have a MT7621 router with no wifi, working fine in wired mode).

Those results seem truly dire. I wonder what's going on and hope it is fixable somehow.

From my iPhone 15 I see circa 400Mbit/s download and upload connected indirectly via WDS using RT3200's.

Yes, the problem is ONLY with Wireless or WiFi.
Wired is as expected. However, you don't buy Netgear R6850 for a Wired connection.
It promises 300mbps on Wi-Fi N and 1700mbps on Wi-Fi AC and support for more than two dozen wireless connections simultaneously.

Some snapshot versions had addressed the issue of "Badblocks" but the issue doesn't appear to have been permanently addressed or fixed in the OpenWRT v23.05

I've noticed settings for MediaTek RT2860/RT2860AP after browsing around the stock firmware. This makes me wonder if this is part of the development issues being that it's assumed to be a clone of other R62XX, R63XX, R68XX models firmware wise.