22.03.0 Netgear R7800 UPnP not working


Just upgraded from 21.02.3 to 22.30.0 using auc.

Everything is fine but UPnP no longer appears to be working, my Plex server can no longer use UPnP to open a port for itself.

I have tried uninstalling and reinstalling luci-app-upnp but still no joy. I have miniupnpd-nftables installed.

I notice in syslog I now see this which I haven't before:

Tue Sep  6 11:13:42 2022 daemon.err miniupnpd[4617]: mnl_socket_open() FAILED: Protocol not supported
Tue Sep  6 11:13:42 2022 daemon.err miniupnpd[4617]: Failed to init redirection engine. EXITING

I don't see any miniupnpd daemon running with ps

Any ideas? Considering a fresh install rather than an upgrade at this point.

It is known to be broken. Updated packages will be provided soon.


Ah OK, thanks.

Any idea where I can track progress ?

I've downgraded back to 21.02.3 as UPnP is pretty important for me with Plex, Xboxes, gaming etc.

Can I suggest the release notes are amended to reflect this broken functionality, specifically "Known issues" says "None so far"

I certainly wouldn't have upgraded if I had known about this, and I suspect others as well, so this would help.


I've opened up a GitHub issue about this for tracking purposes (https://github.com/openwrt/luci/issues/5959) since I didn't see one opened up anywhere else, and it's unclear if this PR (https://github.com/openwrt/luci/pull/5839) will resolve the issue.

1 Like

@fireplex Jow has updated the GitHub issue with a pair of PRs for this issue:

LuCI fix: #5961
Package fix: #19320


Crossposting from the GitHub issue:

The System -> Software panel now lists luci-app-upnp as version git-22.250.64651-a61c041 and miniupnpd-nftables as version 2022-08-31-68c8ec50-1. (The previous versions were git-20.332.74200-03c77da and 2.2.3-4.) The dates and commit IDs don't seem to match the GitHub PRs that Jow did, but I suspect they're being pulled from a different system that the Software system is talking to?

In any case, I just tested these new versions, and uPnP seems to be working correctly now. The Services -> UPnP panel shows the redirects:

and the services are visible outside the local network.

For other folks who want to test this, I recommend uninstalling the luci-app-upnp package and dependencies, deleting /etc/config/upnpd and /var/run/miniupnpd.leases, and then reinstalling the package. This will ensure a clean install without any leftover bits.

I'll leave it up to Jow or other OpenWRT folks to close out this issue, and thanks again for the quick response.


The new packages seem to work, but are the dependencies correct? I just installed luci-app-upnp for the first time, and got miniupnpd-iptables as the dependency. But a working install for 22.03 requires miniupnpd-nftables, is that correct?

Manually installing miniupnpd-nftables seems to work for me (at the very least logread doesn't show miniupnpd exiting immediately).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.