22.03.0 Kernel error

Hello, I'm using Netgear R6220 MediaTek MT7621 ver:1 eco:3, with OpenWrt 22.03.0 r19685-512e76967f
I'm recording the following Kernel error:

[101917.745137] ------------[ cut here ]------------
[101917.770012] WARNING: CPU: 1 PID: 1525 at target-mipsel_24kc_musl/linux-ramips_mt7621/mt76-2022-08-26-5ec78e1e/mt7603/mac.c:208 0x82464864 [mt7603e@54c5fffa+0x96c0]
[101917.799607] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt76x2e mt76x2_common mt76x02_lib mt7603e mt76 mac80211 iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY x_tables slhc sch_cake nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact
[101917.800406]  ledtrig_usbport ifb sha256_generic libsha256 seqiv jitterentropy_rng drbg hmac cmac leds_gpio xhci_plat_hcd xhci_pci xhci_mtk xhci_hcd gpio_button_hotplug usbcore nls_base usb_common crc32c_generic
[101918.012095] CPU: 1 PID: 1525 Comm: hostapd Not tainted 5.10.138 #0
[101918.024573] Stack : 00000000 807200d8 809a0000 80000000 00000000 00000000 00000000 00000000
[101918.041398]         00000000 00000000 00000000 00000000 00000000 00000001 827d1928 24074e28
[101918.058223]         827d19c0 00000000 00000000 827d17d0 00000038 80399864 ffffffea 00000000
[101918.075049]         827d17dc 000001e0 807c2868 ffffffff 827d1908 806ef0cc 80000000 806f0000
[101918.091876]         00000009 00000001 00003a98 80000000 00000000 80403190 00000004 80980004
[101918.108708]         ...
[101918.113752] Call Trace:
[101918.113774] [<80399864>] 0x80399864
[101918.125908] [<80403190>] 0x80403190
[101918.133024] [<80007b08>] 0x80007b08
[101918.140139] [<80007b10>] 0x80007b10
[101918.147251] [<8037e984>] 0x8037e984
[101918.154392] [<82464864>] 0x82464864 [mt7603e@54c5fffa+0x96c0]
[101918.166001] [<8007fa1c>] 0x8007fa1c
[101918.173126] [<82464864>] 0x82464864 [mt7603e@54c5fffa+0x96c0]
[101918.184729] [<8002ff38>] 0x8002ff38
[101918.191856] [<82464864>] 0x82464864 [mt7603e@54c5fffa+0x96c0]
[101918.203473] [<80030000>] 0x80030000
[101918.210634] [<82464864>] 0x82464864 [mt7603e@54c5fffa+0x96c0]
[101918.222281] [<825498e4>] 0x825498e4 [mac80211@f1bfef23+0x81220]
[101918.234277] [<82461ac8>] 0x82461ac8 [mt7603e@54c5fffa+0x96c0]
[101918.245949] [<82453018>] 0x82453018 [mt76@421b83ec+0xafc0]
[101918.257070] [<8254a168>] 0x8254a168 [mac80211@f1bfef23+0x81220]
[101918.269024] [<8018e26c>] 0x8018e26c
[101918.276227] [<82453188>] 0x82453188 [mt76@421b83ec+0xafc0]
[101918.287367] [<82507dac>] 0x82507dac [mac80211@f1bfef23+0x81220]
[101918.299398] [<82509770>] 0x82509770 [mac80211@f1bfef23+0x81220]
[101918.311359] [<80099b64>] 0x80099b64
[101918.318538] [<82509b10>] 0x82509b10 [mac80211@f1bfef23+0x81220]
[101918.330528] [<82413cac>] 0x82413cac [cfg80211@2a358bf2+0x45f40]
[101918.342520] [<80573108>] 0x80573108
[101918.349654] [<80571bb0>] 0x80571bb0
[101918.356820] [<804dcd94>] 0x804dcd94
[101918.363943] [<80571220>] 0x80571220
[101918.371108] [<82413bec>] 0x82413bec [cfg80211@2a358bf2+0x45f40]
[101918.383128] [<80572fb4>] 0x80572fb4
[101918.390256] [<80571ef4>] 0x80571ef4
[101918.397384] [<8057285c>] 0x8057285c
[101918.404545] [<805714c0>] 0x805714c0
[101918.411669] [<801a11d8>] 0x801a11d8
[101918.418838] [<80571958>] 0x80571958
[101918.425974] [<80075824>] 0x80075824
[101918.433099] [<804ea358>] 0x804ea358
[101918.440229] [<805715f4>] 0x805715f4
[101918.447352] [<804d3158>] 0x804d3158
[101918.454484] [<80322f50>] 0x80322f50
[101918.461613] [<804d2a54>] 0x804d2a54
[101918.468741] [<804d4fe8>] 0x804d4fe8
[101918.475867] [<800a3548>] 0x800a3548
[101918.483000] [<80322f50>] 0x80322f50
[101918.490127] [<803230f8>] 0x803230f8
[101918.497304] [<80203798>] 0x80203798
[101918.504426] [<804d5570>] 0x804d5570
[101918.511552] [<804d51f8>] 0x804d51f8
[101918.518671] [<804d1e58>] 0x804d1e58
[101918.525787] [<8020226c>] 0x8020226c
[101918.532904] [<80014578>] 0x80014578
[101918.540019] 
[101918.543662] ---[ end trace f35c7604d07f4b01 ]---

Any suggestion?

Thanks,

cervenka,

How did you get your Netgear R6220 MediaTek MT7621 ver:1 eco:3, running on with OpenWrt 22.03.0 r19685-512e76967f?
Did you upgrade? From with version? Which error messages did you see?
Or did you do a clean install?

If the version was below 19.07, you should do a clean install, without 'keep settings', as stated in: https://openwrt.org/releases/22.03/notes-22.03.0#upgrading_to_22030

This error looks like a firewall of Wifi mismatch, as most of the linked modules are nft, ip or apd related.

DG.

DG,
router was upgraded from 22.03.0-rc6, keeping configuration and without error messages.
Cause before I was using it as a dumb AP, I did a clean install with 22.03.0-rc5.
Adding below a further hint, from this morning log:

Sat Sep 24 06:27:28 2022 kern.warn kernel: [40955.484769] Rekeying PTK for STA 66:e4:94:9f:5c:6b but driver can't safely do that.
Sat Sep 24 06:27:28 2022 kern.info kernel: [46215.116264] do_page_fault(): sending SIGSEGV to uhttpd for invalid write access to 00000000
Sat Sep 24 06:27:28 2022 kern.info kernel: [46215.152058] epc = 77dcaef4 in libc.so[77da6000+a9000]
Sat Sep 24 06:27:28 2022 kern.info kernel: [46215.162233] ra  = 77ba79ac in libwolfssl.so.5.4.0.ee39414e[77ac2000+11c000]

I agree with you that seems related to wifi

I've got a wifi network with WPA2 Enterprise configuration. I replaced original "hostapd-basic-wolfssl" with "hostapd-openssl". It may be some correlation with the last log line?

cervenka,

Did you made your own OpenWrt build with openssl instead of wolfssl, or just

These options do work with underlaying kernel routines, so I don't think you just can replace these without more libraries, like: wpad-basic-wolfssl, libwolfssl5.4.0.ee39414e and perhaps more.

DG.

DG,
I installed the build available in firmware selector (I've no time nor available powerful Linux machine for a self-compilation). I'd check hostapd-openssl dependences and they are all installed: libc, libnl-tiny1, hostapd-common, libubus20210630, libopenssl1.1
May be a bug associated to MT7621 processor? ... I'm using R6220 as main rooter but it's plan B solution, before I was using a Ubiquiti EdgeRouter X (again a MT76*) but become instable since 21.02.3 and I was forced to land on R6220... (I'm looking for a more reliable device, probably a X86 based) ... the error appears after some hours of operations, if there is no solution but daily reboot I will do.

A suggestion to developers:
If hostapd-basic-wolfssl it's now the standard build package (cause of WPA3) why not integrate also WPA2/WPA3 Enterprise capability and avoid the replacement needs (for instance, I'm using both WPA3 and WPA2 Enterprise in my network).

cervenka

1 Like