[21.02-rc3] Disabling ipv6 on LAN

I'm trying to disable ipv6 on my LAN, and seem to be stumbling. I initially just set to disabled in LUCI for both my WAN and LAN interface, but when that didn't work tried How to disable ipv6 on the router

But this still doesn't help..

# /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'
        option ipv6 '0'

config interface 'wan'
        option proto 'pppoe'
        option device 'wan.6'
        option username '<>'
        option password '<>'
        option peerdns '0'
        list dns '208.67.222.222'
        list dns '208.67.220.220'
        option ipv6 '0'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
# /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option local '/home/'
        option domain 'home'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list dhcp_option '6,192.168.1.2'
        option dhcpv6 'disabled'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'nas'
        option mac '<>'
        option ip '192.168.1.2'

But I still seem to be receiving ipv6 addresses via DHCP?

# SBC
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether <> brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 42869sec preferred_lft 42869sec
    inet6 fe80::c5e9:b7f5:eb31:b221/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
# Winbox
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Dell Wireless 1830 802.11ac
   Physical Address. . . . . . . . . : <>
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::7dd3:164c:3e7a:4500%30(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.151(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 17 July 2021 11:43:08
   Lease Expires . . . . . . . . . . : 17 July 2021 23:43:11
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 172548676
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-4F-E3-64-48-E2-44-F5-13-C9
   DNS Servers . . . . . . . . . . . : 192.168.1.2
   NetBIOS over Tcpip. . . . . . . . : Enabled
 

I'm quite confused, LUCI shows no active DHCPv6 leases, and according to my pihole it doesn't have a ipv6 address either. Any pointers, am I missing something basic here?

1 Like

Doh.

<10 char>

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.