21.02 on WRT3200ACM

I tried upgrading from 19.07 recently and have had a lot of trouble because of the DSA VLAN stuff. The new guides seem clear, but I couldn't get that working. Anytime I tried, I'd lose connection, and I'd have to reset and start over. It's really hard to tell what I'm doing wrong in these situations. I then tried to see how far I could get with Luci, but when it came to configuring the VLAN, the "save" button didn't do anything.

Is the new VLAN strategy supposed to work on all devices or just some of them?

DSA is a generic subsystem to configure switches on linux, the same procedures and configurations will work on all devices using DSA (offloaded to the extent possible with the drivers). The wrt3200acm should follow the DSA paradigm and syntax as described.

OK, from stock OpenWRT 21.02, all reset that there isn't even a password, I connect via ssh and edit my /etc/config/network to mimic the simpler example here:

Here's the default:

config interface 'loopback'                                                     
        option device 'lo'                                                      
        option proto 'static'                                                   
        option ipaddr '127.0.0.1'                                               
        option netmask '255.0.0.0'                                              
                                                                                
config globals 'globals'                                                        
        option ula_prefix 'fd1b:40eb:2876::/48'                                 
                                                                                
config device                                                                   
        option name 'br-lan'                                                    
        option type 'bridge'                                                    
        list ports 'lan1'                                                       
        list ports 'lan2'                                                       
        list ports 'lan3'                                                       
        list ports 'lan4'                                                       
                                                                                
config interface 'lan'                                                          
        option device 'br-lan'                                                  
        option proto 'static'                                                   
        option ipaddr '192.168.1.1'                                             
        option netmask '255.255.255.0'                                          
        option ip6assign '60'                                                   
                                                                                
config device                                                                   
        option name 'wan'                                                       
        option macaddr '62:38:e0:b7:d0:80'                                      
                                                                                
config interface 'wan'                                                          
        option device 'wan'                                                     
        option proto 'dhcp'        

I delete a few things and add 'wan' to the br-lan:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde1:ddbc:0bdf::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
    option ip6assign '60'      

This works. I add the VLAN stuff:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde1:ddbc:0bdf::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
    option ip6assign '60'                                                   

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'wan:u*'

This doesn't work. "/etc/init.d/network reload" is left hanging and I have to reset the router if I want to connect to it again. I don't know what I'm missing. Anyone know? Thanks.

See the second configuration of https://github.com/openwrt/openwrt/pull/4036#issuecomment-937334319 for guidance, you're not affected by the issues mentioned there.

One thing that tripped me up several times when using Luci for initial set up (with VLANS at least)

After creating vlan filtering on the bridge, save it, but don't apply until you change LAN interface to use device br-lan.1 (or whichever vlan is appropriate to your use case)

in the case of editing /etc/config/network though

config interface 'lan'
        option device 'br-lan.1'
        .... etc

Yeah the thing I'm following from the "Converting to DSA guide" and the Luci screenshot shows a br0.1 but there's no mention of that in the /etc/config/network but I guess that's a fragment and not the whole thing.

I could've spent hours just doing the wrong thing over and over and not tried that. Thanks for finding it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.