2 pppoe connections 1 dynamic with ipv6 and static with ipv4 only

hello, i have using pppoe pt, so 2 connections on 1 ethernet. the problem is, that one i enable the 2-nd connection the ipv6 goes away, if i disaable wan2, the ipv6 works, why?

The second IPv4 should be done as an alias interface on @wan, not a second pppoe connection.

but the problam is that it only works if there are 2 differnet usernames once is generates the dynamic with ipv6 and the second ppoe with 1234@t-online.hu vs 1234@fixip. so we need pppoe

ok, i fixed the 2 pppoe, could you tell me if i have a server 192.168.78.20 and the wan_static should route to 192.168.78.20 and the rest of the lan use the wan , how can i do it?

ok, i used the pbr and it works, i used 2 different ppoe static and dynamic and pbr set as defualt for ppoe static and the ipv6 was only working on dynamic so it is working perfectly. thanks

actually, i did not even needed pbr, simple firewall and network settings:

/etc/config/network:

config interface 'wan'
        option device 'eth1'
        option proto 'pppoe'
        option username '55500000000000111111@fixip'
        option password '1234'
        option ipv6 'auto'
        option keepalive '0 1'
        option metric '10'
        option mtu '1500'

config interface 'wan_dynamic'
        option device 'eth1'
        option proto 'pppoe'
        option username '55500000000000111111@t-online.hu'
        option password '1234'
        option ipv6 'auto'
        option keepalive '0 1'
        option ipv4 '0'    # Disable IPv4
        option metric '1000'   # Higher metric = lower priority
        option mtu '1500'
        option defaultroute '0'

and firewall /etc/config/firewall:

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan_dynamic'

config rule
        option name 'Block-IPv4-WAN-Dynamic'
        option src 'wan_dynamic'
        option proto 'all'
        option family 'ipv4'
        option target 'DROP'
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.