2.4Ghz not working anymore on Archer C5 v1.2 ~c7 v2

My 2.4GHz wifi stopped working.

"Hardware: unknown" does not sound good to me. How do I check if it is a hardware or software issue?

iwinfo

wlan1     ESSID: "open25"
          Access Point: E8:DE:27:7D:20:0A
          Mode: Master  Channel: unknown (2.407 GHz)
          Tx-Power: 17 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: WPA PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

wireless config



config wifi-device 'radio1'
        option type 'mac80211'
        option legacy_rates '0'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option hwmode '11g'
        option channel 'auto'



config wifi-iface 'wifinet1'
        option device 'radio1'
        option ssid 'open25'
        option key '************'
        option mode 'ap'
        option encryption 'psk'
        option network 'lan'

dmesg |grep QCA

[    0.000000] SoC: Qualcomm Atheros QCA9558 ver 1 rev 0
[   15.376091] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
[   15.604243] firmware ath10k!QCA988X!hw2.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
[   15.831785] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
[   16.058654] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
[   16.285284] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
[   16.511642] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
[   16.812947] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed

"Hardware: unknown" is OK, here is what I get on a known working TP-Link Archer C7 v2. The signal is also unknown - that's because there are no wireless clients at the moment, only wired.

# iwinfo
wlan0     ESSID: "t503"
          Access Point: E8:DE:27:F6:28:D5
          Mode: Master  Channel: 56 (5.280 GHz)
          Tx-Power: 20 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -104 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 168C:003C 0000:0000 [Qualcomm Atheros QCA9880]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "t503"
          Access Point: E8:DE:27:F6:28:D6
          Mode: Master  Channel: 5 (2.432 GHz)
          Tx-Power: 15 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -89 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

What's worrying in your case is the unknown channel. Try to set the channel explicitly, e.g. to channel 1.


config wifi-device 'radio1'
        option type 'mac80211'
        option legacy_rates '0'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option hwmode '11g'
        option channel '2'
wlan1     ESSID: "open25"
          Access Point: E8:DE:27:7D:20:0A
          Mode: Master  Channel: 2 (2.417 GHz)
          Tx-Power: 17 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: WPA PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

It looks exactly the same as here when no clients are connected - i.e. 100% normal. Is there anything bad in the kernel or system log? What appears there when clients attempt to connect?

P.S. WPA is broken, switch to WPA2.

Also, try to set the country. Here is my 2.4 GHz config:

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option legacy_rates '0'
	option country 'RU'
	option require_mode 'n'
	option htmode 'HT40'
	option noscan '1'
	option path 'platform/ahb/18100000.wmac'
	option txpower '15'
	option channel '5'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option wpa_disable_eapol_key_retries '1'
	option key 'censored89abc'
	option ssid 't503'
	option encryption 'psk2+ccmp'

it simply does not show up in the available wlan list on my desktop, nor on my mobile.

dmesg

[24538.969626] br-lan: port 3(wlan1) entered disabled state
[25286.544560] br-lan: port 3(wlan1) entered blocking state
[25286.549954] br-lan: port 3(wlan1) entered disabled state
[25286.555682] device wlan1 entered promiscuous mode

Reboot and post the full kernel log and system log after 3 minutes of uptime. After the reboot, but before sending logs, try to scan WiFi access points on your mobile, so that the scan attempt is logged. Also post the full /etc/config/wireless minus passwords.

br-lan: port 3(wlan1) entered disabled/blocking state

Again, that's normal, it enters forwarding state only when clients connect. You can look into the system log to see if there are any scan attempts.

According to your earlier posts, it measures the noise level, so I guess the receiver is OK. Try to scan on the router to confirm this - it should catch at least some neighboring APs. Another good test would be to create a mobile hotspot and see if the router can connect - this would confirm that the transmitter also works.

Also try to reduce txpower - 17 dBm is too much in some countries.

will do after my wives corona only yoga class :slight_smile:

scanning never shows anything even there is tons 2.4GHz of networks - also on my mobile with wifiscanner

OK, you have convinced me that something is broken in the rx chain. So, reboot, it helps surprisingly often.

If you have installed, uninstalled or reconfigured anything on the router recently except /etc/config/wireless, then do a factory reset and rescan wifi and then reconfigure everything from scratch. If this still doesn't help, that would support the conclusion about a hardware problem.

system log
https://pastebin.com/ENiAg63Z

kernel log
https://pastebin.com/vLyJq9hW

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option country 'US'
        option hwmode '11a'
        option htmode 'VHT80'
        option channel '48'
        option path 'pci0000:00/0000:00:00.0'
        option txpower '10'

config wifi-device 'radio1'
        option type 'mac80211'
        option legacy_rates '0'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option hwmode '11g'
        option channel '2'
        option txpower '10'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ssid 'open56'
        option encryption 'psk2'
        option key '*****************'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option ssid 'open25'
        option key '*****************'
        option mode 'ap'
        option encryption 'psk2'
        option network 'lan'

Sorry, I am out of ideas.

I saw a similar problem on my Archer A7 when I moved from snapshot to this release. For some reason, my 2.4 radio was not working. I eventually found that I needed to use radio2 (and I'm sorry but I don't recall how I got radio2) as my 2.4 radio. My wireless config follows in case that helps. Under luci, radio0 shows as "Qualcom Atheros QZA9880 802.11nac", channel and bitrate but radio1 (not using) says Generic 802.11bg and "device is not active", radio2 shows as Generic 802.11bgn and shows the active channel/bitrate

cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
option country 'US'
option legacy_rates '1'

config wifi-device 'radio1'
option type 'mac80211'
option country 'US'
option path 'platform/ahb/18100000.wmac'

config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'Bill Wi The Science Fi'
option network 'lan'
option encryption 'psk2'
option key '***'

config wifi-device 'radio2'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/ahb/ahb:apb/18100000.wmac'
option htmode 'HT20'

config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option wpa_disable_eapol_key_retries '1'
option encryption 'psk2'
option ssid 'Bill Wi The Science Fi'
option key '***'

FWIW, my hardware is also showing unknown and there are multiple devices attached:
root@OpenWrt:~# iwinfo
wlan0 ESSID: "Bill Wi The Science Fi"
Access Point: AC:84:C6:E2:F3:37
Mode: Master Channel: 36 (5.180 GHz)
Tx-Power: 23 dBm Link Quality: 45/70
Signal: -65 dBm Noise: -99 dBm
Bit Rate: 382.2 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11nac
Hardware: 168C:003C 0000:0000 [Qualcomm Atheros QCA9880]
TX power offset: none
Frequency offset: none
Supports VAPs: yes PHY name: phy0

wlan1 ESSID: "Bill Wi The Science Fi"
Access Point: AC:84:C6:E2:F3:38
Mode: Master Channel: 11 (2.462 GHz)
Tx-Power: 24 dBm Link Quality: 51/70
Signal: -59 dBm Noise: -92 dBm
Bit Rate: 52.9 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy1

I have exactly the same problem here on my routers ...

On the WDR3600 that I use as an AP, the 5GHz radio stopped ...
On the WDR4300 that I use as the main router, the 2.4 GHz radio stopped ...

Both in mysterious circumstances, without anything being installed or uninstalled, it stopped nowhere!

I will reinstall both from scratch because I am seeing some problems on my internet too and it is not with the link.

Let me know if that works.

I ordered a 2nd router to get a working setup and will do a system firmware reset on the current box afterwards. I will keep you posted if I make progress.

During the change from AR71xx to ATH79 the wireless pci-e changed so try to reset the wireless config from scratch.

Hi @excogitation...

I took advantage that my two routers were with Luci extremely slow (I believe it is because of the ath79 driver) and completely reinstalled everything, but using the ar71xx driver and now everything is ok again ...