19.07-SNAPSHOT Firewall.user keep reset

hi i manage to open port 23 telnet , however when i tried to edit any file example firewall.user , it manage to save, however each reboot the command will gone, also tried create script, it is ok but each reboot the file will gone.
any way i do wrong or can save the command or file inside telnet ?

BusyBox v1.30.1 () built-in shell (ash)

DISTRIB_DESCRIPTION='OpenWrt 19.07-SNAPSHOT r0-967ab2ed'

OpenWRT official releases all can persist config files just fine.
You need to arrange fixes with your OEM, all official OpenWRT save config just fine.

1 Like

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

any possible to open port 22 and get winscp directly access to file from window ?

as @brada4 and @psherman pointed out, you're asking the wrong people.

but if your device got internet access, wget those files instead.

yes can access to internet , any idea how wokr with wget ?

Failed to send request: Operation not permitted
thinking somewhere was block the wget

it's a http or https request, nothing special about it.
my guess is, you router doesn't have internet access, after all.

@snapshot this Tozed 5G CPE has turned up several times if you search:

As it's a Openwrt SDK forked from Openwrt and nothing that this forum can directly help with, please contact Tozed for the GPL sources of their device.