19.07 -- Report Devices Here That Can't Save Settings

With the availability of 19.07.0 RC images, please help the development team by using this thread to report images that don't save their settings.

If you can, please include the output of

df
cat /proc/mtd

using the preformatted-text button </>

These are "safe" commands to show what file systems are mounted and their sizes. See https://openwrt.org/docs/guide-quick-start/sshadministration for instructions on how to use SSH if you are not familiar with it.

Please also check

1 Like

Thanks to @tmomas for making this editable by all members!

4 Likes

https://openwrt.org/toh/huawei/hg556a

1 Like

What version? A,B, or C?
I Have the three version, and in my case B version do not admit OpenWrt 19.07
I will check out if A and C can't save settings, and I will report it.

1 Like
> HG556a Model A - Do not lose the configuration after turning it off
> 
> 
> BusyBox v1.30.1 () built-in shell (ash)
> 
>   _______                     ________        __
>  |       |.-----.-----.-----.|  |  |  |.----.|  |_
>  |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
>  |_______||   __|_____|__|__||________||__|  |____|
>           |__| W I R E L E S S   F R E E D O M
>  -----------------------------------------------------
>  OpenWrt 19.07.0-rc1, r10649-c4fdb377a2
>  -----------------------------------------------------
> root@OpenWrt:~# df
> Filesystem           1K-blocks      Used Available Use% Mounted on
> /dev/root                 2560      2560         0 100% /rom
> tmpfs                    29896       292     29604   1% /tmp
> /dev/mtdblock4           10944       424     10520   4% /overlay
> overlayfs:/overlay       10944       424     10520   4% /
> tmpfs                      512         0       512   0% /dev
> root@OpenWrt:~# cat /proc/mtd
> dev:    size   erasesize  name
> mtd0: 00020000 00010000 "CFE"
> mtd1: 00ec0000 00010000 "linux"
> mtd2: 0018d128 00010000 "kernel"
> mtd3: 00d32dd8 00010000 "rootfs"
> mtd4: 00ab0000 00010000 "rootfs_data"
> mtd5: 00100000 00010000 "cal_data"
> mtd6: 00020000 00010000 "nvram"
> root@OpenWrt:~#
> 
> HG556a Model B
> 
> It does not support OpenWrt 19.07.0-rc1.

> 
> HG556a Model C - Do not lose the configuration after turning it off
> 
> 
> BusyBox v1.30.1 () built-in shell (ash)
> 
>   _______                     ________        __
>  |       |.-----.-----.-----.|  |  |  |.----.|  |_
>  |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
>  |_______||   __|_____|__|__||________||__|  |____|
>           |__| W I R E L E S S   F R E E D O M
>  -----------------------------------------------------
>  OpenWrt 19.07.0-rc1, r10649-c4fdb377a2
>  -----------------------------------------------------
> root@OpenWrt:~# df
> Filesystem           1K-blocks      Used Available Use% Mounted on
> /dev/root                 2560      2560         0 100% /rom
> tmpfs                    29896       292     29604   1% /tmp
> /dev/mtdblock4           11008       612     10396   6% /overlay
> overlayfs:/overlay       11008       612     10396   6% /
> tmpfs                      512         0       512   0% /dev
> root@OpenWrt:~# cat /proc/mtd
> dev:    size   erasesize  name
> mtd0: 00020000 00020000 "CFE"
> mtd1: 00ec0000 00020000 "linux"
> mtd2: 0018d10c 00020000 "kernel"
> mtd3: 00d32df4 00020000 "rootfs"
> mtd4: 00ac0000 00020000 "rootfs_data"
> mtd5: 00100000 00020000 "cal_data"
> mtd6: 00020000 00020000 "nvram"
> root@OpenWrt:~#

TP-Link WR902AC v1 also have this problem. Here's the output from OpenWrt 18.06, I've done a rollback because the router was unusable, and I have already installed some extra packages. I can install 19.07-rc0 again if it's needed.

BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.5, r7897-9d401013fc
 -----------------------------------------------------
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.8M      2.8M         0 100% /rom
tmpfs                    29.4M    576.0K     28.9M   2% /tmp
/dev/mtdblock4            3.1M    392.0K      2.7M  12% /overlay
overlayfs:/overlay        3.1M    392.0K      2.7M  12% /
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00010000 "u-boot"
mtd1: 00730000 00010000 "firmware"
mtd2: 00152620 00010000 "kernel"
mtd3: 005b0000 00010000 "rootfs"
mtd4: 00320000 00010000 "rootfs_data"
mtd5: 000a0000 00010000 "tplink"
mtd6: 00010000 00010000 "art"
1 Like

I highly doubt that this device is affected by "image too big to save settings".

Please provide the output of the following commands:

df -h
mount

Does not work with me in version A

tp-link tl-wr841n ver 11.1 is not saving changes across reboots..

using the tiny build..

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.0, r10860-a3ffeb413b
 -----------------------------------------------------
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    13.5M     68.0K     13.4M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

root@OpenWrt:~# mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00010000 "u-boot"
mtd1: 003d0000 00010000 "firmware"
mtd2: 0036904b 00010000 "kernel"
mtd3: 00050000 00010000 "rootfs"
mtd4: 00010000 00010000 "art"

D Link DIR 600 also has same issue...

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.0M      3.0M         0 100% /rom
tmpfs                    13.8M    280.0K     13.5M   2% /tmp
tmpfs                    13.8M     60.0K     13.7M   0% /tmp/root
overlayfs:/tmp/root      13.8M     60.0K     13.7M   0% /
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:~# logread | grep jffs2
Mon Jan  6 16:47:23 2020 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
Mon Jan  6 16:47:23 2020 kern.info kernel: [    0.510900] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Mon Jan  6 16:47:23 2020 user.notice kernel: [   12.527850] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
Mon Jan  6 16:49:03 2020 kern.err kernel: [  130.776285] jffs2: Too few erase blocks (4)
**Mon Jan  6 16:49:03 2020 daemon.err mount_root: failed - mount -t jffs2 /dev/mtdblock6 /rom/overlay: Not a tty**
root@OpenWrt:~# logread | grep -i overlay
Mon Jan  6 16:47:23 2020 user.notice kernel: [   12.527850] mount_root: jffs2 not ready yet, **using temporary tmpfs overlay**
**Mon Jan  6 16:49:03 2020 daemon.err mount_root: failed - mount -t jffs2 /dev/mtdblock6 /rom/overlay: Not a tty**

someone help me plzz :expressionless:
tp-link tl-wr841n ver 9 is not saving changes across reboots..

https://openwrt.org/supported_devices/432_warning

1 Like

Hi @h31. Have you been able to install 19.07.02 in WR902AC v1? If so, any tips?

Thanks,
Marcelo

Please use this topic only for what it is intended for: Reporting devices that can not save settings.

For any questions, please open a new topic.

Thanks!

someone help me plz .

D-Link DIR-859

 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2816      2816         0 100% /rom
tmpfs                    29776       284     29492   1% /tmp
tmpfs                    29776        64     29712   0% /tmp/root
tmpfs                      512         0       512   0% /dev
/dev/mtdblock7           11456       428     11028   4% /overlay
overlayfs:/overlay       11456       428     11028   4% /
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00040000 00010000 "bootloader"
mtd1: 00010000 00010000 "bdcfg"
mtd2: 00010000 00010000 "devdata"
mtd3: 00010000 00010000 "devconf"
mtd4: 00f80000 00010000 "firmware"
mtd5: 0018ffc0 00010000 "kernel"
mtd6: 00df0000 00010000 "rootfs"
mtd7: 00b30000 00010000 "rootfs_data"
mtd8: 00010000 00010000 "art"
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.8M      2.8M         0 100% /rom
tmpfs                    29.1M    284.0K     28.8M   1% /tmp
tmpfs                    29.1M     64.0K     29.0M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock7           11.2M    428.0K     10.8M   4% /overlay
overlayfs:/overlay       11.2M    428.0K     10.8M   4% /
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# 
root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /tmp/root type tmpfs (rw,noatime,mode=755)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/mtdblock7 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)

You are not affected by this problem.
Please open a new topic for your problem.

A post was split to a new topic: WRT1900AC / 19.07.2 can't save settings

WHR-G300N v2 keeps resetting settings after reboot.

root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 3072      3072         0 100% /rom
tmpfs                    13808       288     13520   2% /tmp
tmpfs                    13808        64     13744   0% /tmp/root
overlayfs:/tmp/root      13808        64     13744   0% /
tmpfs                      512         0       512   0% /dev
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 0003e000 00010000 "u-boot"
mtd1: 00002000 00010000 "u-boot-env"
mtd2: 003a0000 00010000 "firmware"
mtd3: 00160000 00010000 "kernel"
mtd4: 00240000 00010000 "rootfs"
mtd5: 00010000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "user_property"
mtd7: 00010000 00010000 "art"
root@OpenWrt:~#

version 19.07.2

That's with 19.07.0 or 19.07.1 or 19.07.2?