19.07 -- Report devices here that can't save settings

WHR-G300N v2 keeps resetting settings after reboot.

root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 3072      3072         0 100% /rom
tmpfs                    13808       288     13520   2% /tmp
tmpfs                    13808        64     13744   0% /tmp/root
overlayfs:/tmp/root      13808        64     13744   0% /
tmpfs                      512         0       512   0% /dev
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 0003e000 00010000 "u-boot"
mtd1: 00002000 00010000 "u-boot-env"
mtd2: 003a0000 00010000 "firmware"
mtd3: 00160000 00010000 "kernel"
mtd4: 00240000 00010000 "rootfs"
mtd5: 00010000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "user_property"
mtd7: 00010000 00010000 "art"
root@OpenWrt:~#

version 19.07.2

That's with 19.07.0 or 19.07.1 or 19.07.2?

sorry, 19.07.2 tiny from current link on WHR-G300Nv2 page. Have not tried the other ones (unless you think it would work better).

Thanks for your feedback, I have updated the WHR-G300N v2 dataentry accordingly.

WHR-G300N v2 lose configuration after reboot. I am using the tiny build 19.07.3.

 -----------------------------------------------------
 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------
root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 3072      3072         0 100% /rom
tmpfs                    13808       264     13544   2% /tmp
tmpfs                    13808        64     13744   0% /tmp/root
overlayfs:/tmp/root      13808        64     13744   0% /
tmpfs                      512         0       512   0% /dev
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 0003e000 00010000 "u-boot"
mtd1: 00002000 00010000 "u-boot-env"
mtd2: 003a0000 00010000 "firmware"
mtd3: 00160000 00010000 "kernel"
mtd4: 00240000 00010000 "rootfs"
mtd5: 00010000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "user_property"
mtd7: 00010000 00010000 "art"

Hello.
I also have this problem with WR841ND v9 and 19.07.2 and .3.
Tried also clean install (clean firmware mtd1 partition, tftp 18.06, upgrade to 19.07).

EDIT: What I see the problem is mainly with the Tiny package for 4MB devices.
I just tried to install community build of 19.07.3 and it works OK.
So this is probably the way, as 4MB devices were deprecated...

I have added the WR841ND v9 to the Table above.

1 Like

Netgear "wnr2000 v3" is resetting to stock when rebooted.

OpenWrt 19.07.3, r11063-85e04e9f46
 
 
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 3072      3072         0 100% /rom
tmpfs                    13864        48     13816   0% /tmp
tmpfs                    13864        68     13796   0% /tmp/root
overlayfs:/tmp/root      13864        68     13796   0% /
tmpfs                      512         0       512   0% /dev
 
 
dev:    size   erasesize  name
mtd0: 00040000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 003a0000 00010000 "firmware"
mtd3: 00159440 00010000 "kernel"
mtd4: 00246bc0 00010000 "rootfs"
mtd5: 00010000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "art"

Same issue with XDX RN502J (no config save between reboots).

root@OpenWrt:~# df  
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 3072      3072         0 100% /rom
tmpfs                    14136        72     14064   1% /tmp
tmpfs                    14136        60     14076   0% /tmp/root
overlayfs:/tmp/root      14136        60     14076   0% /
tmpfs                      512         0       512   0% /dev

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00030000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00010000 00010000 "factory"
mtd3: 003b0000 00010000 "firmware"
mtd4: 001485ed 00010000 "kernel"
mtd5: 00267a13 00010000 "rootfs"
mtd6: 00040000 00010000 "rootfs_data"

root@OpenWrt:~# logread | grep jffs2
Thu Feb 27 21:05:24 2020 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=sq
uashfs,jffs2
Thu Feb 27 21:05:24 2020 kern.info kernel: [    0.433249] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMOD
E_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Thu Feb 27 21:05:24 2020 user.notice kernel: [   10.506316] mount_root: jffs2 not ready yet, using temporary tmpfs
overlay
Thu Feb 27 21:05:59 2020 kern.err kernel: [   60.534639] jffs2: Too few erase blocks (4)
Thu Feb 27 21:05:59 2020 daemon.err mount_root: failed - mount -t jffs2 /dev/mtdblock6 /rom/overlay: Not a tty

That's with which 19.07.x relase exactly?

With 19.07.2.

I did a bit more research into the OpenWrt documentation, and figured out that my device is in the 4 Mb flash / 32 MB RAM category, and that was causing the issue. I build a custom image using imagebuilder, removing some packages and it works now, i.e. it saves config between reboots.

Issue present in device Model: TP-Link TL-WDR3600 v1 Architecture: Atheros AR9344 rev 2:

# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /tmp/root type tmpfs (rw,noatime,mode=755)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/mtdblock4 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)

# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.5M      2.5M         0 100% /rom
tmpfs                    60.8M      1.1M     59.7M   2% /tmp
tmpfs                    60.8M     60.0K     60.7M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock4            3.9M      3.6M    244.0K  94% /overlay
overlayfs:/overlay        3.9M      3.6M    244.0K  94% /

# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00010000 "u-boot"
mtd1: 007d0000 00010000 "firmware"
mtd2: 00185dad 00010000 "kernel"
mtd3: 0064a250 00010000 "rootfs"
mtd4: 003e0000 00010000 "rootfs_data"
mtd5: 00010000 00010000 "art"

No, it's not. The tl-wdr3600 has 8 MB flash, which -while not plenty- is sufficient for modern OpenWrt, now and within the immediate future. Your paste shows that you have a 3.9 MB large overlay at your disposal, but at the same time you already filled up 3.6 MB of that, leaving you with only 244 KB 'free' space. With jffs2 needing at least 5 free erase and you being down to 4 and under, that is a problem - you need to reset (firstboot) your device to recovery and keep a closer eye on your flash usage in the future. But your device is not one with systemic flash shortage, as 4 MB flash devices would be. 8 MB isn't much, it needs some attention to keep it at bay, but it is workable.

There must be something wrong with the sysupgrade image. I literally just did a firstboot reset and the device is full and not saving settings between reboots.

I have the same device, no issue here.

Try this builds.

Edimax 3G-6200n z OpenWrt 19.07.2 lost settings after reboot or turnoff. It doesn't create JFFS.

Steps:

  1. Download the latest version OpenWrt 19.07.2 to Edimax 3G-6200n.
  2. Set e.g. the password to the router and/or turn on the WiFi.
  3. Reboot the router with the reboot option in OpenWrt.
  4. The router has no settings previously saved - the status is as right after installing fresh OpenWRT - no password, no WiFi enabled, default settings.

Problem with JFFS.

root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /tmp/root type tmpfs (rw,noatime,mode=755)
overlayfs:/tmp/root on / type overlay (rw,noatime,lowerdir=/,upperdir=/tmp/root/upper,workdir=/tmp/root/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.0M      3.0M         0 100% /rom
tmpfs                    13.8M    284.0K     13.5M   2% /tmp
tmpfs                    13.8M     60.0K     13.7M   0% /tmp/root
overlayfs:/tmp/root      13.8M     60.0K     13.7M   0% /
tmpfs                   512.0K         0    512.0K   0% /dev

root@OpenWrt:~# free
              total        used        free      shared  buff/cache   available
Mem:          28276       14008        5224         344        9044       11872
Swap:             0           0           0
#here I added the password and turned on the WiFi network - the free RAM decreased
root@OpenWrt:~# free
              total        used        free      shared  buff/cache   available
Mem:          28276       15632        3496         368        9148       10236
Swap:             0           0           0
root@OpenWrt:~#

Thanks for your feedback.
Can you determine which is the last working OpenWrt release that is working?

1 Like

Yes, I can if it will be helpfull. I will find free time and check other versions of software for my Edimax.

1 Like

@tmomas, I've checked many versions: 19.07.1, 19.07.0, 18.06.8, 18.06.7, 18.06.6, 18.06.0. In all these versions problem is as I wrote above.
Version 17.01.7 (lede-17.01.7-ramips-rt305x-3g-6200n-squashfs-sysupgrade.bin) works perfect and save settings after reboot.

login as: root
root@192.168.1.1's password:


BusyBox v1.25.1 () built-in shell (ash)

. .. _________
. . /. . . . /\. . . _. . ___ ___. ___
.. /. LE. . /. \. . | |. | __|.. \| __|
. /. . DE. /. . \.. | |__| _|| |) | _|
 /________/. LE. \. |____|___|___/|___|. . . . . . . . . . . lede-project.org
 \. . . . \.. DE /
. \. . LE. \. . /. -----------------------------------------------------------
.. \. DE. . \. /. . Reboot (17.01.7, r4030-6028f00df0)
. . \________\/. . -----------------------------------------------------------

root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock7 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
root@OpenWrt:~# df -h
Filesystem. . . . . . . . Size. . . Used Available Use% Mounted on
/dev/root. . . . . . . .. 2.3M. . . 2.3M. . . .. 0 100% /rom
tmpfs. . . . . . . . . . 14.1M. . 420.0K. .. 13.6M.. 3% /tmp
/dev/mtdblock7. . . . . 384.0K. . 240.0K. . 144.0K. 63% /overlay
overlayfs:/overlay. . . 384.0K. . 240.0K. . 144.0K. 63% /
tmpfs. . . . . . . . .. 512.0K. . . .. 0. . 512.0K.. 0% /dev
root@OpenWrt:~# free
. . . . . .. total. . .. used. . .. free. .. shared. . buffers. .. cached
Mem:. . . .. 28780. . . 16624. . . 12156. . . . 420. . .. 1896. . .. 5708
-/+ buffers/cache:. . .. 9020. . . 19760
Swap:. . . . . . 0. . . . . 0. . . . . 0
root@OpenWrt:~#

Is it any chance to fix this?
I saved these logs from SSH console for all softs which I tested.
If you want more information tell me.

1 Like