19.07.0 wpa3 on r7800

Just I sys-upgraded to 19.07.0 on r7800 and don't see setting for wpa3. How to enable on this router?

It's supported but not in LuCI afaik, so you'd have to set it in /etc/config/wireless directly.

See this wiki page.

It is supported, also in luci, but you need to provide the dependencies --> wpad-openssl or wpad-wolfssl instead of the other variants (wpad-mini, wpad-basic, wpad). WPA3 requires the assistance of one of the aforementioned ssl/ tls libraries, therefore the smaller (default) wpad variants are not sufficient.


@pkgadd what was the talk on the ML about needing to backport LuCI stuff from master to 19.07 then? Have I missed that and was it backported already?

Wasn't keeping tabs on the LuCI repo, just the regular git...

That has already happened, https://github.com/openwrt/luci/commits/openwrt-19.07, but merely improved/ fixed[0] some aspects of WPA3 integration into luci - those changes were not necessary to enable/ use WPA3, that already worked since openwrt-19.07 was branched off.

[0] one could claim them to be mostly cosmetic, not required, but making it easier; among them e.g. the patches to properly display WPA3/ SAE networks.

1 Like