18.06 on Raspberry Pi 3 B+

Thank you @m4r, I will give it a try.
Update: I have built your driver with sources from "master" and everything I need is working.
Many thanks to @m4r

i have built with usb adapter and im supposed to get dhcp but couldn't brows.
and set eth0 to static
usb connected to wan
pi lan connected to pc
i can ssh only google dns

any thing to do with friwall or dns ?

Thanks @m4r; unfortunately, I didn't have luck building the latest snapshot on master with mac80211 reverted to just prior to the backports update. Your r8371 detected Wifi, but seemed to have other bugs, so I wanted to build the latest. Is there a place where the effort to get a stable 3B+ 18.06.1 build is being focused on other than this thread? I tried the issues database, but I couldn't find anything referencing these problems. Do we need a separate RPi branch to work out all these regression bugs? Am I in the wrong place?

@dgilmour77 there is other fix, read this post Brcmfmac failed on Pi3 and Pi Zero I'm testing it now

anyone tried to use wireless as AP?
i tried many things but i couldn't get it work.
I'm on @m4r snapshot build.
:face_with_raised_eyebrow:

I've come back to this after a lengthy gap.
Has anyone had any luck with 18.06.2 on a Pi 3 B+?
I've just given it a quick try tonight, butit won't boot - brcmfmac errors.

No, 18.06.2 still doesn't boot like the comments above.

The latest trunk snapshot will boot and connect to wifi. But I cannot get it to create an AP.

It is here:
https://downloads.openwrt.org/snapshots/targets/brcm2708/bcm2710/

FYI - snapshots do not include luci, so you'll have to ssh to it.

Looks like the raspian folks having the same problems a new kernel:

https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=224931&start=125#p1434906

You already ported 4.14? That is different from the one on your google which shows 4.9.105?

Not me, but it was ported

Hey, so what is the latest version of OpenWrt that I can use on the Pi 3 B model? I need basic wireless AP to be set up, and I would connect it to my ISP issued router via ethernet.

The one being offered to download via the website is the 18.06.02 and it seems this one work work properly.

Pi 3 B or B+?

The topic was about B+, but your post says B. If that's the case then it's best to start a new tipi.

It is 3 B indeed, I didn't see the topic for B so thought this one covers both.

Anyway it seems B doesn't have any issues, everything seems to work out of the box, which are good news! :slight_smile:

Just in case somebody wonders, I just tested the latest snapshot from here: https://downloads.openwrt.org/snapshots/targets/brcm2708/bcm2710/

And creating an AP with my Raspberry Pi 3 B+ is working fine and so far no bootloops.

2 Likes

Great news. Is it working for both 2.4 and 5 GHz?

1 Like

Unknown package 'luci'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~# opkg install luci

do an opkg update first. Most probably you are not connected to the internet or your networking isn't properly set up.

I’ve tried this (the image you mention) this week, but have issues. Link leds don’t work, wifi seems not to work. Can’t update because I can get access to my RGW. Eth0 should use DHCP os I can connect to internet. Documentation is extremely weak on how to configure using command line.
One pointers on how to change eth0 port to become a WAN port and how to get wifi to work? Just to confirm I’m talking about pi 3B+

1 Like

Regarding Pi 3b+ I'd appreciate if anyone can clarify how to get the wifi country code to work. According to the instructions: "you do need to set/change the country code in the latest Raspbian, and then you can go back to OpenWrt". I can set country code and run wifi successfully with Raspbian but what does it mean to go back to OpenWrt? Does it mean to power down RPi, change SD card to one that is running OpenWrt, then power on again?

guys, do not bother with trying to set country code, the issue is with the brcmfmac driver.
I solved the issue with getting the firmware files from the latest snapshot, copied over to running latest stable version (18.06.5 - kernel 4.9.198) and restarted wifi, all is working now and using mode '11a' with no other issues.
here is the list of steps:

  1. download snapshot (mine is the latest frm Nov 26 - r11595-5d2a900163)
  2. mount it via loop device
    fdisk -l <img_file>, shows the 2 partitions, get the start block number for the 2nd partition
    calculate the offset, multiply number by 512
    in my case it was 75497472
    mount -o loop,offset=75497472 <img_file> /mnt
    scp lib/firmware/brcm dir to the running system
    remove /etc/config/wireless, if there is any in your running system
    reboot (or use uci commit wireless and wifi), phy0 and wlan0 will be created just fine, check dmesg and wireless/network etc files and continue setting up your system
    happy 'wrt-ing'!