18.06.4:Serious 'LED' Problems! (TD-W8970 v1)

I have a TP-Link TD-w8970 v1. In 18.06.2 we have some problem about wifi LED(See this and bugs).
But after upgrading to 18.06.4, I face down with new LED Problem! When PPP Link established and Internet connected, the Internet LED does not Light up!
The LED's are really important to me. please let me know how to fix this by my self! I cannot report it and wait for next few months for patch, again!
Update: It's a real mess :neutral_face: The LED function completely ruined! right now, I miss all LED's(except power and lan).

Don't panic. Post your /etc/config/system and we'll see what we can do.

1 Like

Thank's a lot! this is my /etc/config/system file content.

config system
	option hostname 'OpenWrt'
	option ttylogin '0'
	option log_size '64'
	option urandom_seed '0'
	option zonename ''
	option timezone ''
	option log_proto 'udp'
	option conloglevel '8'
	option cronloglevel '8'

config timeserver 'ntp'
	option enabled '1'
	list server '0.openwrt.pool.ntp.org'
	list server '1.openwrt.pool.ntp.org'
	list server '2.openwrt.pool.ntp.org'
	list server '3.openwrt.pool.ntp.org'

config led 'led_wifi'
	option name 'wifi'
	option sysfs 'tdw89x0:green:wifi'
	option trigger 'phy0radio'
	option default '0'

config led 'led_usb'
	option name 'usb'
	option sysfs 'tdw89x0:green:usb'
	option interval '50'
	option default '0'
	option trigger 'none'

config led 'led_usb2'
	option name 'usb2'
	option sysfs 'tdw89x0:green:usb2'
	option interval '50'
	option default '0'
	option trigger 'none'

config led 'led_dsl'
	option name 'dsl'
	option sysfs 'tdw89x0:green:dsl'
	option trigger 'none'
	option default '0'

config led 'led_internet'
	option name 'internet'
	option sysfs 'tdw89x0:green:internet'
	option trigger 'netdev'
	option mode 'link tx rx'
	option dev 'pppoe-wan'
	option default '0'

You have a few default '0' in there that are unnecessary, and I'm pretty sure the trigger 'none' on the DSL LED prevents it from working correctly.

Here's my LED config for my TD-W8980, pretty much default except for the internet LED I tied to the pppoe netdev. Maybe you want to swap them out wholesale and reboot, see if that helps:

config led 'led_wifi'
        option name 'wifi'
        option sysfs 'tdw89x0:green:wifi'
        option trigger 'phy0tpt'

config led 'led_usb'
        option name 'usb'
        option sysfs 'tdw89x0:green:usb'
        option trigger 'usbdev'
        option interval '50'
        option dev '1-1'

config led 'led_usb2'
        option name 'usb2'
        option sysfs 'tdw89x0:green:usb2'
        option trigger 'usbdev'
        option interval '50'
        option dev '2-1'

config led 'led_dsl'
        option name 'dsl'
        option sysfs 'tdw89x0:green:dsl'
        option default '0'

config led 'led_internet'
        option name 'internet'
        option sysfs 'tdw89x0:green:internet'
        option trigger 'netdev'
        option mode 'link tx rx'
        option dev 'pppoe-wan'
1 Like

This is my current /etc/config/system file state:

config led 'led_wifi'
	option name 'wifi'
	option sysfs 'tdw89x0:green:wifi'
	option trigger 'phy0tpt'
	option default '0'

config led 'led_usb'
	option name 'usb'
	option sysfs 'tdw89x0:green:usb'
	option interval '50'
	option default '0'
	option trigger 'none'

config led 'led_usb2'
	option name 'usb2'
	option sysfs 'tdw89x0:green:usb2'
	option interval '50'
	option default '0'
	option trigger 'none'

config led 'led_dsl'
	option name 'dsl'
	option sysfs 'tdw89x0:green:dsl'
	option default '0'
	option trigger 'netdev'
	option dev 'dsl0'
	option mode 'link'

config led 'led_internet'
	option name 'internet'
	option sysfs 'tdw89x0:green:internet'
	option trigger 'netdev'
	option dev 'pppoe-wan'
	option mode 'link tx rx'

I try so many times and change that parameters several times. I pretty sure this settings are correct, because if you reload the led script manually after connecting to the internet, you can solve the problem temporarily(until next reboot).
I believe that the trigger of led_internet runs in the wrong time, and I have to run it manually by /etc/init.d/led reload command.

There are already open bugs for the internet (or rather ppp netdev) LED no longer working at FS#2193 and duplicate FS#2239 which appear to be due to changes in commit.

2 Likes

Is there anyway to fix this problem now? I mean like installing update or path or something?
I have to wait until next stable release of OpenWrt?
ps: I don't know much about the networking or Linux OS. if I knew it, then I try to fix it by myself.

You could try the following workaround. See if the following gets the internet LED working by SSH'ng to the router and running (double check the path, it might not be under gpio-leds on your router);

echo pppoe-wan > /sys/devices/platform/gpio-leds/leds/tdw89x0:green:internet/device_name

If successful, add a cron job with this that runs every 15 minutes.

1 Like

In extreme cases, that would delay the LED coming on for as much as, well, 15 minutes. A simple script in /etc/hotplug.d/iface that reacts to WAN ifup events (for example, name it 30-wanled) would do it better:

#!/bin/sh
[ "$ACTION" = ifup -a "$INTERFACE" = wan ] || exit 0
# untested, not all of the below might be necessary (but none of it can hurt)
echo "netdev" > /sys/class/leds/tdw89x0:green:internet/trigger
echo "pppoe-wan" > /sys/class/leds/tdw89x0:green:internet/device_name
echo "link rx tx" > /sys/class/leds/tdw89x0:green:internet/mode
2 Likes