18.06.2 rtn16 wifi broadcom-wl

Hi, I have flashed my rt-n16 on openwrt and I have problems with wifi, tell me how to enable logs to set up wifi session? (There is nothing in the logread, option log_level '0' does not work) After flashing, my laptop (windows) does not connect and the phone on the android connects. Tell me how to find the problem?
My config
root@Router:~# cat /etc/config/wireless
config wifi-device 'wl0'
option type 'broadcom'
option txantenna '3'
option rxantenna '3'
option txpower '20'
option log_level '0'
option channel '6'
option country 'DE'
option hwmode '11gn'
option htmode 'HT40'

config wifi-iface
option device 'wl0'
option network 'lan'
option mode 'ap'
option ssid 'point'
option key 'passw'
option wmm '1'
option encryption 'psk2+ccmp'

I'm almost certain this is an invalid setting for a Broadcom device.

https://openwrt.org/toh/hwdata/asus/asus_rt-n16
https://openwrt.org/meta/infobox/broadcom_wifi#infobox_for_dataentries

yes you are right, but I have already corrected the config (I mistakenly posted the old config) I tried 11n and 11g and 11ng and ht20 and ht40 and wl chains to increase the range The result does not change unfortunately

I really think you should understand the links above providing warnings regarding your Broadcom WiFi device.

Also see: https://openwrt.org/meta/infobox/broadcom_wifi

I suggest a fully-supported device for better improvement in WiFi.

To be clear, most of those settings are invalid as well.

I have the same situation with RT-N16. The proprietary driver on OpenWRT does not work. On LEDE, the proprietary driver works great.

Can you better explain what this means.

  • Are you saying some driver works in different versions of OpenWrt/LEDE?
  • What proprietary driver are you talking about?!?!

The kmod-brcm-wl or "wl" driver.

1 Like

I don't know which ones don't work, but according to the wiki, you need to install “kmod-brcm-wl” and “wl”, also “wlc” and “nas”.

everyone has a rt-n16, vote

https://bugs.openwrt.org/index.php?do=details&task_id=2139

1 Like

The number of "votes" don't really have any influence on 'if' or 'when' or at which 'urgency' a bug is tackled (it's a default feature of flyspray, which isn't easy to disable, but isn't used/ considered by OpenWrt).

I have the same issues. No one action helped me..
Did you solve them?

I found the way to use proprietary kmod-brcm-wl on openwrt 19.07.2.
Basically we need add one disabled wifi-iface at the end of config:

Details:

1 Like