18.06.2 No improvement in 5Ghz wireless on ACM3200

Hi,
Just installed the new version of OpenWrt and there's no improvement. Neither a phone or a raspberry pi will connect over 5Ghz.

Could anyone check if there's a problem with my config, I'm trying to connect to bigwideworld. I not really sure why the radio2 exists, but as it was there
config wifi-before, I've left it. The idea is to have 5Ghz for my external DMZ and reserve 2.4Ghz for the internal service
Thanks
James

device 'radio0'
       option type 'mac80211'
       option channel '36'
       option hwmode '11a'
       option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
       option htmode 'VHT80'
        option country 'GB'
       option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'bigwideworld'
        option encryption 'psk2+ccmp'
        option key 'test'
        option network 'DMZ'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option country '00'
        option legacy_rates '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key 'blanked_greyarea'
        option ssid 'greyarea'
        option network 'lan'

config wifi-device 'radio2'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option htmode 'VHT80'
        option channel '153'
        option country 'US'
        option legacy_rates '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key 'blanked'
        option ssid 'wtf'
        option disabled '1'
        option network 'lan'

I'd say radio 2 is causing you the trouble due to conflicted country codes.
Do as the git says, and remove radio 2 (particularly if you have no use for it).

Note for DFS of WRT3200ACM (88W8964):

All WRT3200ACM devices are programmed with device power table. Mwlwifi driver will base on region code to set country code for your device and it will not allow you to change country code. There are another wifi (phy2) on WRT3200ACM which is not mwlwifi. It will allow you to change country code. Under this case, country code setting will be conflicted and it will let DFS can't work.

There are two ways to resolve this problem:

Please don't change country code and let mwlwifi set it for you.

Remove phy2. Under this case, even though you change country code, mwlwifi will reject it. Because phy2 is not existed, country code setting won't be conflicted. To do this, run the following commands (for OpenWrt/LEDE):

opkg remove kmod-mwifiex-sdio
opkg remove mwifiex-sdio-firmware
reboot
1 Like

Use this command > rm -f /etc/config/wireless and wifi config to reset the wireless configuration. Then service network restart.

OK, done this; and it now works but only reports 6Mbps. Is that expected? I'm having a separate problem with the bridge so that clients on that wireless aren't getting a proper route and ip address?

There's a package called kmod-btmrvl, should I delete that too?
I've deleted the radio2 in the config too.

I'm having no luck setting the country on this router, it now thinks I'm in France, when I'm in the UK. The command "iw reg set GB" has no effect.

Thanks for the help

I'm not sure how that would help. I need one wifi for one interface and one for the other, this would just trash that.

I can’t help with the other issues, but the country region is locked on these routers. Attempting to change it will cause you plenty of trouble, and was why radio2 was causing havoc.

6mbps reporter speed doesn’t sound right. It reports speed fine for me.

This is what I usally do to make my 3200ACM behave on the wifi side:

opkg remove kmod-mwifiex-sdio mwifiex-sdio-firmware kmod-bluetooth kmod-btmrvl
reboot
rm -f /etc/config/wireless
wifi config > /etc/config/wireless
reboot

This removes support for radio2 and the bluetooth packages and then resets the wifi config to default without radio2 messing things up.

After that you can do your wifi config as usual, just don't touch the country code settings in any way.

If your unit is meant for europe it might not set the exact country code for the country you bought it in.

E.g. if you bought it in "germany" it might show "france". They seem to set a a country code that works for most countries even if it doesn't match. It should be fine tho.

The maintainer of the wifi driver said improvements for the country code issues are coming. But that was a quite some time ago. So don't expect them soon.

It might most likely be better for most people if those packages weren't included by default anyway.

No, if before sending the command to restart the network, you edit the wireless configuration file with the settings you want. It is not necessary to renicicar the router, only the network.