Topic: AR7 port - how do I get ADSL working?

I played a bit with Ti AR7 port on D-Link 504T device.

While basically it boots and works, I got the following issue: ADSL lamp blinks quickly and it appears there is at least attempts to establish DSL link? But I see no boot log or dmesg records anyhow related to ADSL nor I can see any interface related to ADSL, etc. How can I use DSL connection with AR7 port? Are there something special required to get it working? Any hints? Technically I need PPPoA, I do have proper VPI and VCI numbers and login and password but where to I have to supply all this? Are there some documentation describing this?

Re: AR7 port - how do I get ADSL working?

Please see this thread.
http://forum.openwrt.org/viewtopic.php?id=17161

Don't forget to install the sangam atm driver for your region (AnnexA for North America, etc.).

Re: AR7 port - how do I get ADSL working?

Very useful, thanks!

I have to admit that requirement to install something usually implies there is network is up and running. How can I install something if network is not operable? That's just like old pkunzip.zip joke - you need to download something for networking device over network while usually it is AR7 device who provides access to network and network is down if device can't provide access to network! smile. So, all needed packages SHOULD pre-exist in constructed firmware image - BEFORE I'm going to flash firmware.

As far as I know, in recent Kamikaze there is at least added ADSL Annex A firmware. I hope PPPoE and PPPoA also added - haven't tried myself recent Kamikaze yet since I had enough headache with recovery of AR7 device when it has turned out that I can't get network up and running with OpenWRT and device has been a "gateway" so I had no choice but to restore stock firmware to get network up and running.

Let's say is a bit PITA with their stupid ADAM2 boot loader (it had some compatibility issues so TFTP upload was aborted at the middle, etc). All this actually discourages testing Kamikaze on AR7 pretty much (I had 2 days of headache and internet downtime after attempt to test OpenWRT on my AR7 device).

Re: AR7 port - how do I get ADSL working?

Once you get it running it works really well, at least on my DSL-524t, i haven't seen a crash in months.
Building from source is a good way to include the necessary drivers, if you have the time and disk space.

Anyway, keeping another working modem around is very useful when playing with an AR7 wink

Re: AR7 port - how do I get ADSL working?

I'd like to install openwrt on my Dlink DSL-524T, but i found that the information on the old wiki a little confusing.

Have you some tips on how to upload the firmware on the router?
Building the firmware is not a problem.

Thanks!

6 (edited by Drone 2009-06-22 21:01:31)

Re: AR7 port - how do I get ADSL working?

> Anyway, keeping another working modem around is very useful when playing with an AR7 wink
I'm noticed this. And uhm, I should "type" these word in stone. Because when I had to fallback to original firmware (thanks to missing stuff), it has turned out ADAM2 had some compatibility issues with my OS (Ubuntu) on IP layer so TFTP upload rather looked like a Russian Roulette. Where I have to hit Zero sector, nothing more, nothing less. TFTP upload to ADAM2 usually stopped in the middle with high chances and only way to go was to "win" on this "roulette" (one try from 30 or so succeeded after all, uploading ALL data, he-he big_smile). Should I admit I hate this [bugged] ADAM2 stuff?

7 (edited by ath 2009-06-22 23:36:16)

Re: AR7 port - how do I get ADSL working?

AraKs wrote:

I'd like to install openwrt on my Dlink DSL-524T, but i found that the information on the old wiki a little confusing.

Have you some tips on how to upload the firmware on the router?

They are confusing, but the chances of bricking the router are pretty low (as long as you don't touch anything regarding the mtd2 partition with the bootloader)

1) find out the ADAM2 IP setting (mine was at 5.8.8.8 by default, you can login via telnet with the factory firmware and take a look in "/proc/ticfg/env" for "my_ipaddress")
2) reboot and use FTP to connect to the ADAM2 FTP server
    follow the instructions at http://oldwiki.openwrt.org/OpenWrtDocs(2f)Hardware(2f)D(2d)Link(2f)DSL(2d)524T.html under "Flashing the new firmware", "so... edit adam2"
    don't worry about calculating the partition values by hand, the ones shown in that guide should be ok. Don't touch anything that has "mtd2" in the name, though.

It will take a while to reflash it, it might seem stuck just after the "put" command before the trasnfer starts, just keep waiting for a few minutes. Note that there are strange interations between the bootloader and recent Linux kernels, so if the flashing procedure takes a really long time just keep retrying or try with a different OS.

Buona fortuna wink



Drone wrote:

it has turned out ADAM2 had some compatibility issues with my OS (Ubuntu) on IP layer so TFTP upload rather looked like a Russian Roulette.
[...]
Should I admit I hate this [bugged] ADAM2 stuff?

I've found that running ftp as root increases the chances considerably... it looks like ADAM2 has some TCP retransmission issues, but running FTP as root allows it to change some socket options that shorten the timeouts (don't ask me how, though...)

Re: AR7 port - how do I get ADSL working?

ath wrote:

Buona fortuna wink

It's been tricky repartitoining the mtd with adam2 but i was very "fortunato", and everything works now. I've got trunk r16776 running on Dlink DSL-524T.
This modem always used to be hot, but when i opened it i found that both the cpu and the switch were the hottest chip i've ever touched... Dlink, a couple of heatsink are too expensive?!

Anyway, the DSL line syncs but i've no ppp0 interface or anything like that... what i'm missing?

This is my ifconfig output:

root@DSL-524T:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:17:9A:B7:92:D6  
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  MThis is etric:1
          RX packets:347 errors:0 dropped:0 overruns:0 frame:0
          TX packets:234 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:27793 (27.1 KiB)  TX bytes:23129 (22.5 KiB)

eth0      Link encap:Ethernet  HWaddr 00:17:9A:B7:92:D6  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1041 errors:0 dropped:0 overruns:0 frame:0
          TX packets:698 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:80652 (78.7 KiB)  TX bytes:61456 (60.0 KiB)
          Interrupt:41 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:74 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4954 (4.8 KiB)  TX bytes:4954 (4.8 KiB)

dmesg:

...
registered device TI Avalanche SAR
Sangam detected
requesting firmware image "ar0700xx.bin"
firmware: requesting ar0700xx.bin
avsar firmware released
tn7dsl_set_modulation : Setting mode to 0xffff
Creating new root folder avalanche in the proc for the driver stats 
Texas Instruments ATM driver: version:[7.03.01.00]
DSL in Sync
...
root@DSL-524T:~# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
    lo:    8218     122    0    0    0     0          0         0     8218     122    0    0    0     0       0          0
  eth0:  208072    2510    0    0    0     0          0         0   289935    1972    0    0    0     0       0          0
  eth1:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
br-lan:   37575     534    0    0    0     0          0        23    78673     437    0    0    0     0       0          0

I tried to configure the wan interface with pppoa, but i don't know what to put under "ifname" option...
I hope it's some stupid thing i'm missing... and what eth1 is???

ath, thanks for the tips...
Bye

Re: AR7 port - how do I get ADSL working?

I got it working with PPPoE and encapsulation LLC, using this config file:

root@DSL-524T:~# cat /etc/config/network 

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'type' 'bridge'
    option 'ifname' 'eth0'
    option 'proto' 'static'
    option 'netmask' '255.255.255.0'
    option 'nat' '1'
    option 'ipaddr' '192.168.2.1'
    option 'macaddr' ''
    option 'ip6addr' ''
    option 'gateway' ''
    option 'ip6gw' ''
    option 'dns' ''

config atm-bridge
    option unit     0
    option encaps   llc
    option vpi      8
    option vci      35
                                
config interface wan
    option ifname   nas0
    option proto    pppoe
    option username aliceadsl
    option password aliceadsl

Should work for all the ADSL lines of Telecom Italia.

Mattia

Re: AR7 port - how do I get ADSL working?

To automatically start the internet connection at boot, modify the /etc/init.d/network script as it's done in the patch attached to this ticket:
https://dev.openwrt.org/ticket/2781
https://dev.openwrt.org/attachment/ticket/2781/01-ifup-wan-on-boot.patch

Now the router is fully functional wink

11

Re: AR7 port - how do I get ADSL working?

AraKs wrote:

This modem always used to be hot, but when i opened it i found that both the cpu and the switch were the hottest chip i've ever touched... Dlink, a couple of heatsink are too expensive?!

Pretty much every AR7-based D-Link modem runs hot, but there is probably some variance between different chips. My old 524t used to run at acceptable temperatures, but the new one I'm using now runs way hotter. Same model, same revision.

AraKs wrote:

ath, thanks for the tips...
Bye

You're welcome... nice to see another 524 running OpenWrt wink

AraKs wrote:

To automatically start the internet connection at boot, modify the /etc/init.d/network script as it's done in the patch attached to this ticket:
https://dev.openwrt.org/ticket/2781
https://dev.openwrt.org/attachment/ticket/2781/01-ifup-wan-on-boot.patch

Nice one, hoping to see it included soon. I used a dirty hack instead wink

12 (edited by AraKs 2010-03-15 20:52:03)

Re: AR7 port - how do I get ADSL working?

ath wrote:

Pretty much every AR7-based D-Link modem runs hot, but there is probably some variance between different chips. My old 524t used to run at acceptable temperatures, but the new one I'm using now runs way hotter. Same model, same revision.

I applied a small heatsink over the CPU... i hope it will help... you can find some pictures in my post:
http://www.aracne.name/linnotes/2009/07/openwrt-su-d-link-dsl-524t/